CTD after checking for updates

I am receiving a CTD without an error message whilst I’m loading after the checking for updates. I have reinstalled the game, deleted every folder related to FS2020, I do not have any mods or 3rd party apps in relation to this game I have been crashing since the xbox release. I’m not sure what else to do to get it to work, it’s 100% consistent each time I load the game so I have not been able to play since before the release. Any help would be appreciated.

Note: If I launch the game without being connected to the internet it works fine, however if I reconnect I crash

Same here, crashes during the “blue bar” loading of sim after “checking for updates.”. Same empty community folder, and did not have any CTD before SU5. Been happening through the SU5 and both hotfixes.

Also tried re-installing, no go.

I’ve found that if I wait until the mouse cursor goes away during loading (after the 50% mark, when the text appears on the background image of the XCub), and then I move the mouse and then hold and click until im in the Sim, it seems to prevent CTD. Not sure why.

Did you find a solution here?

Had the same issue, I could only start the game without being connected to internet. With the latest update (1.19.8) it seems to be fixed.

I’m still having this issue.

1 Like

Still having the issue as well, i’ve pretty much given up!

1 Like

same here since the update 5 … i can start the game offline but if i connect my ethernet cable the game crash

Same here. I have installed MSFS on two computers. Both behave the same. Both give the same error message. I’m thinking it has to do with something on a cloud save or something on Asobo or Mircrosoft’s end, not us the clients.

Haven’t been able to fly since world update 5. Only tried offline today, which works, but then you can’t download planes, airports, enjoy the much better graphics which is streamed from online…

I genuinely believe its on Asobo / Microsoft, (maybe even steam for me)

I did the whole disable and delete steam cloud save, still no fix
I tried to log into a different Microsoft account (in sim and ms store / xbox) still no fix

It either like some sort of file or something that’s corrupted in terms of connecting to the servers or the servers itself are literally crashing my sim

edit 1: it feels weird though that like If I disconnect the internet the game works as it should for the most part, most of my mods works fine and stuff but noooo, the moment I connect to the servers my sim gives up. lol

1 Like

Someone on a different flightsim forum encouraged me to try Family Sharing, so I made a new account and added it to my “family”.

I have two computers, both have had the same issue and exact same dll mentioned in the event viewer crashes. Had nothing to lose…

So I signed in on the second PC to try. What happened was it was as if I’ve never started flightsim before; it asked me about where to install content, what graphics settings I wanted to use, set up keyboard/mouse/joystick…

And I could download the world updates…

Bottom line is; I’m more and more confident that it’s my cloud stored profile that’s wrong/corrupt, than my hardware or software. That’s the only conclusion I can come to.

“It’s not me, it’s you.”

same issue here: [BUG LOGGED] CTD on loading - 100% reproducable - Account Issue

Installing the .net 5.0 hosting bundle 5.0.9 fixed the blue bar crash. Yesterday Windows Update installed 5.0.10 which brought back the CTD.

This all started after SU5… Previously I did not have to install the .net hosting bundle.

So after many reinstallations, many safe mode attempts, many graphics driver installs and nothing but automated responses from Support, I feel there is no fighting chance against this bug. I have narrowed it down to the “Online Functionality” which if you start the game in airplane mode, or not connected to the internet it’ll start up fine. As soon as you connect to their servers/turn on the online functionality, it’ll crash with no error message which doesn’t help to trace it down. I’m not sure if its an xbox service that MS2020 uses or if it’s a issue within MS2020 as an underlying issue, but for a reference I can launch any other Xbox crossplatform game no problem, the only issue is this game.

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?
MS STORE, 1.19.8.0

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
no
Are you using Developer Mode or made changes in it?
no
Brief description of the issue:
CTD right after checking for updates but before installation manager download of new wu6
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

Update via Windows Store to 1.19.8.0, launch app.

PC specs for those who want to assist (if not entered in your profile)
Dell XPS 15 9570 (laptop), gtx 1050 maxQ

Build Version # when you first started experiencing this issue:
1.19.8.0 wu6
Are you on the Steam or Microsoft Store version?
store.
Did you submit this to Zendesk? If so, what is your ticket #?
no

I’m having CTDs cockpit screens out on my Xbox series s

i have this same problem

Cant fly more then 20 min… CTD. PC all done as per instructions

Zendesk link: Game crashes to desktop after checking for updated and blue progress bar is nearly complete – Microsoft Flight Simulator Support (zendesk.com)

Microsoft Store version

Clean install, nothing in community folder

Welp, up until now, I’ve not had any persistent issues with the sim. Since yesterday, I’ve not been able to properly install the dang sim. It’ll CTD after it checks for updates, and the blue progress bar is about to be finished loading. CTD. I’ve downloaded almost a terabyte of data for the game since yesterday trying to get this resolved.

Take note, the game was installed and playing just fine. I uninstalled the game, put a new ssd in, and also upgraded my video card. I installed a 3080ti from my previous 3080. SSD went from a 1TB 970 EVO PLUS to a 2TB 980 Pro. All other games installed to the new ssd are playing just fine.

Provide Screenshot(s)/video(s) of the issue encountered:
Microsoft Flight Simulator Crash to Desktop (clean install) PC Windows Store Version - YouTube

Detail steps to reproduce the issue encountered:
Installed restarted pc, start game ctd, uninstalled, reboot pc, repeated 6 times now.

PC specs for those who want to assist (if not entered in your profile)
Ryzen 7 5800x
64GB Gskill 3600 DDR4 RAM
Gigabyte x570 Pro Wifi motherboard
Samsung 2TB 980 Pro ssd
Samsung 1TB 970 EVO PLUS

Build Version # when you first started experiencing this issue:
Latest release

Are you on the Steam or Microsoft Store version?
Microsoft Store

Sign out from xbox app.
Sign out from microsoft store app
Restart PC

Sign in to microsoft store app
Update all apps.

Sign in to xbox app.

Launch msfs.

I am having the exact same problem as of today. I have a i7-9700k with a 2080 super and 32GB ram. 500GB nvme ssd. MSI z390 pro motherboard. MSFS 2020 from Microsoft store. Will try what was mentioned above by F34…PER.