CTD after CTD after CTD...repeat

Obviously your RAM speed is the cause, not the sim.

XMP causing CTDs is common, particularly with certain Intel cpus like the 9700k that tend to rise very sharply in temperature. Sometimes it is better to leave the RAM running at a lower speed, and overclocking the CPU instead. You could also underclock the CPU and enable XMP. Whatever you do, you should always check stability with a program such as CPUID Powermax.

Ditto…Tried everything…no luck, very inconsistent. I get it at a remote airport but CTD at mega airports


My CTD’s are very strange and it has nothing to do with hardware or settings because it started after the last update. Just had a NVIDIA driver update today and that didn’t help either. I can fly with no issues BUT ONLY in certain airports of the world. For example I can load up fine at St. Barthelemy but if I try to load up in San Juan PR it crashes. Same with Mexico some airports load and others crash, these are not add on airports. I’ve tried everything and submitted a report to Zendesk.


That’s not a software problem, it’s a hardware one, then.
You should edit your first post and admit the rant against Asobo is unfounded.


Exactly the same here…Hope a new update will solve this soon

I got random midflight CTD after patch 5 too, no CTD never before patch 5, HDR is on. Sounds get looped in 1sec and CTD without errormessage.

can all the same a problem specifically with your iron? Since the release of the simulator, not one CTD, not one at all.

I’ve been pretty luck up until now but recently, particularly in longer flights (TDM930, flights of 2 hrs+) the game will CTD. This morning I got up at 5:30am to fly an OnAir job (because most OnAir jobs aren’t Europe-friendly) and CTD’d three times towards the end of the run, to a point that OnAir wouldn’t resume the flight. Frustrating.

Might be relavant: This morning there was pretty heavy weather (thunderstorms in the NW of the UK). I noticed a huge frame-rate reduction prior to the CTDs this morning.

I’ve been trying to actually get ctd myself by overclocking to see what error sim throws in event log to compare with others and send to Asobo, but i can’t get my sim to ctd no matter what. My memory is xmp enabled to 3000MHz and i have such profile selected in bios. I’ve never experienced a ctd.

You guys need to send windows event log error. This is very strange, but what can you do when theres thousands of configurations oht there.

I have:
Ryzen 5 1600 stock speeds (overclock = no ctd)
32GB RAM DDR4 3000MHz + XMP Profile
RTX 2070 Super 8GB + overclock, no ctd
Windows 10 2004

My ram is 3600mhz , currently running on 2133mhz due to the fact when I went into BIOS I selected XMP to get my ram at 3600mhz. Sim CTD 5 times.
Even my webpage was going on and off. @Jokabaku

What’s OnAir?

@Camargo24, I was running FS2020 since August with XMP @3600 without a single cdt.

I also have oc in my proc (3800x) and gpu (2080 super)

Yesterday I installed 2 extra memory modules to add up to 64 gigs, the same spec from the first 2, all using XMP.

Needless to say that I had 10 CDTs in a row.

After spending multiple hours investigating, I noticed that swapping the modules int the slots solved the problem and I was able to fly for 2 hours without any issues.

My suggestion is to give it a try because running without XMP really impacts your memory performance…

Also, I increased the voltages just a tiny bit (1.37 v) for stability.

Wow. I also have 64gb of ram 3600mhz.
So what you’re saying is that you took out the sticks and moved them around on the mob?
Also, did you manually set up your speed and voltage in bios or did you selected the XMP profile? @Djorous

Yes, just swap them around. Tried several combinations.

I used the xmp profile, nothing manual, but I found in my bios an option to manually increase only the voltage and that is it.

I tried many apps and games but fs2020 is the only one failing due to xmp, so you need to use it as your benchmark.

Can you send me a screenshot to see where you manually changed the voltage?

So you haven’t had any CTD after all this?

Fixed my issue for those interested. I had previously removed my GPU overclock from MSI (or thought I had) but it seems I also needed to delete all files in my MSI/profiles folder by the looks of it. Just done this and the Sim fired up fine and into a flight. A deeper dive into Event Viewer was pointing to a possible NV issue.
I used MSI for a boost in VR for XP, not sure why it kills MSFS, probably not stable enough if applied. Anyway you live and learn :+1:

No CTDs after the changes.
I will set a flight and let it run the whole day to be sure (I set a heading to cross europe in low altitude and leave it flying with everything maxed to stress the system)

I need to be online for work now, but in a couple of hours I will be able to go downstairs and get the screenshot for you.

My mobo is an Asus X570 TUF.

Edit: Forgot to mention that yesterday I also formated my pc just to be sure that nothing else was causing the cdts.

I reverted my bios settings back to auto and no CTDs. The only bad thing is that my ram went back to 2133mhz.
Please help !!! I’m not a computer genius so I really don’t wanna start moving things around inside the bios and break something.

I really think that what did the trick for me was moving the mem modules around, and not the changes in my bios.

Hardware is finicky sometimes.

I would suggest simply switching them and re-enabling XMP.

Said that, my mobo don’t like to have the memories switched and every time I had to do it, it got stuck and I had to clear the CMOS with a jumper :frowning:

Never had this kind of problem before with other models, but it might be because of those fancy OC settings, so you might get stuck too.

Nothing to worry, just extra steps.

Okay what? Lol.
I think I’m just not going to move anything around and leave them as they are and mess with the bios.
I mean is the gameplay a big difference in msfs2020 overclocking the ram?