CTD after newest sdk update

hello all,

I have just updated to the newest SDK version to see if I can add or explore the newest airport lights to my project. Unfortunately, every single time I try to load my project in the editor, I get a CTD immediately after I click “load in editor”. I have tried reinstalling the SDK, disabling my anti-virus, and removing everything from my community folder. Any thoughts?

1 Like

Yes, known problem, if the airport contains ProjectedMesh, it will CTD in the editor. You can fix it by removing them manually from the airport XML file, but of course you’ll lose the projected meshes, because even if you add them back, you’ll get again a file that cannot be opened on the next session.

And, even if you compile the scenery externally with the fspackagetool, the resulting .BGL won’t show all your projected meshes anyway, some ( or all ) of them might not show, because the compiled .BGL has duplicate guids and coordinates for them instead of the correct data you put in the XML, the same XML compiled with the previous version of the sim ( remember, it’s not the SDK that compiles the sim, it’s the simulator itself ) will generate a correct XML.

Yes, we notified Asobo about this, and the other problem of Light Rows not working properly too.


i guess i’ll wait for a fix then. MY airport does have a TON of projected mesh. Thank you Umberto

Other than the regression to a purple color, what issues are you having with Light Rows? Seems like SDK 10 and have fixed them for me.

I just -always- CTD if I try to click the new Scenery Editor button functions (blue circle or checkbox square) a 2nd time before allowing the sim to redraw. Click - wait, click seems to be ok.

Noticed if I comment out the projected meshes in the xml file it loads in the scenery editor ok. If I uncomment one projected mesh it also loads ok. But if I uncomment more than one projected mesh it causes CTD when clicking “load in editor”.

But in the previous version, everything was fine. ASOBO only messed up the latest version? I tried with new and previous versions of SDK, but the result is the same.

The only solution I’ve found so far is to slightly change one last digit of the coordinates. This is not the best solution, but it works.

1 Like

Does it worked for multiple projected meshes?

I checked for two and three projected meshes.

1 Like

This seems to due to the fact that changing the file slightly would trigger some kind of refresh//recompile of the files ( most likely something in the _PackageInt folder ) but, have you then tried if the compiled scenery will then work in the Community folder and show all your ProjectedMesh ?

Because, even if you manage to fix the CTD on load, if you recompile the scenery, it doesn’t create a proper .BGL, meaning some of the Projected Meshes will not be shown, because in the .BGL ( at the binary level ) they are misplaced and with GUID conflicts, the .BGL compiled with this version of the sim/sdk doesn’t really match your .XML.

1 Like

I managed to correctly display two ProjectedMeshs from the community folder. When I added the third layer, I got the Sim freezing when loading the airport.

I cannot yet figure out the dependency of the successful compilation of the file. But sometimes the build goes fine.

Try this:

  1. Delete all ProjectedMesh entries in .XML
  2. Enter the editor, re-add ProjectedMesh and change the last digit of one of the coordinates to make the meshes different.
  3. Save your scene and compile .bgl
  4. Close the simulator, put the scene in your community folder and upload your airport.
  5. So far, everything is bad and I see one layer.
  6. Now load the scene again in the editor. (community folder with your scene too)
  7. Compile .bgl again
  8. Close the simulator and replace the scene in the community folder with a new one.
    After these unpleasant manipulations, I see the Projected Meshes correctly.

Oh wow. That does sound like a lot of work. Now i’m oretty new at this and my airport easily has over 60 projected meshes in it. Because i am new, my technique has not been the most practical. This means that most of my meshes weren’t only placed and rotated, they had to be scaled and i did some of them in sections so readding them will take many hours. I firmly believe asobo needs to fix this. Thanks for finding this out!!

Where exactly is this .xml file located? Are the entries called: ProjectedMesh?

This issue needs a fix asap.

Seems that this new SDK is really giving problems. Cannot export from Blender2msfs toolkit with the sdk open, build failures.
Cannot duplicate painted lines, and cannot duplicate apron textures or add a new texture with the sdk open without the whole package failing on build

I don’t have any ProjectedMesh in my project and I am also getting a CTD. Started when I finished updating the Light Row placements at one of my remade airports. Saved the project, went to build it, and CTD. Can’t open the project since. Any ideas?

Could it have something to do with now when we “Duplicate” it creates a “copy” of the item? Or perhaps the new grouping system?

Seems like with each “update” to the SDK, there are new bugs.

I had this issue as well, it most certainly has to do with Duplication and creating copies. Every time you duplicate anything, the duplicated item automatically gets the display name (copy) if you duplicate this copied item again the new item will be named (copy)(copy) and this goes on and on and on as you duplicate. If you have enough of these your project will CTD when trying to compile and will also CTD when trying to open the project.

The solution, if you can open your project is to delete the (copy) from the display name under properties every time you duplicate something. In your case its a bit more complicated since you can’t open the project. You will need to go into your .xml file in the scene folder and manually delete every displayName= “(copy)” in that file. This should fix your project without deleting anything. Please make sure to make a back up version before you attempt this.


Awesome. Removed that allowed me to open up my project and retain my work. Thank you!

1 Like