CTD after the black Shark splash screen

Hi,
I’ve been using MSFS since release, really enjoying it. Experienced a problem this morning that I cannot seem to resolve.

I bought the premium deluxe version on steam, and this morning while trying to launch the sim, it Crashed to desktop just after the black shark splash screen.

A little history in case it might be relevent. I bought a new m.2 ssd and used the steam client to move the game to the new drive. This was last thursday, and it has been working fine until this morning.

I tried disabling windows defender as per a solution I saw in a similar thread but that did not resolve the problem for me. I get no error messages and do not know what to try next. I have already tried deleting local files and re-installing the game. Using steam interface to do these tasks, but the same fault persists. It will not get past the S.A.R.L message after Black Shark screen.

Please Help !

2 Likes

Are you running the latest version?

Just as a diagnostic step, can you unplug all controllers, excerpt mouse/keyboard, then try launching again to see if it will get past that point?

Yes, and it was working fine last night.

Also I tried re-installing MSFS this morning.

Nvidia drivers and MB drivers are up to date, but the problem persists

Removing the controllers before starting up didn’t help, then?

On the previous patch, before the hotfix, some uses with custom controller profiles, so called “null” profiles with no bindings, were getting crashes.

I just wanted to rule that out for you, as the problem went away when no related controllers were plugged in.

No it did not help. I also just continued a mission in my IL2 career. Peripherals were working as expected.
If any of you enjoy flying in VR, and have not yet tried IL2 Great Battles series of games, then I can highly reccomend it.

My MSFS problem is crashing before you get to the welcome screen where it checks for updates. Also remember this is a new install, after having removed the local files in an attempt to resolve the problem.

excactly same thingh for me … !!!

I’ts old solution.

Open microsoft store and update gaming services app. On the upper right corner click 3 dots select download and updates -> get updates.

Thank you for the reply. I bought the game through steam and not the microsoft store. So far as the microsoft store is concerned I do not own the game.

It doesn’t matter.
Update gaminng services app, xbox app ect.

Ah I see, I have updated them and ensured that the services are set to automatic, this did not help

I updated all from the 3 dots just now, and it updated skype and one note. Nothing else

I also problem, already all options list above and nothing. Help me please. Already reinstal MSFS2020 and nothing too.

Maybe if we didn’t vote for the “press any key” removal we wouldn’t have these CTDs

well To be honest the press any key was kind of pointless, especially before the game has finished updating and loading.

But one solution I saw from a while ago was to not press any key for something like 30 minutes. Obviously impossible now, and I hope whatever the problem is, is not dependent on that.

Really gutted that for now I cannot seem to get it working

We now get a black screen that takes around 30 seconds before it goes to the Japan splash screens.

The press any key wasn’t needed but to be honest I had no problem with it either. Press a ■■■■ key and you’re good to go.

Made a quick vid showing the xbox app logged in, and the microsoft store being fully updated before launching MSFS, so you can see the point at where the CTD happens

Never had this issue. Have you tried emptying out your community folder?
Logged off Xbox game pass and back on?
Disable firewall?

I have a custom folder where all of the packages go. I completely emptied it this morning. It still fails to launch as per the video above