CTD amd 6800xt 6900xt, it's been 5 months now

From about january, if you use VR with radeon 6800xt or radeon 6900xt the game CTD. Always. Sometimes after 5 minutes, other times after 30 minutes. We have people in the forum that tried over 100 ( ONE HUNDRED SOLUTIONS OR TWEAKS) with no succes. Drivers, underclocks, complete windows reinstalls, openxr, steamvr, low settings, it will clockwork CTD.

Steps to reproduce: play the game in vr with those videocards. The less fps you get the faster it crashes.

Are amd users a joke to you ASOBO? Doesn’t xbox use amd navi? This CTD persists afaik from january. What the actual hell is happening, does no one care about vr and the top amd cards currently released?

CAN AT LEAST SOME OFFICIAL FROM ASOBO ACKNOWLEDGE THE PROBLEM? Because in the livestream you were chicken and deflected and ignored this specific problem.

Ya same here. I went from a Radeon vi with no problems at all to this 6900xt and get nothing but CTD what kind of ■■■■ is this

1 Like

Topic moved into #bugs-and-issues:virtual-reality

I was with you guys after upgrading my Vega64 to a 6800XT. while not using VR, I almost daily got a Driver Timeout Error with CTD. Since I rolled back to 20.11.2 driver, disabled Freesync, and changed FPS limit back to 60 from 30, I have not had a CTD since. That’s been around 3 weeks now with about 3-4 hours of sim time per day. I am not sure which one of those things made the difference and I am not going to change any of it back to find out.

@latotheX FYI: if you get driver timeout again you can solve it by going to settings–>system in adrenaline and disabling “issue detection”. It doesn’t mean you solved the underlying problem but at least the driver won’t time out.

Also, that driver version you recommended won’t work for 6900 xt. This card needs at least 20.12.1.

I can’t use anything past 21.3.2 (3/26/2021) with VR.

I am using the latest AMD driver 27.20.21003.8013 and the VR crash with OpenXR is especially bad. I tried absolutely everything from downgrading driver to last year’s version up to newest, tried all fresh install of MSFS and Windows, all to no avail.
It’s very bad when I replay Nevada Bush Trip, I couldn’t get a single leg done with VR. If I quit WMR and play 2D, I have no problem whatsoever.
Currently, I am testing SteamVR, I had some success with it, but performance wise it’s inferior to OpenXR.
I’ll come back and update for the SteamVR result.

P.S. But using SteamVR introduce a lot of stutters, especially in the cockpit. The worse thing is that both of my CPU/GPU are under utilized, CPU main tread running at 70% and GPU 70% to 85%. I wonder how could I make them work harder in SteamVR!

Yes, only issues since I bought my 6900XT card… always CTD and no fixing neither from Asobo or AMD (whoever belongs to).

They have our money already, why would they care? It’s not like a subscription where we can walk away and punish them sadly.

Sadly I’m having the same issue. It would crash at 2-5 min in a flight or before loading in. When I set my page space to system managed I successfully stay in game for about 15-30 min now. However, it’s really odd that when I play the game I get GREAT performance even at 150 render scale then BOOM, deaded. Seems to be RAM related, or AMD driver since I get a driver error in event viewer as well as a bug report pop up from Radeon Software. Here is a few things that I’ve done. Running VR default with render scale set to 130.

  1. Disable rolling cache
  2. Disable Azure voice for traffic control
  3. Set page space to system managed in msconfig
  4. Re-installed the game
  5. Rolled back AMD drivers to the one in Jan? I think? I’d have to confirm
  6. Set the render scale to 80
  7. Disable any features in Radeon software

Last thing on my list is to undervolt the GPU but I don’t see why it shouldn’t work at stock since I paid 2100 for a 6900 XT. I’m sure there’s some sort of code issue between the game and AMD driver but I’m not sure what! It’s for the devs to find out I suppose!! :stuck_out_tongue:

Either way, let’s hope this gets resolved soon because the moments I do have in VR are incredible and the best/optimized simulator I’ve seen to date imho. I play DCS world mostly and it ain’t even half as beautiful as this game.

Set up:

Odyssey+
3700X
6900 XT
X370
16 GB CL14 RAM
RM850X PSU
average temps: 75-80C on GPU and 50-60 CPU
Bottlneck according to dev FPS: “Limited by GPU” mostly…

1 Like

Can someone try this out with a 6800XT or 6900XT and let me know if you get a crash?

Hoping the next amd driver 21.6.1 fixes the crashing.

@Corei7rocks Surely that would only be relevant to people using ReLive and not everybody else that’s experiencing CTD in VR without recording…

@AltamiraDan

You may be correct. But after doing a little investigating with my quest 2 and Sapphire 6900XT SE using Radeon drive 21.4.1 keeping the 72hz and recommended locked or 80hz recommended lock or 90hz recommended lock I’ve not had a single crash in VR.

However I have had a few pauses with the hour glass for 2 - 10 seconds at different times but it didn’t crash to desktop as it did with unlocking the recommended setting.

I have an opportunity to purchase a 600XT at MSRP. A large chunk of my “gaming” involves FS2020. Threads like these make me a little queasy about upgrading.

It would be an even upgrade monetary wise (from a 1080ti, since they sell for $700+). However, IF i encounter this same frustration, the “upgrade” would be a considerable downgrade in my opinion.

So has this problem been sorted out with current drivers, I see a lot of conflicting info.

I’ve not had a CTD with my 1080Ti since the launch days. It’s been stable for past 3-4 months. I do plan on using VR, that’s why I want the little more oomph in my GPU.

Other option is to Of course wait out this whole GPU nonsense. Also I want to add that buying 6800XT for my own personal gains is NOT an option. The person is an extremely good friend and is selling to me for what he paid, I would NEVER do that to him.

Thoughts?

@dundermiffpaper I paid €1300 for my Rx6800xt, great card… works very well with everything else I use it for, upgraded for MSFS from RTX2080 Super. If I had the chance to go back and rethink my purchase, I’d buy an Nvidia card AMD Drivers are too flaky I’m also using with a Reverb G2 and it doesn’t really seem to be a good mix at the moment, as in MSFS, RX6800xt, and the G2

Agh. I’ve been an nVidia user since the GTX 600 series. The ONLY reason I never went to ATI/AMD was because of it’s consistent driver issues (Especially with MFS products). from what you describe, not much has changed. I’ve said that ATI/AMD’s downfall has ALWAYS been it’s drivers, not hardware and it sucks that it still holds true to day.

Dang it, I really wanted to act on this rare opportunity to upgrade at, God forbid, MSRP prices.

I appreciate your honesty and input into this. Sucks because 2080Super was still a nice card for MSFS. Hope you’re enjoying the 6800XT elsewhere to make up for it.

To be fair about amd drivers, the only game that crashes in vr is MSFS.

Other games work perfectly in vr at 3kx3k per eye resolutions.

So i would not say it is a problem with amd drivers, but with priorities of MSFS developers.

Let’s not forget that this issue with MSFS and amd vr
ctd has been reported since january.

More than one guy that reported this bug with zendesk (also knows as let’s discourage users to report bugs by making it a complicated process) had received answers like “reinstall vcredist, reinstall windows, reinstall amd drivers” and then marked as solved, without feedback. This is blatantly disrespectful.

Asobo=Microsoft

MSFS quality assurance = Windows 10 quality assurance, releasing betas for consumer testing, constantly breaking stuff with every update, but in their mind they do a good job because “new features” and “checkboxes marked as solved”.

2 Likes

@lviuts Yeah very true Re: drivers & AMD My card is very stable with other Sims, but I did upgrade to use with MSFS, So really MS need to get the finger out and sort the problem… I was on to Zendesk told me to reinstall Visual C++ which I did and it didn’t make any difference Then they said to reset the PC so I wiped the SSD RE-installed Windows & MSFS still CTD. I got back on to them told them it didn’t work and they told me to uninstall Visual C++ and reinstall, then they said reinstall Windows eventually they just marked it as solved and disabled comments

I’ve pasted my own issues with Asobo as far as fixing things go Like this today. They definitely left all the problem solving up to Microsoft and that’s very apparent in how they deal with issues.

However, I can’t also ignore the fact that the users on the other side of the pond do not appear to have similar experience with these issues when using nVidia hardware. I could be wrong because I’ve just now started to delve into VR, thus my desire to upgrade GPU. Just my initial scan of the reporting tends to point to AMD more often than not.

Since I would be selling my 1080ti in order to recoup the cost of purchasing 6800XT… I’d be stuck with the 6800xt since buying another card to replace it would certainly be nearly impossible right now.

I’m leaning towards getting it and trying it out. If it doesn’t work out I can always just give it back to my friend as I don’t think he’d mind selling it to someone else at market value. At the same time, I’m not gonna lie, I’m also trying to capitalize on the 1080ti market value.

It’s a risk no matter what… Agh. ■■■■ you AMD/ASOBO or which ever of the two is at fault (I’m gonna say both since that’s the dreaded combo for FS2020).

Update #1

So I’ve done a few more things. Here’s what I’ve done extra and ACTUALLY super stable now. I even flew through London and I’m getting 60 frames within the cockpit and 90 outside of the cockpit.

  1. Reset my PC - full wipe
  2. Made sure that VR settings were all to “Let Windows Decide”
  3. Set virtual memory in advanced system settings to 16 X 1024 X1.5 = 24576 (min and max)
  4. overclocked my RAM to 16-16-16-36 timings. Instead of CL14 3200 mhz, it’s CL16 3600 mhz.
  5. Radeon Tuning - Auto - Default
  6. Turned off game mode, optimize fullscreens, game bar, game streaming and record voice in streaming settings as well

So far, I’ve gotten 2 hours in at 3 different locations, Toronto, Grand Canyon, and London. No CTD, not even black screen for 2 seconds.

My original post I disabled all settings in MSFS but they are all re-enabled and not causing issues (rolling cache, Azure traffic). VR settings are default + refresh high in cockpit and 150 render scale. AA is off or DLAA I can’t remember. OpenXR dev kit is NOT installed on my system.

I think the huge culprit here is RAM. This game just needs a S*** ton of it! I’ll check back in if I get more crashes.