CTD at game launch after WU5 - PC Version Deluxe Steam

I have the MSFS Deluxe version for PC via Steam.
While before my simu was working nominally, since the WU5 and also with the WU6, I systematically have a CTD at about 80% of the game launch.
After several uninstallations reinstallations of MSFS, the problem persists.
Several observations:

  • slow download via Steam (max 30 Mbits while I have a 300 Mbits/s fiber connection.
  • once installed, MSFS launches then switches to developer mode (while the SDK is not installed), the sound jumps and CTD

Translated with www.DeepL.com/Translator (free version)

J’ai la version MSFS Deluxe pour PC via Steam.
Alors qu’avant mon simu fonctionnait de façon nominale, depuis la WU5 et également avec la WU6, j’ai systématiquement un CTD à environ 80% du lancement du jeu.
Après plusieurs désinstallations/réinstallation de MSFS, le problème perdure.
Plusieurs observations:

  • lenteur du tĂ©lĂ©chargement via Steam (max 30 Mbits alors que j’au une connexion fibre Ă  300 Mbits/s.
  • une fois installĂ©, MSFS se lance puis bascule en mode dĂ©veloppeur (alors que le SDK n’est pas installĂ©), le son saute et CTD

Why wasting time?
It’s completely useless since Commodore 64.
Check if you have C1 or if new hotfix succeeded in not sideloading dll from other software.

Sorry but I don’t understand Commodore 64 and C1.

Same for me. I’m in touch with the support, will get back to you if I find a solution. Just a question, do you have a special character in you windows user name such as “é,è,&,…”?

No, no special characters in my windows username.
I am also in contact with Microsoft support but I only get generic messages unrelated to my bug!

what you tried from existing hints , what do we need not ask you again ?


I made sure that the community file was empty.
I uninstalled MSFS and STEAM and then ran CCleaner to remove any harmful dlls.
I reinstalled STEAM.
I reinstalled MSFS in an externalized folder without any problem. I did not install the SDK.
I launched MSFS which did the last WU 6 update.
When I launch the game, it switches to developer mode at some point without me asking it anything and without the SDK installed.
I then have the CTD at 80% of the launch, CTD preceded by a deterioration of the sound.

I also tested without the firewall (windows or Bitdefender). Same result.

Je me suis assuré que le dossier community était vide.
J’ai désinstallé MSFS et STEAM puis ai lancer CCleaner pour supprimer d’éventelles dll néfastes.
J’ai réinstallé STEAM.
J’ai réinstallé MSFS dans un dossier externalisé sans problème. Je n’ai pas installé le SDK.
J’ai lancé MSFS qui a bien fait la dernière mise à jour WU 6.
Lorsque je lance le jeu, il bascule à un moment en mode développeur sans que je ne lui ai rien demandé et alors que le SDK n’est pas installé.
J’ai ensuite le CTD à 80% du lancement, CTD précédé d’une détérioration du son.

J’ai testé également sans le pare-feu (windows ou Bitdefender). Même résultat.

some additional reasons for crashs at these phase may be:

  • login issues… try to relogin in xbox app, restart
  • sound-drivers/sound-tools , check nahimic and asus tool hints in forum ( in short words: deinstall asus sound tools, disable nahimic service )
  • in case you installed the game on a ext.drive, be sure its not formated in exFAT

Also check the windows event viewer for error message. May be we get a hint about the issue.

PS.: auto switching to Dev-Mode sounds strange

I bought MSFS via STEAM. Is the XBOX application really necessary?
The disk on which MSFS is installed is NTFS.
I’m looking to disable Realteck High Definition Audio Driver and Nahimic

J’ai acheté MSFS via STEAM. Du coup l’application XBOX est-elle vraiment nécessaire?
Le disque sur lequel MSFS est installé est bien en NTFS.
Je regarde pour désactiver Realteck High Definition Audio Driver et Nahimic

so far I know yes…

If you not use the MS-Gamebar stuff, I also recommend to disable all of these in windows settings.

may be first try to disable Nahimic, these is usually the “bad boy”…
Of course, try to find up2date sound-drivers is also allways a good idea, there are real horror stories about :wink:

I noticed the same issue - Windows Store version.

One out of five launch attempts end-up with a CTD. Just restarting the game works almost all of the time.

I started tracking the cause and it seems it’s a weak piece of code in the part that reads a configuration file. I’m collecting additional crash dumps to make sure it’s always the same error.

Annoying but not critical. Yet.

Realteck high definition audio driver removed. Still this CTD…
Not found Nahimic!

Pilote audio haute définition Realteck supprimé. Toujours ce CTD…
Pas trouvé Nahimic!

No Nahimic in the service window of my system configuration folder

Pas de Nahimic dans la fenêtre service de mon dossier configuration du système

hmmm… you searched within Windows “services” ?

if yes, its good that it not exist and we can assume there is no issue from this side :slight_smile:

So far I understood @StopHalfling310 correct, he mentioned the case where user settings files becomes invalid. I’am not sure whether this is the reason here, but it’s may be a try worth in case xbox re-login will not help. Unfortuanlity its bit more complex. I remember latest I mentioned it here:

Another test-run can may be to start the game Offline…

Nothing like Nahimic

The reinstallation of the XBOX application remains frozen on this screen…

In offline mode, same thing. It switches to developer mode and CTD around 80%.


I seen that I have currently only the older “Xbox Console Companion” App… so far I remember installed over the MS-Store.

a question… had you the developer mode “on” before the update ?

It is possible. I can’t remember. But in either case, shouldn’t a reinstall of MSFS restart the game in normal mode? Would there be something to empty on the Steam cloud?