CTD before main menu is loaded

You might want to try what is suggested in this topic:
https://forums.flightsimulator.com/t/crash-to-desktop-while-loading-flight-can-anyone-tell-me-what-this-means/508872 Deleting the exe.xml and content.xml files.

NOTE: A word of caution that deleting the exe.xml may not rebuild with all your addons. I would make a backup of that just in case.

Don’t know if this pertains to everyone but the NVidia update to 516.59 was causing CTDs on my system at the beginning or end of a flight, from/to main menu. I reverted to 516.40 and no more CTDs.

HTH

Make sure under Steam Properties you do not have Steam Cloud sync checked.

Log Name: Application
Source: Application Error
Date: 7/19/2022 9:47:29 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: DESKTOP-E3K293J
Description:
Faulting application name: FlightSimulator.exe, version: 1.26.5.0, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version: 1.26.5.0, time stamp: 0x00000000
Exception code: 0x80000003
Fault offset: 0x0000000001cbc4c2
Faulting process id: 0x44c8
Faulting application start time: 0x01d89beb42add11e
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Report Id: 2a740b50-28a9-469b-898b-a0fc94033885
Faulting package full name:
Faulting package-relative application ID:
Event Xml:



1000
0
2
100
0
0x80000000000000

2508


Application
DESKTOP-E3K293J



FlightSimulator.exe
1.26.5.0
00000000
FlightSimulator.exe
1.26.5.0
00000000
80000003
0000000001cbc4c2
44c8
01d89beb42add11e
C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
2a740b50-28a9-469b-898b-a0fc94033885





1 Like

deleted the two .xml files. seems to load for slightly longer but still crashes.

The error that you posted is: 0x80000003

Does a dialog pop up about a breakpoint error?

Forum search on that error code:
https://forums.flightsimulator.com/search?q=0x80000003

1 Like

There is no dialog box. Seems to be loading then just goes to desktop without any warning or announcements.

If you have anything in the community folder, move those out (or rename your community folder).

Completely emptied the community folder and renamed it. Still CTD in safe and normal mode in the same spot as before.

Is there a procedure to completely remove MSFS 2020 Steam and start from scratch?

I honestly don’t think that would fix it. If you want to try it and have a fast internet connection, there is an uninstall option. Any leftover folders you can manually delete. I’d make a backup of your community folder.

1 Like

before you start with re-install ( it takes long time ), can you give some infos about your system ?

Very often these “raw” code pointed to low memory ( not allways ). Did you own 16GIG RAM and how is your free disc space ?

Sometime it was also helpfull to remove the rolling-cache file.

I have already done the Steam Uninstall, then reinstalled the game. No difference.
Still open to every option. What’s your next suggestion?

thats because re-install not delete all files in AppData and thats why you sometime need to remove files manualy. But thats only if the issue is caused from eg. invalid files and not from e.g. mentioned low memory ( eg. insufficent pagefile ).

Very frustrated. Still open to suggestions.

now… may be you missed my former post… How much RAM you own and how much free space is on your disc ?

Users with 16GIG RAM must have a sufficent windows pagefile size and with low free disc space, windows can not create this and you must manually set a sufficent min:size.

But as mentined… Sometime also the RollingCache file can cause that.

You can also try to remove in %AppData%\Microsoft Flight Simulator the folders like DCE, SceneryIndex,SceneryCache, ( and if you not changed the default there is also the ROLLINGCACHE.CCC file )

And of course you can try without connected devices, in case you own many ( e.g. radiopanel, etc. )…

I have 32 gig of RAM. I have 263 GB of free space on a SSD Drive.
Something I failed to mention. The Sim worked fine until I installed SU 10 beta.
SU 10 worked fine, then this all started a couple of days later. I have since uninstalled SU 10 beta, but made no difference. Sorry that info is probably important.

2 Likes

:slight_smile: thats an important info and there is a topic about within the #sim-update-10-beta category

But then it is may be possible that a setting becomes corrupt and in worst case one from the cloud-save.

EDIT: but here the user reported, that reinstalling will help, but you have to remove manualy the whole %AppData%\Microsoft Flight Simulator folder after uninstall in Steam.

Topic moved into the Beta forum.

one additional note…

may be it is not necessary to un-install the whole game. You can simple try to remove that folder “%AppData%\Microsoft Flight Simulator” and start MSFS. At least is worth to try… if its work you not need to redownload whole game…

1 Like

During the big sim CTD weekend 20-23 august 2022, my MSFS also ended up in CTDs … But they went from CTD in the game to “CTD before main menu is loaded”
I made a post in the “Constants CTD every flight now…”

The error log, which I actually don’t understand was identified by Hester40MT as another kind of CTD and he asked me to post it here instead.

2
3
4