Ctd conditions ascertained and other bug

  1. When running msfs for the first time (after a boot), the following happens:

A. The weather is clear skies, no matter if it has been set to “live weather”. Even switching it in flight has no effect, clear sky remains. Switching to a premade weather theme or handcrafting it though, works fine.

B. The sim CTDs without any error code after a period varying from few seconds to few minutes after taking off.

  1. After CTD:

A. The sim is restarted. Now live weather works as intended, although some areas show lack of weather data.

B. Occurs rather often, that the sim CTDs again, in this case, at any time during final approach. This particular ctd appears to have a relation with using garmin equipped planes, while regular steam gauges ones seem less affected.

All the above started happening in the latest 2 releases.

After last update, it worked once - now it crashes to desktop all the times at about 80% into loading a flight.

I’ve been able to see a “WERfault” window for a second or two in one case.

Can someone be so kind to provide some assistance? the simulator is unusable for me at this moment.

What from the given hints from existing threads have you already tried ?
( we can not clairvoyance :wink: )

e.g.
Have you mods installed ? -> remove
Rolling Cache file already removed ?
What’s your system specifications ?
etc…

deleting the rolling cache file made it work - for one flight.

on loading the second, it crashed again with the following message.

fserr2

as for mods, i have none.
specs:

Intel i6700K @4.2 Ghz - 16GB DDR4 - Nvidia 1080 GTX - FS on Samsung Evo 512GB SSD - Win 10 x64 - 1G/bit Internet Connection @ ~ 980/200 Mbps - Samsung SMS24’’ @ 1920x1200 - Saitek X52 Pro Hotas - Logitech G13

have you already increased the Windows Virtual Memory ?
( e.g 4Gig Min and 20Gig Max , or simple a fixed value of Min/Max 20 , possible is also Max 30 )

Example Thread with images:

I’ve set the swap file between 4 and 32 GB, so far there’s been no more crashes.

I’m not sure weather is working as intended, but at least the sim works.

Thanks for your assistance.

it is at least a point for MSFS FAQ because nobody expect to do so if the minimun requirement of the game is 8Gig RAM.

Also the problem comes more on top since 1.12.13.0 .

PS.: please mark a post a “Solution” so that other users can find it :slight_smile:

of course. Sorry for doing that so late, I was rly busy these days.

Thanks again.