CTD every time I click

When I clck main screen it CTD


Same here. Every time I try to return to the main menu after a flight CTD.

Same deal. New with this update. CTD after every flight. From last patch, only Bush Trips did that. Now, every flight.

Same here. Only done it 3 times, but it’s 100% CTD so far.

So… this time, it didn’t CTD. Community folder was empty this time. Now it’s time to add things up little by little to see what’s causing it. I will add Bush Trips first, then Aircraft. Then the very little scenery I have in that folder. Gonna stay away from aircraft mods for now (though those have been removed prior to update)…

1 Like

Clear out your community folder and try again. It’s probably one of your mods conflicting with the sim after the patch.

1 Like

Also Delete the rolling Cache. It solved 2 CTD’s for me in the last update. Some say dont, I say what have you to lose?

UPDATE: I cleared all items form my community folder and it fixed the CTD. Some mod is causing this.

1 Like

what a surprise.

The first line in the patch notes is this:

Some packages in your community folder may not have been updated and, as a result, may have an unexpected impact on the title’s performance and behavior. Please move your community package(s) to another folder before relaunching the title if you suffer from stability issues or long loading times.


Well, usually the only mods I ran that would potentially cause issues are Aircraft mods (Working Title, etc)… Those would be removed prior to every patch and there were zero issues with all others - simply cause the others are payware aircraft and Bush Trips. I stay away from all freeware scenery.

So this one is a first. Like I said, gonna add them little by little and figure out what’s doing it.

heh, there have been numerous instances of 1 or 2 liveries crashing the sim after an update :slight_smile: So yeh, best to just clear out the entire folder, and then add them 1 by 1 (most useful first) and see what they do.

Personally, I’ve decided to just stay away from most mods for a couple of months. I have plenty of aircraft and an entire world to explore already. The couple of mods I do use are fairly easy to check on every patch day.

Yeah, I mean… I stay away from liveries like from fire because I have heard these horror stories and… well… I just don’t care.

But payware aircraft is different - I would hope those things would still work! But granted most of them ALSO come with multiple liveries, they may be causing issues too. I am gonna add the Bush Trips first cause those are least likely offenders. Aircraft will have to be one-by-one. And I have 4 that don’t live in official folder: Aermacchi, Jabiru, Bird Dog, and Bleriot. So I am guessing it’s PROBABLY one of them! :wink:

same here. now no CTD

Yep all it takes is one livery and boom ! All heck breaks loose

One things for sure… msfs patches are superman, mods are kryptonite

Remove em all, clear your rolling cache, check the content mngr and 3rd party updates then add mods back one by one

I found the culprit on my end. It’s the IFR training mission set from FS Academy. I’ll email them to let them know.

FS Academy IFR

1 Like

$10 this is a driver failure on your end and not anything to do with the patch.

Yes @CaptHawkeye50 or a mod – 60,000 of the posts “ASOBO BROKE THE GAME” are all because the mods we have in our Community folders no longer work with the new patch.

This is just going to get worse and worse I am afraid.

Ah… Makes sense. I added back all the Bush Trips and the Jabiru aircraft. So far so good… Gonna keep adding aircraft. Will test IFR last - I DID have that, so that may have been the cause of CTDs.

To be fair, we really need a better way to manage mods. Throwing hundreds of folders in “Community” with no naming conventions and no way to organize is asking for trouble. As you say, it will only get worse.

At the very least, we need the ability to create subfolders. At least that way, we can enable/disable dozens of mods at once during troubleshooting.