CTD immediately and every time after pressing yellow 'FLY' button

:warning: :airplane: Click: POSSIBLE SOLUTION :airplane: :warning:

Around 280 hours of flying never had really issues with CTD’s but currently I can’t even start any flight anymore. Happens every single time as well with training events, thought they were safest to do some troubleshooting.

Zendesk ticket: Game crashes to desktop every time when I click FLY (not Fly Now!) – Microsoft Flight Simulator Support (zendesk.com)

Things I tried/did

  • Empty community directory (as always)
  • Deleting old content.xml from %appdata%
  • Used DDU for clean install of latest Game Ready drivers since I used the lastest Studio Drivers of nVidia
  • Disabled second GPU in my machine
  • Disabled Audio Drivers
  • Disabled additional monitors
  • Started as Administrator
  • Verified game files
  • Disabled all controllers (unplug from USB)
  • Disabled all programs from startup/taskmgr
  • Turned of AI traffic
  • reset manual/rolling cache
  • Disabled rolling cache
  • Disabled live traffic
  • Deleted hospital plane
  • Turned off online mode
  • Disabled ATC
  • clean boot as MS states, no non-microsoft services except Steam, no startup programs.
  • updated Windows to build 19043.1151
  • updated MSFS to
  • updated MSFS to
  • fixed problem moving it to another drive
  • tried moving it back to original nvme, crashes again on pressing FLY

PC Specs

  • i9 9900K - not overclocked
  • 64GB RAM
  • nVidia RTX 2080Ti
  • nVidia GTX 1070
  • latest Windows 21H1 (19043.1110)
  • all drivers are up-to-date, nerds like it that way
  • plenty of space on C, MFSF is running from D (Nvme SSD)
  • running the Steam edition

I’ve a 4G+ internet connection so I prefer not to download the entire sim again. Because it just quits right after I press ‘Fly’ I think there must be something different going on anyway. Never experienced this but the Event Viewer ain’t helpful at all.

Hope some people have some suggestions! Stay safe.

Be sure to have AI aircraft off.

Did not work, I was actually testing with training missions since those are like most basic/default and tested I guess. Just to narrow the amount of variables.

I’d try just spawning in to a quiet airport, I’ve never had any luck with the “missions”

Disable everything in start up and restart your PC, the entries will still be there so you can include them later if you need to.

Exactly the same here. The sim crashes also if I move or zoom the world map too fast. Never happened before. I submitted zendesk tickets.


Just tried that, no difference unfortunately.

Yeah that happened to me as well. Also why I tried to start using the training stuff since you skip the world map.

I am having these same issues (world map and Fly) too.

I have AI traffic turned off, and my community folder is empty.

1 Like

Try resetting your data cache: go to Settings > General > Data and delete rolling cache, then you need to initialise it again by switching it back on on the same page, clicking save, and waiting while it initialises, then restart the sim and try again. If you set up a manual cache of some regions, do the same with those.

I don’t use rolling caches or manual caches.

I had the same problem. MSFS crashed every time i pressed fly after update 5. After trying a lot off different solutions mentioned in the forums i removed my installation of msfs and reinstalled it. 6 hours later and i was able to fly again. After that i installed all the addons, placed the rolling and manual cache back in the right folder and downloaded the world updates. Everything seems to be working fine now.

Hope this might help for others.

If I had a normal internet connection I would also do so but I’m currently on 4G. Have daily limit of 8GB which is actually unlimited but for more I’ve to send a text message for an extra 2GB. So I can’t simply do it overnight since I’ve to send those text messages every few minutes.

It’s a shame the verify game files doesn’t actually verify all I think. At least I don’t have the feeling it does looks for a checksum or so on every file.

1 Like

Just tried it to be sure, tried it once before. Didn’t solve anything. I’m just a bit puzzled it crashes immediately after I click ‘fly’ at such speed I can’t imagine it’s already loading something. I’m not sure which is the first file it will load, might be fs_base stuff and if there was a chance only download the first few files it loads it helped a lot with troubleshooting but not sure if that can be done.

Same problem here. Did a full reinstall of the game and it was not fixed. Super annoying, I really wanted to try out the performance updates.


Well I’m actually happy you said the reinstall didn’t work for you. Saves me from a download-hell-like experience with my 4G connection. I’m sure there will be a fix since more people have exactly the same. Should also be easy to reproduce once they find a PC with the issue since it’s same every time.

I would also love to try the new stuff but must say that it did run really well already at my PC. At least, if I compare it with older flight simulators. Taking the amazing looks in account I think it’s amazing what they have achieved.

I dont think this will help everyone - but I solved my starting issues after pressing FLY by completely deleting my community folder (and letting MSFS recreate) and uninstalling the Eye Plane (you cant fly it - crazy its even there)

Now my ILS still isnt working and the visuals are worse but thats another battle for another day…

As far as I can surmise it’s something to do with A.I. atc or A.I. traffic which only Asobo can fix. In the meantime disable both and try again. Deleting rolling cache I’m not sure about but it can’t really hurt.

I disabled the LIVE traffic and no CTD for the several flights.

CTD back :frowning:

What is Eye Plane and how do I uninstall it?