CTD immediately and every time after pressing yellow 'FLY' button

I think you mean with ‘packages’ the Community folder under InstalledPackages? I leave that one out of my story since those are separate from the real game. Best to start with an empty one as well after a big update.

But my ‘real’ community content is still at my Nvme since I use an addon manager to just create symbolic links in the game folder (now on E). Those numbers you see are also without the community folder, mine is for example -uhum- 672GB but I enabled Windows real time compression on it so it’s 451GB on my nvme. Nice save of over 200GB and you won’t notice a thing while loading the game.

[edit]
Steam doesn’t really check a thing, just the flighsimulator.exe which is just a launcher. But if you like rename an original MSFS game folder or rename some on %appdata% it will recreate or redownload those folders (that’s what the game inspects while it says it looks for updates). I did it with the fs_base folder, after rename it downloaded like those 13GB or so again.

about these I’am also a bit confused. The folder name in my case is “packages” :thinking:

and these explain it… thus “normal” users should be carefull with usage of " Steam move ".
At least they should should former backup the “packages” folder :slight_smile:

it is the application and these folder contains also steam specifiy “things”. I installed these 1.09GIG into my main Steam lib.

this is about I wrote. Normaly lies within %appdata…packages" the sceneries, etc… ( all the huge content ). And this can users move to another drive without redownload. This contains not executable.

I assume with Steam move is somewhat fixed at your msfs installation… but who knows.

Ah I now understand which folder you mean, the normal ‘packages’ folder under appdata/roaming etc. Well I just renamed that one in an earlier step trying to solve my problem. That folder has nothing to do with the base game but gets used with some addons. I now have only some files of the Working Title CJ4 in it.

Think for this thread it’s better to focus on the game. Community folder, or packages all can be empty. Basically the only folder that matters is the folder where it has FlightSimulator.exe and all it’s sub-dirs. All other files/folders just get recreated if they don’t exists.

For troubleshooting I for example renamed about everything in %appdata% besides the UserCfg.opt (if you remove that one you need to reinstall I read somewhere).

There is a big difference between packages and the Community folder inside ‘InstalledPackages’ the community folder should hold your addons, liveries, aircrafts, sceneries etc and the ‘packages’ folder should only have some cache files generated by for example the CJ4 mod, CRJ etc. But still, those content gets recreated as soon you use that addon again.

1 Like

It’s worth remembering that external drives are mostly designed to make data portable, not run apps from them which at least in part is what MFSF does with the community and official folders as it needs continual access. USB controllers can also be flaky especially with cheap no name contraptions and even the quality of the cable is a factor, if it’s not the original it could even be configured differently.

Edit: and thinking about it I’ve never encountered a portable app that doesn’t load itself wholly into ram before becoming functional, not that they don’t exist but I think it unusual and is only asking for trouble.

You can add KLAX to the list of airports that I cant load from…sigh

Take a look at my post maybe it can help

Having same issue since su5. Instant CTD when clicking the fly now button. It’s been many weeks since I’ve even seen a runway or the air this is absolutely ridiculous. Never had one CTD before su5 and the dumb hot fixes didn’t do shyte. Even moved the game off my ssd to my c drive and nothing helped

1 Like

Totally agree with you. I work hard enough all day ling and just want to come home and fly. But that’s impossible right now and extremely disappointing. We should not have to have a degree in IT to play a stupid game. It should work when we click it end of story. This is the only program on my pc that has issues.

1 Like

Too bad moving it to a different harddrive didn’t work for you. I tried to move it back from SATA drive E to a nvme D (where it originally was) but immediately crashed pressing FLY again. It’s weird and from Zendesk I only get stupid automatic replies.

1 Like

I did move it back yesterday and immediately it crashed again pressing FLY. Just so weird, so moved it back to the SATA and no problems again.

1 Like

OzBoz, Sim update SU5 patch 2 has killed my simulator. I have CTD’s when I press fly on the Discovery flights. If I do manage to get flying I get a CTD as soon as I touch my trim wheel. This was a complete re-install on Friday with all the old files and folders removed. I am on the verge of giving up now for the time being. My anti-aliasing looks poor and the buildings appear topple to the right and to the left repeatedly like falling dominos as I look at them if the plane is moving. It’s almost like the shadows are switching on and then off. It’s so weird and looks very ugly. This is happening in the mid-distance and I am not moving my head. I had so few CTD’s before this latest patch. The developers may have cured the CTD’s for some but created them for a new audience! :laughing:

BRGDS. Charles.

Charles, sorry to hear. I changed some LOD things in usercfg.opt to 4.00000 and that made my game look better as ever. But it’s not that stable if I’ve some addons loaded. You could try to move the files to another drive but think that’s only possible if you’ve the Steam version. Foes take a while as well.

I also added a thing on Zendesk that it kills FPS if you undock for example the ATC window. Drops my FPS from 56-32. I usually have those on a different monitor so it doesn’t clutter the screen so much so took me a while I noticed that if you dock them you suddenly have around 25 FPS more. Here is a small clip for my Zendesk friends (who actually are scripts doing auto replies) https://youtu.be/t9l1UZt_DTc

1 Like

In reference to the move operations, it is better to not confuse The download App of where your FS2020 is located.

There is the 1st part, approx 2GB, that is always and can only be installed on your C:\ drive (or your boot drive where Win 10 resides).

The 2nd part is the other part of FS2020 that the download App will install,
store, any where on any drive you want.

If you don’t muck around with the installation, you can move the
FS2020 App easily with:
Win 10 Settings, Apps, MS light Simulator and the “MOVE” command
or the “UNINSTALL” command.

I just did today. SU5 wasn’t acting right.
So, I uninstalled FS2020 and re-installed it.

Re-Install worked great.

  1. Settings, Apps, MS Flight Simulator - “Uninstall”
  2. MS Store
  3. Choose “Downloads & Updates”
  4. Select “MS Flight Simulator Deluxe” - my package
  5. FS2020 downloads - 2 minutes (around 2 GB)
  6. Install C:/ (your boot drive) files - 1 minute
  7. Asks where you want to install FS2020
    I select my FS2020 drive, D:\FS2020 - 2 minutes (around 127 GB) *
  8. Done. FS2020 running and problem solved.
  • the 127 GB was not downloaded since it was already there.
    The uninstall does not delete it

Hello OzBoz,

I have discovered that if I load a scenario, (in this case it was a Discovery flight) if I move my trim wheel and controllers in the last third section of the loading screen which takes you to ‘Fly’, my simulator appears to be fine and I managed to fly for one hour without a CTD.

As for the buildings that appear to be doing a Mexican wave in the mid-distance or toppling like dominos, increasing my Render Scale setting to 155 really helped to mitigate this problem as well as setting the other two sliders to maximum, (buildings LOD and terrain LOD). The caveat: I only have an i72600K with a 1070 GPU. I have set a frame rate limit of 30FPS and amazingly I can fly quite well at this high level of rendering on my computer. This would not have been possible for me to really go above 100 in the render settings pre-SU5. I am not far off full ULTRA settings within the simulator which is amazing considering my hardware is old now. I only have a 1080P monitor.

So there appears to be a problem with a Saitek trim wheel controller on my system. I can either remove
the trim wheel or just toggle it in the loading stage to avoid CTD’s within the sim. It’s all a bit of a ‘fudge’ fix really.

Charles.

You are right but most people here were talking about the Steam version which is a bit different in how it works and from which locations. Also with Steam it’s not really needed to download the game again (well you can of course). Personally I like that about Steam that you can move any game and never have to reinstall it if you have a new harddrive or pc, as long as you keep the steam folders you only need to download the client again.

I found nothing worked after hitting fly until i deleted the files for add ons in the main list of files I forget the folder name beside marketplace.
Akso comm file is empty. It eorks great now and the files are still avsilable for reload if you want to test each one to see which is causing the problem.

A fix for ‘Game Mode’ from Microsoft and a fix for some games that will not launch in Win10…

Same here, full reinstall after having spent a lot of time ensuring absolutely every trace of the original install had been wiped, even cleaned up the registry. I was hoping that a full reinstall would solve the other issue I had been suffering from, namely the game freezing when I turned on to the approach leg of an IFR flight. Well, I haven’t been able to check for that as the game CTDs on me when I press Fly. Tried three times, three CTDs, tried restarting PC, no effect. Given up, I’ve got better things to do with my life than wait on this rubbish.

If you have the Steam version you can try to move it to another drive. That’s not much work using Steam. Use Steam to create also a library on another drive, than you right click at Flight Sim and in the properties you can check the location of file and there’s a button you can move it to another Steam library. Takes of course some time but you get a message when it’s done.

After you put the right path to the InstalledPackages folder at the bottom of your UserCfg.opt file and try to run it again.

It makes absolutely no sense but for me it worked. I tried to move it back afterwards since the original drive is a much faster Nvme but immediately got the CTD when I press FLY again. I really don’t know why it worked for me since I also removed all traces, emptied the content.xml, renamed some folders so it would created new ones but still, only moving made it possible for me to fly again.

I still cannot start at certain large airports (marketplace and MSFS ones). I have tried removing them but it makes no difference after reinstall. I am assuming I will need updates from the developers at this point.