CTD immediately and every time after pressing yellow 'FLY' button

Unfortunately it didn’t work, I put them at the ‘did try’ list. Als tried to put it on offline but I think it’s more realistic it has to do with some GPU things. Since that menu still pushes the GPU hard and when it switches with fly button it suddenly changes. Not sure though, just rough guess.

Possibly but then mine is something else as it occurs when I enter another air space and/or encounter A.I. traffic. Others are having more luck with online traffic so I will test again tomorrow.

Its a free plane in the marketplace - if you didnt download manually yourself you wouldn’t have it.

I see a great deal of Steam users reporting the CTD. There may be an application conflict. Try a clean boot and then run your simulator to see what happens. Charles


Thanks, I added it to my list of things tried, but it’s still the same. Also opened a Zendesk ticket, since I read so many people who CTD after a click on ‘FLY’

1 Like

Me too I was eager to test it but few sim friends reported bugs in the graphic, lower resolution clouds with halos, clipping and LOD modified with appearing boxes but definitely better smoothness and FPS. I guess they implemented the xbox update to PC.
Anyway can’t do it because of the CTD

1 Like

Welcome @Alexandros76557
even with LIVE traffic off can’t start a flight. For me there is no other solution than to wait for a fix (hopefully)

I have the exact same issue - tried everything, got nowhere. Waiting on a Zendesk ticket, but basically given up hope of being able to play until they put out a patch.

I also put a Zendesk ticket in. While a lot of mid flight CTD’s are hard to reproduce or caused by addon’s I think this is more a major bug which can only be solved by Asobo. At least I can’t think of something I didn’t try already. Eager to fly again though :smiley:

1 Like

Hi, apologize for not not helping here. Just to let you know, I am encountering the same issue since the latest update of MS2020 with version FS2020 Version The community folder is empty, and even the training events crash or freeze. Everything was working perfectly well before the update.
I have just raised a ticket to support@flightsimulator.zendesk.com.


are you aware later today there will be already a patch, better wait for that.


Yeah I know, can’t wait. Microsoft also sent me an email I should get back to them if it’s still the same after the hotfix from today. Really hope it’s fixed. Not being able to start any flight feels nasty, enjoyed my daily trips so much.

Update 5 is the worst thing to happen to this SIM!!!
Thanks for your post< I am having the exact same problem, Every time I press fly it does not load.
I have tried everything I can think of at this point, including uninstall and re-install 5 times!!! since this horrible update
I am really dissapointed how careless and sloppy this upgrade was. Thanks alot Xbox

1 Like

Well I’ve the feeling it’s a thing that’s easier to reproduce than more vague problems since it just happens every time. Therefore I think it will be fixed in the hotfix later today. I hope I’m a happy flyer again in 3 hours.

try this

I wonder if someone with the same problem had luck since after a Windows update + Steam update + MSFS Hotfix update I still experience exactly the same. Press FLY > CTD

I still cant start at EGLL - FLY button then hang - so thats not fixed with the “Update” for me

For me it doesn’t matter what I try, to have a bit of a tested scenario and not a random airfield I tried mostly to start some of the trainings since they are about the most default scenario. Just surprised Zendesk with 3 video’s from screen with 3 different crash locations, once training FLY button, once a normal flight FLY button and when I tried that it also crashed scrolling over the map :X

1 Like

Followed all the steps Microsoft recommended, updated the game, still CTDs every time - still unplayable.

Same. Now sent 3 movieclips I captured so Zendesk team can see the game crash with 2 different FLY buttons and once when I was scrolling their world map… didn’t see any plane from the inside.

1 Like