CTD immediately and every time after pressing yellow 'FLY' button

Same here…

Pointless hotfix…

I’ve been troubleshooting this issue wince I tried everything you’d read on these forums. Everything. On two different computers.

I was finally able to fix this by deleting both FlightSimulator folders in appdata

  • Local > FlightSimulator
  • Roaming > Microsoft Flight Simulator

and then deleting the application (Note that I had the application installed onto one of those T5 Samsung Portable SSD’s connected via USB 3.0) and reinstalling the application fully onto a physical HDD.

Note that some of my settings were still changed from all the troubleshooting (Ex: Paged Memory, No AI, Low quality, Cloud saves turned off, etc.) so I can’t confirm if the clean install alone fixed it.

I have not rebooted the machine yet (I’ve seen people say this breaks the game again). I’ve not flown for more than 5 minutes yet. I am just so surprised that I can even click ‘Fly’ and not crash. I loaded a discovery flight (Naples). I picked two airports randomly on the world map and was able to load successfully on the runway.

I’m going to try copying the install folder to my other machine to test it. I will update with more information as I progress. Now I need to find the energy to play the game!

Edit 1: I have no add-ons installed. Clean install only.
Edit 2: Still works after restart

1 Like

Are u using 3rd party landmarks add-ons?

I also experience unlimited freeze (not responding) when click “fly” yellow button in orbx dubai…

When i uninstall the orbx dubai (back to original dubai from MSFS), i can load dubai smoothly after click “fly” yellow button.

My conclusion:

  • orbx landmarks not performance friendly (?)
  • su5 make many 3rd party add-ons broken (?)

Try not setting a flight plan. If I just set a start point it works, flight plan will CTD after hitting FLY.

You brought me on an idea to rename those existing folders in those appdata locations so they get recreated. But didn’t help a bit. I would reinstall if I had the feeling it would solve it but see too many people who have the same after a complete reinstall. And got 8GB data a day, well it’s unlimited but after those 8GB I’ve to send text messages to get 2GB extra. That’s quite a lot of text and time to reinstall.

@OzBoz73 I had problems even starting the sim. This helped and perhaps it can help you as well:

Start menu → Apps & features → Click on Microsoft Flight Simulator and Advanced Options

Then I did a Reset.

Tried repair first but that didn’t help.

Thanks! But I think you’ve the MS Store version, I can only select ‘uninstall’ and not reset like I can do with apps from the store.

Oh, what a bummer :confused:

I’ve got exactly the same issue. I press the fly button and then get a black screen for a few seconds, the menu music pauses and then a CTD with no error message. I’ve also done the same steps as you; empty community folder, full reinstall, updated everything etc.

I’ve also got the game on a portable nvme SSD and running the Steam edition.

I’m wondering if it isn’t an issue with the game’s handling of the SSD with SU5?

Well I didn’t have any problems before 1.18.13. I also tried to slow my PC a bit down disabling XMS and while I was at the BIOS disabling Intel speedstep. But still same. It’s a shame there are no useful log files. It’s quite annoying but I guess they are working on it, well they should.

After freeing up 150GB, I’m reinstalling it onto an internal SSD instead of an external SSD on my MSI Laptop at the moment. It crashes with the external SSD on the laptop but is working on my desktop (internal HDD). I tried to use the External SSD on the desktop and it crashed as well. Could be an external SSD issue but I figured since it could load the main menu and not crash that the external SSD was okay.

Will update with the laptop install once it’s done.

Update 7/31/21 @ 6.19pm EST: I can confirm (see my earlier posts) that reinstalling the entire game on an internal SSD solved the problem. I am able to use my MSI gaming laptop now. Perhaps it didn’t work because of the external SSD…

1 Like

I’m having exact same problems as OzBoz73 and Vectorising: CRT after pressing Fly button. And I’m running MSFS on an Omen X laptop with a 107gtx card and a 2TB external nvme SSD. Also, I’ve symbolic linked the C installation to the SSD to save on internal space. Up to this SU it’s worked a treat. So maybe there’s a pattern here which has been ruined by the update.

1 Like

because it only happens to me with a320 fly by wire?

Neither did I with the same setup. This patch and the hotfix have made the game unplayable. I unfortunately don’t have the space to free up to test on my internal drive.

It’s a bit hard to find out what can be the problem. Could be also outside MSFS like having some kind of .net framework or C++ library etc. and hard to think of other things to try, if there was some kind of log file you could at least see what flightsim does after you press ‘FLY’. Hope I get some response from Zendesk

1 Like

Is the SSD you have the game loaded on internal or external? Wonder if that’s the pattern here and what was broken with SU5.

I have the world map and Fly crashes, and my game is installed on an external SSD.


Everything is on the external SSD. I originally installed MSFS on the C drve of my laltop and on tne internal HDD last August, but running out of space and l;ooking for more speed, then bought an SSD and put the whole installation on there, but using symbolic links between the C: User/ data and the same on the SSD. It worked perfectly, with really good frames. Since the update, I’ve not been able to start a flight.

I’ve tried everything I can think of to solve this, but this is the only thing that makes sense: Asobo hasn’t taken into account kind of hybrid installation which is really very common on gaming laptops

I can confirm (see my earlier posts) that reinstalling the entire game on an internal SSD solved the problem. I am able to use my MSI gaming laptop now. Perhaps it didn’t work because of the external SSD…

I just have the game on my external SSD with no symbolic links to my C drive. I assume it’s just external SSDs that are broken for this update and hopefully it can be resolved with a hotfix. I’ve messaged several people that have been reporting this specific fly buttom immediately CTDs issue and they all have the game installed on an external SSD.

1 Like