CTD immediately and every time after pressing yellow 'FLY' button

Basically Microsoft/Asobo are asking us to:

  • Do not install any additional software in windows
  • Do not install any add-on on MSFS
  • Do not install any USB controller
  • Use the default folder and avoid the use of external disks
  • Do not overclock your system
  • Sign in and sign out your Microsoft Store
  • Remove all start-up software (even Windows Audio Service)
  • Disable the use of any app in background
  • Disable AI traffic
  • Put your paging file fixed and not managed by the system, at a specific amount
  • Do not set a flight plan
  • Empty the community folder

I still have CTD (even worse since I followed ZenDesk instructions, I can’t even get to press the FLY button now)
Well, as much as incredible the above list might appear I would suggest adding your personal test/feeling you might have.

I will try myself as a last hope to create a local user on my machine an do a clean boot.


I too can report the same CTD problem. In my case, however, it only occurs at some point between clicking the ‘fly’ button and entering the cockpit. For me it appears to be random, occurring about 50% of the time but once in the cockpit everything proceeds normally without any CTDs during flight. Sadly intermittent behaviour like this is extremely difficult to diagnose. One thing is certain though, it is coincident with the SU5 and was not solved by hotfix

EDIT: Only 12 votes on the Forum! It’s my guess many more users are experiencing the same issue.

EDIT: CTDs after clicking ‘Fly’ now incessant making FS2020 completely unusable for me at this time. Forced to give up flying again until Asobo and MS consider the problem important enough to fix.

I’ve my game on an internal NVme SSD and never had issues. Well, if I had issues it was some custom livery I downloaded but like @Mollenon says, even with all those steps which will render your PC MSFS only it still doesn’t work. I do a lot or 3D renders so I really need a stable system since those push my CPU + GPU to 100% for a longer time. While I can imagine some of the Zendesk advice might help some people I think this ‘FLY’ button thing is an entirely different problem.

I might try a reinstall next week but I read to much people who did it once or twice and still have the same ‘FLY’ button > CTD issue. Just hope I get a more useful reply from the Zendesk friends.

1 Like

Have exacly the same problem. If i scroll on the worldmap or click Fly… instant CTD…

Exact same issue with crash immediatly the yellow fly button activated. Had cleared cache before attempting to fly. Returned all options to default and fly out of local small airport fixed issue. Still could not fly out of London City, Fly from Heathrow to London City OK. Then it was OK to start Fly from London City. Have no idea what the issue was but all seems OK except the appearance/Graphics are woefull. One step forward 10 steps backward.
PS. Did not have this issue before the Hotfix, had all sorts of other issues.

Its infuriating to have purchased all of these beautiful airports thru the marketplace and cant start a flight in any of them.

I tried it as well, returning all settings to default and cleared out the cache (well again) but no luck here.

I have been able to deliberately create this CTD/or version of it, on a virtually fault-free simulator, (SU5). I was able to fix the problem I deliberately created. I have posted my findings in…

If I can create the CTD scenario and fix it again, there might be light-at-the-end-of the tunnel because in some instances some people might be able to get the sim’ working again. I am not claiming a fix, what I did, worked for me on my PC with my simulator.


1 Like

I’m really curious of course but it says your linked page does not exist or is private.

[edit] Found it, gonna try!
[edit 2] Unfortunately not working for me but hope some others have some luck!

1 Like

Yea, sorry. I just linked to the main thread. Have you tried disabling ‘Lock’ mode if you have it enabled?

I have learnt from my experimenting today, that, (certainly in my case) just making some system changes or changes to the options within the simulator, can turn CTD’s on and off! Some of the fixes for CTD’s may be quite fundamental, unfortunately no simulator or computer, (or even the user) are equal. There are just so many software/hardware environmental variables, it makes looking for a solution very difficult, In any case I have finished my experimenting and I am going to enjoy my simulator now. I only have 60 hours in my simulator log book. Take care. Charles.

BRGDS. Charles

1 Like

I really appreciate the thinking along. And you’re absolutely right there are many differences between all PC’s etc. Still something like the options shouldn’t be able to render a product useless. I just tried to install my latest Realtek Audio drivers so it uses the default Windows ones but no luck as well. Think this one has to be figured out by Asobo/Microsoft.

Best regards!

1 Like

ive had excatly the same thing today, done 2 weeks of flying including 2 seperate 8 hour flights from uk to usa and back and 2 weeks real time flying round without one issue, now today i crashed out after 45 mins when opened mini map in flight, and now every time set up a flight, click yellow fly button, BOOM crashed, its nothing to do with any add ons since i have had the game it has only been basic i never alter or add on anything its soley down to the update simple as that, i know it, you know it and they know it

The link is not working

1 Like

Ok, now please put lots of attention on what @TheAviator3506 found since I discovered that I could get inside the cockpit again. For me putting the accessibility option - Cockpit Interaction System to LEGACY worked!
I suggest simmers out there before reinstalling or wasting time to blame it on ASOBO or MICROSOFT to use this precious time to give positive feedback.

Play with your accessibility and look what is working best for you and please post your comments below so we could find a solution all together.

EDIT: For those using another SSD (both internal or external) be assure to be formatted in NTFS and not ExFAT. I had few CTD before the last update mostly caused by improper file system)

1 Like

Thank you kindly Mollenon. I don’t think l will get much thanx for this but it does not matter. I am sure what l have discovered will help a number of people, if l have only helped you it will be worth it!

Just to recap, some may benefit by turning off ‘lock’ and revert to ‘Legacy’ mouse control for cockpit interaction. It will not work for everyone though.

Take Care.


1 Like

I fixed the link/updated it. :grinning:

1 Like

I have to thank you @TheAviator3506, being able to start it again after days it is indeed a huge improvement.
I hope your suggestion could help lots of other simmers besides a thank you that is inexpensive on our side and much appreciated on both sides.

1 Like

I moved my msfs2020 folder from my external T5 drive to my interval drive and al my CTD when i press fly are gone… now i can fly i see a massive performance inprovment in VR… buttersmooth now.,


Brilliant and thankyou for sharing this discovery with us, one that worked for you.
I have a separate swap file on a dedicated partition and my MSFS2020 has a dedicated partition too.

Maybe if some people move their main swap file to a dedicated partition, this could help if they have a dynamic swap file that is located on a root drive with the simulator that perhaps does not have enough space?

I have fantastic performance on my 2012 PC and no CTD’s. i72600K and GTX1070 GPU.


1 Like

Since a lot of people talk about moving to another drive…

I just used Steam to move my Data from a Steam Library at my D-drive (Nvme SSD) to my E-drive which is a normal harddrive. After the move the game wanted to download 124GB again. Not my hobby so I changed this line (inside C:\Users\username\AppData\Roaming\Microsoft Flight SimulatorUserCfg.opt):

InstalledPackagesPath "D:\Steam\steamapps\common\MicrosoftFlightSimulator\InstalledPackages"


InstalledPackagesPath "E:\Games\Steam\steamapps\common\MicrosoftFlightSimulator\InstalledPackages"

And miracles, I got inside a plane this time. It makes absolutely no sense why this works and need to do some more testing but at least I saw the inside of a plane again.