CTD / No Flightplan entrys when DEP=ARR-Airport

I want to practice an ILS approach on my Departure Airfield. So I selected DEPARTURE Airport and DESTINATION Airport the same. I tryed to select any SID´s or STAR´s and Approaches, but i failed. No Route shown an Display, no Waypoints in my Flightplan. After several trys for selecting an Approach, my Sim CTD.

Can anybody confirm, that there is an issue, when Departue is equal to Destination, and unable to select SID´s / STAR´s for same Airport?

(i hope you understand what the Problem is, sorry)
thank you!

There are quite a few threads on the forums where people are reporting crash to desktops and it seems there is no one single cause. Reports indicate that the ‘fix’ for one user doesn’t work for another user etc. Tracking down the cause is very time consuming. I suggest maybe using the forum search function to find other threads for this issue. If you wanted to be brave, even though it is time consuming, you could take the plunge and go ahead and reinstall windows. It might actually save you time in the long run. However, it doesn’t guarantee that it will solve your problem if the CTD is caused by hardware weaknesses (unlikely but possible) or driver issues.

To get you started, here are two links (Link1, Link2) to existing mega-threads about CTDs.

It would also be a good idea to check out the known issues post to see if you are affected by one of those.

For advanced troubleshooting, if none of the other fixes seem to work, then there may also be some useful information contained in this detailed thread: Community Troubleshooting Guide.

1 Like

thank you …but my question was more about the bug in the Flightplan for the DEP and ARR airport, as discribed. The CTD is not my main issue.

and thank you, but i well known the search function!

and…i don´t want to “reinstall windows”, when it is a known bug! THANK YOU

Yikes… re-install windows? I think that is a bit premature.

@andrejetcat there are so many bugs in IFR procedures that I consider it unuseable. But, like others, I am finding certain aircraft has less issues. The C172 is one that I find is severely broken, yet the TBM930 has fewer issues.

@TCarlisle2012 - No one is implying that’s the first choice. I struggled a great deal personally with CTDs and spent several weeks doing a host of things to isolate and resolve the issue, and had no joy. When I reached the end of known possibilities, I resorted to reinstalling Windows. Amazingly, no issue since. It was my last resort, and it worked. However, YMMV.

@andrejetcat Do you have the FPS Fix installed? If you do, I recommend removing it. I was having the same problem. When I loaded a saved flight plan, it would load in the GPS and show on the ND, but not in the MCDU. Even when I tried to enter a flight plan in the MCDU, it wouldn’t even let me enter the DEP/ARR airports, much less enter a SID/STAR. so I removed the FPS Fix after reading a post from @rtm11745 saying he had the same problem and solution and it worked for him and me as well. I hope this helps!

1 Like

thank you for you solutions! Yes, I removed all my Community stuff from the folder after the “new” patch.

  • the Problem only occures, when the departure airport is the same as the destination airport. Then I can´t select any SID´s / STAR´s. If I select a different Destination Airport, all works.