CTD on accessing OPTIONS > GENERAL

CTD on opening OPTIONS > General

I am running MSFS vers. 1.15.10.0.

Since update 1.15.8.0 I have been unable to access my Options > General settings. Everytime I try, the screen mists over and I am returned to my Desktop.

When I check Event Viewer I always receive the same error message :-

Description:
Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x6087d3ea
Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf
Exception code: 0xc0000409
Fault offset: 0x000000000007286e
Faulting process ID: 0x2640
Faulting application start time: 0x01d744e89bb3247c
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.15.10.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report ID: 117928aa-093e-4d9b-845d-c4e873687db1
Faulting package full name: Microsoft.FlightSimulator_1.15.10.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

I have been told by some that the CTD is caused by not having the ENGLISH (United States) Language pack installed. Not only is it installed but so have been ALL of the Speech/Region/Date and Time formats
Without any success whatsoever.

The Flight Sim is still flyable even though I cannot change any of the parameters stored within OPTIONS > General. It appears that I am just running on those settings that were in place prior to this fault developing.

MSFS has been fully reinstalled - no change.
Windows has been reset and MSFS reinstalled - no change.
Windows has been fully wiped and MSFS reinstalled - no change.

Any ideas please?

This seems to be relatively common one, to do with the US English language pack not being installed.

image

I have to say I never used to have this installed, and didn’t get this error. My understanding it was only to do with offline ATC voices, which I never used as I have Azure turned on. But I installed it anyway as a backup in case Azure drops offline.

unfortunately not only for that… its a realy strange dependency.

as @Hester40MT already mentioned we can only repeat that this combination is normaly because of the missing english lang pack US.
What you find out after checking the link which Hester gave you ?

So far I remember me other cases for ucrtbase.dll was somewhat with the c++ lib or the windows audio service. But not sure, because these seems not realy match with your desc and these have different error numbers.

May be… how much controllers you have connected ?

I think I flew without it for maybe three months. :slight_smile:

yes… it was same in my case… I installed it because Offline-ATC only :slight_smile:

But some users can neither install the game nor play the game without these Lang Pack.

1 Like

Many thanks to you guys for your help. I knew about the English (US) Language Pack and had it installed for a couple of weeks but it did not cure the problem. Then when I saw your screen shot I noticed that you’d got more icons showing against both of your Language Packs and so, I attempted the get the same. Don’t know why but it nows works and once again I can open Options>General.

I’m sure that I’ve been running this sim for many months without that English (US) pack running!

Anyway, thanks for your responses. Best wishes.

1 Like

Same Issue - CTD only when i click on the Options.
Otherwise the sim is running normaly.

Have an new PC with an new install from MSFS , on the old PC the MSFS is running normaly.
Also without the english-language package.
Community folder emty - no other MOD
Errormessage : ucrtbase.dll

It’s reported that error can occur if you do not have the US English pack installed.

The scenario that could cause this is you have Azure TTS enabled, but for some reason this connection fails, then offline ATC tried to use a language pack that is not installed. What they should do is just generate a text based only if the language pack is detected as missing, rather than a crash.