CTD on first run

I do not know if somebody has been experiencing this lately. But every time I run MSFS, the game will start loading, and it crashes before loading the game. The second time I run the game, it does work fine. It has been happening all the time since I installed the SU10 beta. Has anybody experienced this? Maybe is something on my end?

I’m curious, because I’m having a similar issue. On the second start, do you get the dialog asking whether you want to launch in safe mode or normal mode?

For me, it goes like this: I restart Windows, I use the Steam client to run MSFS, the window opens with the “progress circle” turning in the bottom right for like half a second, then the window closes before the Xbox Game Studios logo is displayed.

On the 2nd start, I sometimes get the safe mode dialog, sometimes MSFS just starts as if nothing happened.

On my system, this issue started after the recent launcher update for 1.27.19.0. It happened for the first time before 1.27.19.0 was even installed – I had to try several times to get to the… what’s it called… Installation Manager window (the one where you confirm that you want to download the actual update).

So this appears to be a launcher issue.

[edit: to clarify, as I said this happens after I “restart Windows”, so rebooting does not help to prevent the issue on my system. fspackagetool seems not affected at all.]

Yeah, on Steam that dialogue pops up pretty often if you don’t start the sim from within the Steam library but from a direct shortcut to the flightsimulator.exe.

I also encountered CTDs after the dialogue now on 1.27.19.0. - currently I’m forced to run MSFS with administrator privileges to start it up properly. Maybe a reboot of the system may help here.

Edit: Yes, a proper system reboot fixed the issue in my case!

Also getting a CTD on first start since the last update. Okay on the second start and get the get the ‘safe mode dialog’ box. I’m using the store version.

Had the same problem this morning with Steam…after the CTD, boot into Safe Mode, get the update, close MSFS, and relaunch. All good now

Confirm same from here. System reboot cured the CTD on first run for me too. Thanks!
(Steam version btw)

I’m seeing similar problem with CTD first start then OK on second. Reboot does not fix the problem for me.

1 Like

Yep, just happened to me. Took a restart and three more attempts to get into even safe mode.

Eventually worked but I hate restarting my Windows as it always means waiting 3 or 4 minutes for wsappx to do its thing.

Same here. Just CTD after updating to latest beta in MS Store.

Edit: After 1 reboot of the PC and 5 attempts, it keeps crashing even in safe mode. I can’t start the program.

Edit 2: My sim was in DX12. Manually edited usercfg file to DX11 and now it’s starting.

Yes i see the same. 1st run after PC restart, crash. 2nd run no problem.

Your DX12 related crash might be a different issue. Consider opening a dedicated thread for it, because it seems like a severe issue that will leave people (who don’t know how to edit the config file) stranded.

The crashes we’re talking about in this thread happen very early in the startup process, before the actual sim starts and initializes graphics, and most of the time the sim starts on the next launch attempt after the CTD.

(For the record, I’m using DX11. I did not try DX12 with 1.27.19.0 yet.)

I was talking about the same crash. Just after the program launch. But it solved changing to DX11 in the opt file.

Now is good in DX12 also.

Not trying to nitpick and I’m not an expert, but I believe if you’re indeed talking about the launcher crash, it was probably pure luck that it worked after changing the config. From what I believe to know about DirectX (and I will be happy to acknowledge if someone who knows better corrects me), a DX12 related crash should only happen after the actual game engine starts to render in 3d.

I see this too. 3 out of 5 MSFS App starts, are CTD before getting into the main app screen.

This is happening since 1.27.18.0 BETA. Before I never had this issue.
I have no corrupt files and it does this also without any addons in the community folder.

2 Likes

Yes, since yesterday each first start instant ctd … second, sometimes third start works.

2 Likes

Same thing here, I have it since .18 update.

Edit:
it even happens after a restart of pc, first run CTD, then second run with asking for safe mode, when selecting start normal, it starts normal. When then quit and restart, it CTD again.

1st CTD:
Fault bucket 1422297993888408599, type 5
Event Name: MoBEX
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft.FlightSimulator_1.27.18.0_x64__8wekyb3d8bbwe
P2: praid:App
P3: 1.27.18.0
P4: 00000000
P5: VCRUNTIME140.dll
P6: 14.30.30704.0
P7: 615a9215
P8: 00000000000100bd
P9: c0000409
P10: 0000000000000002

2nd CTD:
Fault bucket 1230406746829341435, type 5
Event Name: MoAppCrash
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft.FlightSimulator_1.27.18.0_x64__8wekyb3d8bbwe
P2: praid:App
P3: 1.27.18.0
P4: 00000000
P5: FlightSimulator.exe
P6: 1.27.18.0
P7: 00000000
P8: c0000005
P9: 0000000000176bf3
P10:

Edit 2:
hmm, it sometimes works, sometimes not, can’t replicate it every time

SU10 1.27.20 Steam version Win10 i9-9900k RTX3090 PC
First attempt with 1.27.20 and CTD after pressing “Fly now”

Application event log
Faulting application name: FlightSimulator.exe, version: 1.27.20.0, time stamp: 0x00000000
Faulting module name: VCRUNTIME140.dll, version: 14.31.31103.0, time stamp: 0x006cb796
Exception code: 0xc0000005
Fault offset: 0x000000000000161e
Faulting process ID: 0x1740
Faulting application start time: 0x01d8c5019f85a6bd
Faulting application path: E:\New library\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Windows\SYSTEM32\VCRUNTIME140.dll
Report ID: e2f7918c-a324-46f8-b9f7-7b75f8b65e45
Faulting package full name:
Faulting package-relative application ID:

Same here, first time CTD, then it starts. Store version.

Naam van toepassing met fout: FlightSimulator.exe, versie: 1.27.18.0, tijdstempel: 0x00000000
Naam van module met fout: FlightSimulator.exe, versie: 1.27.18.0, tijdstempel: 0x00000000
Uitzonderingscode: 0xc0000005
Foutmarge: 0x0000000001c7156b
Id van proces met fout: 0x960
Starttijd van toepassing met fout: 0x01d8c50681770f65
Pad naar toepassing met fout: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.27.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Pad naar module met fout: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.27.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Rapport-id: d91bec97-6451-425c-85a7-69d03c68fe92
Volledige pakketnaam met fout: Microsoft.FlightSimulator_1.27.18.0_x64__8wekyb3d8bbwe
Relatieve toepassings-id van pakket met fout: App

today i had no CTDs, flew 2 Legs of the USA bushtrip in VR, no problems. I’im still on .18 with the MS store Version.

Since I installed 1.27.18.0 I have had quite a few ctd when running MSFS, before it gets to the “checking for updates” screen. (MS Store version)

What definitely triggers it on my PC is any changes to the contents in the community folder.

When it happens I tend to quickly delete the “running.lock” file in
C:\Users\username\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState
to prevent the prompt to “Start in safe mode” and re run the sim.
It usually starts on second attempt but sometimes it can take two or three attempts for MSFS to start.

2 Likes