CTD On Loading All Flights in SU13 Beta

Sorry I wasn’t clear. I will reword my post as mine are both MS Market place. Not community folder.

1 Like

One more observation from tonight.
I tried to start a flight in FACT, since I have no addons from marketplace in Africa. And it worked. Then I tried a flight in HKT (most addons in the region in the community folder). Worked as well. Then went back to Europe (EDDF). Instant CTD after clicking “Ready to fly”. So it seems to have to do with the amount of marketplace addons in a region or the presence of problematic addons in a region. That was unclear to me. I had expected that once the marketplace library is loaded you are doomed to CTD.
By the way: Loading time of the sim and waiting for the flight as terribly long as always in SU 13.

If anyone is still getting regular CTDs starting a flight, I made a post on how I have so far gotten around it, I’m curious if anyone can reproduce my fix? If so it could help point to the cause.

My fix was somewhat VR focused, but if I just don’t touch anything after clicking the fly button on the world map, give it some time to settle and then click the ready to fly button and then stay hands off and let it settle, I haven’t gotten CTDs.

I have to keep my VR headset off and on the table to avoid creating any motion.

It seems the sim is sensitive when initially loading the flight.

I have the same problem:

loading fpl = ctd
or
loading flight = ctd
or
flight loaded, after 1-2 sec = ctd

Doesnt matter which aircraft or airport
MFS works fine in safe mode (with ugly standard airports)
All updates are installed / 3070 /i9/32gb/…MFS worked fine until second to last update

…hope, there will be a solution soon…

Negative for me. I wanted to try that when I read your tip, however even not clicking “Ready to fly” gives me a CTD after about 5 seconds.

A solution would be great!

But, even if they said they identified the problem and that 3rd parties would need to “fix” their addons for them to work with SU13. Not ideal at all but better than our current situation. I am worried that they see this problem as being limited to a few users with unique hardware setups. In which case they won’t fix it and won’t clearly identify it as a problem for the 3rd parties to fix.

Also, it seems like a number of folks have either dropped out of the BETA or disabled the problematic addons on their systems. As such, I suspect their telemetry is reporting decreasing numbers of CTDs. I hope they don’t misinterpret that as the problem being solved or more limited.

That would be a dramatic mistake.
First of all, this affects marketplace customers, which means MS customers. And the update shoots down their sim. If only the individual airport/scenery did not work, they definitely would not care (which is okay).
And lastly: They alway say, when an update is released, that you have to empty the community folder. How funny would it be, if they would have to say to remove all marketplace addons from the official folder.
No, they either resolve this mess or there will be un unprecedented wave of anger from marketplace customers when the update goes live. That would bring down marketplace sales and even hurt MSFS 2024.

1 Like

I think the MSFS Content (mod) Manager needs a big improvement too. It’s not easy at all to find, select and sort your current mods. And changes usually require a restart of the sim which makes everything really time consuming. It should be possible to enable / disable (and update) every mod (including Community Folder) in the sim without having to restart.
I think (and hope) that is something MS2024 will bring with the new architecture.

1 Like

I’ve gone through the, initially, tedious task of color-coding my add-ons folders by type. (wow, how badly has MS gotten the steps to do this wrong as compared to Apple?!)

Then, whenever an update to any of them is released, I have to sort by date and re-colorize the updated ones as needed.

I leave all the base, WUs, CUs, etc. folders the default yellow to easily know that they need to be left alone.

Screenshot 2023-08-31 131605

That’s your community folder I assume? Or just use the useful add-on manager programs out there…

Checking updates… through flightsim.to manager, pmdg manager, orbx manager, Flybywire installer etc etc…

No. That is OneStore content aka Marketplace.

Wow… all because you can’t just simply enable or disable marketplace content in the content manager without having to uninstall and redownload the entire thing.

But, more on topic: There is something strange going on with certain Marketplace content, because I still run a pretty large number of airports in my community folder and none of them causes longer loading timers or CTD’s.

For sure, the issues that I’ve found aren’t due to all MP content. There are definitely specific ones that are causing the most havoc, but I’ve also found that random combinations of them are as well.

The latter is the hardest to work with, because of the randomness. By randomness, I mean just throwing whatever X, Y & Z add-on into the OneStore folder out of your total collection and loading the sim. Individually, they don’t cause issues, but combined they do.

2 Likes

This may be part of a wider problem and not just limited to the Beta. I get a MSFS lockup whenever I load a flight for a new livery or new aircraft for the 1st time. The aircraft or livery appears OK in the hnager, but as soon as you load it in a flight, MSFS stops. It is only recently that this has starting happened, so I assume it is related to the latest update. After terminating MSFS through the task manager, the livery or aircraft always then loads successfully then next time you run MSFS, and the problem never resturns for that livery or aircraft. This problem is very consistent.

This how I was seeing it, too. If I had X aircraft with Y livery and loaded into Z airport for the first time I’d get a CTD. If I relaunched the sim, most of the time I’d be successful loading that same combination immediately. However, if I took the same aircraft and livery and loaded into a different airport I’d get a CTD. Or If I switched aircraft and used the same airport I’d get a CTD, etc.

There is something in that initial loading of a combination it doesn’t like.

Another beta update, and again nothing is improved/fixed. Still long load times, CTD when I hit “fly”, and on the rare occasions when it doesn’t CTD, the performance is HORRENDOUS. What in the world have they done in SU13?

I hope we will hear something in the Thursday update blog…

I may also be an extension of the problem where if you load a different livery or different aircraft and select a parking bay, MSFS always loaded the flight on the runway. The second time you load the same livery or aircraft, it loaded correctly in the parking bay. This problem has been around for some time. The solution to that problem was to select 2 different parking bays one after another before loading a flight. I’ll have to try this next time I load a new livery and see if that works for this problem as well.

Sorry to hear that. :frowning: I may have gotten lucky up to this point.

Even under stable builds, the first minute of the sim load does seem to take a while to settle in, especially with VR or mixing between VR and 2D.

I’ve been running the same airports, airplanes, addons, etc. Prior to the beta I was super stable.

1 Like

I’m not even sure why MP or Community content should cause instability. I can see performance problems in some systems. But it’s all really just content, usually not executing, unmanaged code.

And still this thread is not tagged bug-logged or merged with the parallel thread in the performance section. Very sad.

1 Like