CTD on Long Flights. Boeing crashes, Airbus doesn't

So, I decided to expirement a little. I enjoy starting a long-haul flight before bed sometimes, waking up and finishing it off. I started to realize that whenever I used the Boeing planes, it was inevitable that I would wake up to the Sim no longer running. The Airbus, not the FBW version, always seemed to be flying along just fine. With both, I sometimes had that frame drop to 3-4 fps, but the sim was always running.

I decided to try something over the last month. Each night, I would start a flight with either the 747, 787 or A320. Every single time the Boeings were CTD’s in the morning. Every single time the A320 was flying nice and smooth.

I have come to believe that it has to be something specific with the Boeing programming that is causing the CTD. Thoughts anyone?

  • I use the MS Store version

I dunno, CTDs are mysterious things. I don’t fly the Boeings at all, so I can’t really confirm that for you, but I recently did a 14-hour long haul flight on the A330-900neo and it went without a hitch (well except for that one time I ran out of fuel and my engine cutoff… but nothing a little magic mid-air refueling won’t do that would let me do a mid-air engine restart and get back to my cruise altitude).

That being said, just a few days ago, my sim CTDs on startup load, every time. And it doesn’t matter whether I have mods or not, I cleared all my community folder, and when asked I choose Start in Safe mode, and it’s still CTD at the same spot during the initial startup load.

The only way I solved it was to do a clean windows 11 reinstall, install MSFS again, and I gradually start adding mods one thing at a time, while starting the sim to make sure everything is loaded properly and also to see which mods starting to cause the CTD on startup load. When I got all the mods installed, it was stable, and as I keep adding more mods than before, it’s still stable.

I don’t even know what’s causing it. This is in the exact same PC, exact same Windows 11 build, the latter which was actually clean reinstalled just 1 day before. So it’s just as clean as it is on my current MSFS install.

Bottom line is, who knows. Everyone seems to be getting different CTD behaviour. Heck, even I am gettting different CTD behaviour, on the exact same hardware, and the exact same software conditions.


I get CTD’s for other things too. About 50% of the time that I make an attempt to fly the Baron, it crashes almost immediately. I just made this specific observation in relation to longer flights with these 3 specific planes.

1 Like

Same issue when I fly the CJ4 or the Airbus no problem but if I want to fly the F18 I have CTD

My CTDs are happening in the exact same way; I will attempt a long haul flight, 13 or 14+ hours, with a Boeing (usually before I go to bed) and see that its CTD in the morning. I’m playing the series X. Hopefully that helps.

In my case, it’s the 787-10 Dreamliner which after 7, 8 or 9 hours flight brings down fps to below 5, basically as soon as I start decreasing height to start descent. Not doing anything special but just about then the fps drop so low that I have to cancel the flight as it becomes inoperable (one hit with the mouse or controller takes minutes to react). Is there a fix available for that for 787-10 Dreamliner?

Not sure, but this issue was there already in earlier updates, however, never fixed properly especially for that airplane.

Could it be the scenery of the area that you start your descent on? I just had 9 hour flight on the 787, and I had no issue with FPS as I descend and approach to OMDB at the end.

But I also had a flight to LTFM on the same 787 which is just under 4 hours. And I had massive FPS loss and stuttering on approach (from 30 FPS, down to 8 FPS). But I know it’s a scenery issue, because the LTFM addon is not optimised and it even gives me the same 8-10 FPS when parked at the gate at the start of the flight.

So for me FPS drop is usually coming from scenery. And my major FPS drop comes from Photogrammetry and unoptimised scenery addon. So I always remove all Photogrammetry content from my content manager and set my Photogrammetry setting in the Data Options to OFF.

Never had any FPS drop issue on 9-14 hours flight for me other than descending to poorly optimised scenery addon.

I have tried three flights from KSAC to KLAX, In the default Cirrus SR22. Half through the flight it crashes. Checking the event logs I saw this error.

Faulting application name: AFC_Bridge.exe, version:, time stamp: 0x60049820
Faulting module name: AFC_Bridge.exe, version:, time stamp: 0x60049820
Exception code: 0xc0000005
Fault offset: 0x000000000000f9b0
Faulting process id: 0x0x2BBC
Faulting application start time: 0x0x1D9ABA43AE85689

That is to do with your Throttle Quadrant not the sim

Another Crash
function Toggle(node) { if (!window.fullyLoaded) return; var divNode = node.nextElementSibling; // nextElementSibling may unexpectedly return null if (!divNode) divNode = node.nextSibling; if (!divNode || divNode.nodeType != 1) return; // Expand the branch? if (divNode.style.display == ‘none’) { // Change the sign to “-”. var bNode = node.getElementsByTagName(“b”)[0]; bNode.innerText = “-”; // show the branch divNode.style.display = ‘’; } else // Collapse the branch { // Change the sign to “+”. var bNode = node.getElementsByTagName(“b”)[0]; bNode.innerText = “+”; // hide the branch divNode.style.display = ‘none’; } } // Toggle “System” element by default so that its default status is to hide its children function ToggleSystemElement() { var body = document.getElementById(“body”); var anchor = body.getElementsByTagName(“table”)[0]; Toggle(anchor); } // If binary data is present in event XML, show it in friendly form. function ProcessBinaryData(binaryString, binaryDataCaption, wordsFormatString, bytesFormatString, normalFont, fixedWidthFont) { var bodyNode = document.getElementById(“body”); // Add a

at the end of the HTML body. bodyNode.appendChild(document.createElement(“hr”)); // This paragraph (p element) is the “Binary data:” literal string. var p = document.createElement(“p”); p.style.fontFamily = normalFont; var b = document.createElement(“b”); b.appendChild(document.createTextNode(binaryDataCaption)); p.appendChild(b); p.appendChild(document.createElement(“br”)); bodyNode.appendChild(p); // // Show binary data in Words format. // p = document.createElement(“p”); p.style.fontFamily = normalFont; p.appendChild(document.createTextNode(wordsFormatString)); bodyNode.appendChild(p); // Must use fixed-width font for binary data. p = document.createElement(“p”); p.style.fontFamily = fixedWidthFont; var i = 0; var j = 0; var s, tempS; var translatedString; var charCode; var byte1, byte2; // Each character in binaryString is a hex (16-based) representation of // 4 binary bits. So it takes 2 characters in binaryString to form a // complete byte; 4 characters for a word. while (i < binaryString.length) { s = (i / 2).toString(16); // To hex representation. while (s.length < 4) { s = “0” + s; } s += ": "; // DWords representation is simply a rearrangement of the original binaryString // For example, from: // // 0000000002005600000000000f000540 // // (which is 00 00 00 00 02 00 56 00 00 00 00 00 0f 00 05 40). // // to: // // 0000: 00000000 00560002 00000000 4005000f // 8 words per line, 4 DWords per line. for (j = 0; j < 4; j++) { s += binaryString.substring(i + 6, i + 8); s += binaryString.substring(i + 4, i + 6); s += binaryString.substring(i + 2, i + 4); s += binaryString.substring(i, i + 2) + " "; i += 8; } p.appendChild(document.createTextNode(s)); p.appendChild(document.createElement(“br”)); } bodyNode.appendChild(p); // // Show binary data in bytes format. // p = document.createElement(“p”); p.style.fontFamily = normalFont; p.appendChild(document.createTextNode(bytesFormatString)); bodyNode.appendChild(p); // Must use fixed-width font for binary data. p = document.createElement(“p”); p.style.fontFamily = fixedWidthFont; i = 0; j = 0; // Each character in binaryString is a hex (16-based) representation of // 4 binary bits. So it takes 2 characters in binaryString to form a // complete byte. while (i < binaryString.length) { translatedString = “”; // 2 characters in binaryString to form a byte s = (i / 2).toString(16); // to hex representation. // Prefix with ‘0’ until its length is 4. while (s.length < 4) { s = “0” + s; } s += ": "; // Show 8 bytes per line for (j = 0; j < 8; j++) { tempS = binaryString.substring(i, i + 2); // 2 for 1 byte i += 2; s += tempS + " "; // Treat tempS as hex integer charCode = parseInt(tempS, 16); if (charCode < 32) { translatedString += “.”; } else { translatedString += String.fromCharCode(charCode); } } while (s.length < 32) { s += " "; } s += translatedString; p.appendChild(document.createTextNode(s)); p.appendChild(document.createElement(“br”)); } bodyNode.appendChild(p); }


AppName FlightSimulator.exe


AppTimeStamp 00000000

ModuleName FlightSimulator.exe


ModuleTimeStamp 00000000

ExceptionCode c0000005

FaultingOffset 0000000004f9ccb0

ProcessId 0x3e24

ProcessCreationTime 0x1d9afcdadb63e5a

AppPath C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.33.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

ModulePath C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.33.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

IntegratorReportId 2c1c38c8-2697-44ba-b875-baff308ad583

PackageFullName Microsoft.FlightSimulator_1.33.8.0_x64__8wekyb3d8bbwe

PackageRelativeAppId App

I had no CTD for months now with the default A32n.

2 weeks ago I switched over to fly the long-hauls with the default B78X and have nearly every time a CTD when flying over Central Europe. So for example if departing from LOWW (Vienna, Austria) after reaching my cruise altitude it would crash after some minutes.
Or when doing a long-haul just passing Europe like CYHZ–>UDYZ it would crash on cruise altitude over Berlin, Germany.

Had good flights without any troubles in Asia and South America / Central America, though.

Does anyone know why this happens to the B78X and how to avoid it?

I think if you’re getting CTD’s mid flight in a default plane…then its likely scenery related. Just flying over a scenery location (that may have issues) can cause a crash, I think.

Could it be liveries loading on final?

I don’t think that this issue is connected to liveries loading as they would be loaded everywhere else as well? In my experience Europe has just the highest density of quality objects to load so it demands the highest performance and caused many issues in the past. They managed to get it much better over the years and now I face those peak issues again but interestingly airplane related.

It’s a rabbit hole.
I use addon linker and only put in what I need before I load the sim.
Otherwise, most things are just turned “off” to avoid conflicts.
It still happens though

Mep. Had a default sim except for payware scenery and it still crashed on my approach towards CYXU (payware). I was a good 20 miles out and boom…frozen…then crash.
Exception code: 0xc0000005
Fault offset: 0x0000000004f9ccb0
Faulting process id: 0x0x6E94
Faulting application start time: 0x0x1D9D383F3E27942
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.33.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.33.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: 5db42eb0-e8a2-4445-b8bc-0a6c58da4564

None of this means anything. Asobo needs to get their stuff together. What a waste of time.

Im experiencing the exact same thing. Ive not completed a European flight due to crashes in more than a yesr, and just recently last night with Salty 747. The same happened with Asobo 747 after the release of SU 13.

For me it is much better now. Had no problems with CTD anymore and get really beautiful landings with no stutters.

What I did?

Turned off all AI traffic and multiplayer. I recently switched over to using VATSIM. The traffic injected by VATSIM makes no problems, looks better than the in-game AI traffic (lights are displayed correctly, the movements look much more realistic) and so I have a very good user experience now.

My advise to you is to also turn off all msfs traffic and switch over to the VATSIM network which is completely free to use.

Not possible with Vatsim. I signed up years ago with a different email that I cant remember, a different CID and different password. I’ve gone around in circles to no avail.