CTD on Patagoionia bush flying after 1.12.13.0 update

Brief description of the issue:

Any leg of Patagonia bush flying activity crashes to desktop while loading the flight after I hit the ‘Continue’ button to start the leg.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

  1. Start the simulator
  2. Go to Activities -> Bush Trip - Los Cerros to Cochrane
  3. I had completed the first 4 legs. So I get a Continue button on the bottom right
  4. I hit continue. The SIM starts loading and screen shows the map of all legs of the bush trip. Half way through loading, background music stops and CTD

Additional Information:

  • My community folder is clean
  • I restarted the bush trip from the first leg. Same resulted
  • I tried to fly the Alaska bush trip. Same result
  • I manually created a Cub Crafter X Cub flight using the home screen World Map. It worked

Same experience here wanting to continue with leg 8 in Patagonia.

It happens for all bush trips in the sim. Landing challenges are working.

I just reflew 1st leg of Patagonia and it worked. (Already completed full trip). I had restarted 2nd leg before and it wouldn’t close out but I landed at wrong airport 1st so that or just where I started saved from prior sim version may have been the problem.
What I do know is for my setup when I connect little nav map while in this Bushtrip causes CTD, at least I think that’s what is doing it. So I’m thinking maybe they added something to prevent use of any of the plethora of other VFR maps from being used. LNM works in rest of world as I used today in multiplayer and after bush CTDs. Haven’t tried any other maps yet. Have LNM set to launch with game thru addons linker and disabled Community mods to troubleshoot.
But I can confirm leg 1 of Patagonia worked with no mods & no LNM.

2 Likes

I confirm that using LNM in bushtrips causes CTD.
even if you launch LNM after the selected bushtrip is loaded, whatever leg you are on and for all bushtrips.

3 Likes

Just to add to the discussion: I also see these crashes in the latest version 1.12.13.0 doing Bush Trips when LittleNavMap is running with the bush trip .pln loaded. Oddly, Navigraph works fine during Bush Trips. So I don’t believe it’s them attempting to block 3rd party VFR maps, it may just be a bug. Not sure what Navigraph does differently.

2 Likes

3rd party Bushtrips do not seem to CTD.
It may just be a simconnect thing. Advance VFRmap panel doesn’t cause CTD but I haven’t tried any of the other VFR maps that connect through simconnect.

2 Likes

I just experienced this issue with Navigraph running instead of LNM. I also had Landing Rate Monitor running, so that might have been the problem. I am trying it now with Navigraph again to see if it can work with LRM down.

Okay, that was successful. Apparently, both LNM and LRM cause CTDs when a bush leg starts.

Edit: Well, I later discovered that, although Navigraph does not crash MSFS, it is not able to connect to a bush trip. It appears that the ability to use third-party trackers has been completely disabled for bush trips.

Not sure what exactly you mean; Navigraph doesn’t connect automatically, but I was able to fly one bush trip aided by Navigraph by hitting the GPS (“Enable moving maps”) button in Navigraph once I was in flight. Will live track your position on the map.

I might have had a temporary issue, but when I clicked the GPS button, it tried to connect and could not.

Same issue here with LNM and Alaska Bush Trip.
However If I’m doing a regular world flight, LNM does not cause FS2020 to CTD.

Wonder if this is a LNM issue causing FS2020 to crash or a FS2020 issue. I don’t think it’s an intentional implementation as the remedy to CTD seems severe. Sounds more like a bug because most bugs cause MS2020 to CTD.

LNM does not need to connect to the Simulator for CTD to occur. Start LNM. Start Simulator. Manually disconnect LNM from simulator if it is connected. Also disable auto connect option on LNM. Start the bush trip and you will promptly get CTD when you start the bush trip leg. I have a hunch there is deliberate check in the bush flying part of the simulator code (1.12.13.0) to check if LNM is running and crash the simulator.

Why crash? That does not look professional and creates a perception that the simulator code is not stabilizing with successive releases. Instead a co-pilot message can flash to say use of third party nav apps will prevent a possible award at the end of the bush trip?!?

Same here. Never (repeat: NEVER) had a single CTD. I’ve done the first three bushtrips without a problem. I’ve done 1st leg of Alaska-bushtrip, no problem. After a few weeks yesterday I wanted to fly the 2nd leg: CTD during loading. I’ve tried the old bushtrips: same problem. I’ve tried the Alaska 2nd leg as a normal flight with the same aircraft: no problem. I’ve done the following:

  • reinstalled the bushtrip (after emptying the community folder)
  • cleared the rolling cash and made a new one
    but nothing worked. Everything is running fine, only the bushtrips lead to a CTD.

Yes, I use LittleNavMap (with simmconnect). This evening I’ll try without LNM, I’ll report.

Edit: Yes! It has something to do with LittleNavMap. Without LNM everything runs smooth; as soon as I connect LNM the CTD follows. No matter if I load LNM in advance or while flying a bushtrip leg.
I’ve disabled AI aircraft and ships, I load no flightplan --> CTD
In another post it says that there is a problem with SimConnect and the devs are already investigating.
But: If I run GMap (FSWidgets) - that also uses SimConnect - I’ve got no CTD. I’ll submit a ticket.

With today’s development update, bush trips seem to be working as expected with LNM in the background. Just tried. I am able to start the bush trip. Yet to complete. Don’t know what other surprises are waiting to be found in this patch.

1 Like

The CTD problem persists.

I just tried to start all of the bush trip but the same result: CTD at first when i hit the fly button, know when i’m halfway of the flight loading.

These is my hardware devices:
HOTAS WARTHOG (JOY+THRUST)
SAITEK PEDALS
LOGITEK AP panel
5 LOGITEK Intruments panels
15 leo bodnar boards
mouse & keyboards

PS: Before the last update I was good…

I have the same issue. Starting Patagonia Bush Trip with LNM launched always CTDs on the loading screen. When LNM is off, everything is fine.

I know you’re new here, so just to help out – look at the topic title. If it is marked as solved, then it contains the information you probably need to fix your own problem.

For example, in this topic, the Original Poster marked this as solved because it is a known bug with Little Nav Map. The LNM author has even posted here, saying there is a bug and do not use LNM until further notice.

Sure, got it:) I’ve just read last few posts, missing the point.

I’m not a moderator – what a nightmare that would be! :wink: I’m just a simmer like you, but I do my best to help others on the forum by clearing away some of clutter. The hot topics right now are things like terrain spikes, frequent CTDs (crash to desktop) for some users, and issues with the flight models and physics.

It’s a good idea to search for a keyword before posting so that you don’t just become part of the clutter. There is already a HUGE amount of content on anything you can think of – including a whole lot of solutions for many of the issues.

As a fellow simmer, welcome to the forum.