CTD or Freeze when loading into Flight since World Update 3

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
No, I dont use any add-ons, I am just a casual gamer. The folder is empty

Are you using Developer Mode or made changes in it?
No, I even do not know how to switch to developer mode

Brief description of the issue:
The game was perfectly fine before world update 3. I have played for more than 40 hours and probably there is just occasional App crash. But after world Update 3 (UK), I just can not load into flight anymore, the app will either crash into desktop without any error messages or it will freeze forever after the loading bar has completed (I can get into the menu screen). I was hoping the developing team can fix the issue in the following update, but until now, I still cant get the game running at all.

I have reinstalled the entire game several time into different drive and it is not working at all (Yes, I have re-download those 127GB of ■■■■ over and over again). The problem is consistent. I am perfectly fine with all other games except this one. So I am really reluctant to fresh reinstall my Windows System.

I have tried to reinstall my graphic driver several times and it wont work. It is the most recent graphic driver from nvidia.

I have deleted my rolling cache and it wont work

I have set my windows language to English (United States) and it wont work

I have disconnected second monitor and disabled the audio driver, it wont work

I have tried to start my flight from various airports, either super dense or super remorse. None of them works.

I have only 16GB of ram, but the game is perfectly fine before world update 3. So i dont think it is ram problem. Even if it is ram problem, I should at least get into the game and CTD somewhere during flight. But currently I am just forever freezing at the loading to flight screen or CTD during the loading screen.

It is so frustrating to play this game as compared to other games. I dont know what is wrong with the SIM app or it is just me who are having all these problems.

Provide Screenshot(s)/video(s) of the issue encountered:
The game will either freeze here forever or Crash to desktop. Which will happen is totally random. However, when the game is running in windows mode, it tends to crash to desktop while full screen mode, it tends to freeze. But anyway, It is just very random. Once it crashes to desktop, sometimes it will also crash my Chrome internet browsers as well. I am not sure what is the link between the game app and my Chrome internet browser.

PC specs for those who want to assist (if not entered in your profile)
Intel I7 8700K
RTX 2070 Super
16GB ram

Build Version # when you first started experiencing this issue:
The latest version is1.15.8.0.
But I am experiencing CTD and freeze when loading into flight since the world update 3 (UK)

Are you on the Steam or Microsoft Store version?
Microsoft Store Version.

Did you submit this to Zendesk? If so, what is your ticket #?
Not yet.

I’ve been having CTD as well… :crying_cat_face: I;m going to empty the community folder see what happens?

The reason your Chrome Browser also crashes when FS does, might be due to “Hardware Acceleration” turned on in the browser settings. This makes Chrome access the graphics card to render web pages. I recommend to turn it off, as this prevents Chrome to mess with your GPU in the background when playing games that need every available hardware resource.

Another reason might be RAM. Either a failing RAM stick or wrong timings, that might be caused by some sort of overclocking, either automatically or manual overclocking (check your BIOS). FS2020 has issues with overclocked hardware. That’s the most common reason for CTDs.

Other things to consider:

  • Did you install Windows Updates lately? For some users, certain updates cause problems as well (e.g. here). Uninstalling those solved their crashing issues.

  • What are your hardware specs?

  • And what version of Windows are you on (type winver in the start menu, that should show you something like 2004 or 20H2)?

  • Do you play any other 3D games? How do they perform? Crashing as well?

  • Did you try to start a flight without multiplayer traffic? (see screenshot, turn multiplayer to off):


Thus… try to increase your windows virtual memory ( pagefile ) to a max value of at lease 20, better 30GIG and ensure enough free space on disc.

And with ONLY 16GIG RAM don’t have other app open in parallel. In special not such memory eating monsters like a Browers ( Chrome ).

I have has freeze on loading for several days. Would not get past the picture of Paris. No popup warning notice of course (please ASOBO - when something stops or crashes to desktop - give us a message saying why like many other games do.
So , not knowing why I tried loads of things and finally a complete reinstall but after the initial bit it would hang at the same place and not get to download the main grillion bytes. Eventually by chance I logged out of that ■■■■ X-box app and there was the problem !!! It had received an update (quietly and in the background like all updates) and that had corrupted my gamertag ID. So the sim couldn’t progress past start of checks for updates/installs.
Happy that I have solved it - unhappy that I have downloaded the sim again and also that we don’t get given any clues when things stop working.

after the Jan 2022 updates. I start having the same problem. When starting a flight or any other flying option it freezes at about the 80% mark of loading such flight. If I start with my computer disconnected from the internet, it will run.
It seems that when reaching the Asobo site it goes into “iPv4 loopback”
Please somebody help me!

…google maps add-on installed ?

PS: world update 3 is a while ago :joy:

OK well ever since my post a long time ago I have cured the loading problems. Since then it has always been caused by the x-box app on my PC. Usually it updates and then a part of it fails to work. MSFS uses that part to connect many things at startup - then the sim loading fails as well. We can also be loading the sim when that app gets an update and stops - again stopping the sim load-up.
They say the cure is to reinstall a module that is part of the x-box app.
But it is much easier to uninstall and then reinstall the whole x-box app: that takes only a few minutes.
So what I do is select it from the apps menu - delete it - switch off the PC - start PC again - go to Microsoft Store - reinstall X-Box app. It should come back with all your details correct - no logging back in needed etc.
If you are loading and there’s ever any problem, open the x-box app seperately and see if it is showing your tag and so on properly. If it is blank for a few moments and then shows everything correctly I leave it minimised and then start the MSFS.
Welcome to the flightsim community and I hope this helps. And as MichaMMA said there will be some updates of the sim to load so leave plenty of time for that - we are (i think) on version 7 now.