CTD Vanilla game, no plugins or add-ons (SOLVED)

,

SOLVED: The issue seemed to be the graphics driver, went back to an earlier one and Its all good now.

First off I’ve gone thru the extensive troubleshooting steps on msfs zendesk support and even reinstalled my entire game (deleted official and community folders and the actual game), and removed all apps like FSPIUC that may be interacting with the game. Yet after all this I still CTD after about 30 seconds in the main menu.

PC Specs:
Ryzen 5 3600
RTX 2070
B450 MOBO
16 GB 3200Mhz Ram
Windows 10 Pro (latest update)
Nvidia driver (511.23)

1 Like

I know this is an old post but before sim update 8. I installed the new nvidia drivers and did a complete reinstall of the game so it was completely vanilla no add ons etc… However 30 seconds after hitting the main menu I get ctd in normal and safe mode. I have however swapped gpu drivers to studio rather than game but unfortunately still got the same issue. I have contacted zendesk if u have any tips please feel free to let me know because as a frequent flyer this is deverstating

It is your graphics driver, same thing happen to me like a month ago. Reinstalled vanilla game and still CTD. I rolled back driver to I think it was 472 or whatever is closest to that and it worked perfectly. Make sure it’s the game ready driver I assume your on a desktop and not a laptop just use their tool online to find them. Also make sure you aren’t running and intense apps in the background.

Yeah it worked however had issues where I’d installed it so had to uninstall and reinstall on doing that got error when installing and blue screen of death think I’ve resolved BSOD however still getting an error in xbox app???