CTD when connected to the internet

I am having this same problem but I don’t use steam at all, so it can’t be related to steam. I am getting useless answers from support as well. Any advice based on this?

It could be something similar, maybe an account problem. But in my case it is definitely steam related because the store version with the same MS account works without problems.

1 Like

I had the same issue - CTD about 5 secs after checking for updates. The next time it always offered me to start the sim in safe mode, which I never did, I just temporarily disabled my network interface.
Today I decided to give safe mode a try, it started. So I closed it and tried again - problem solved, no CTD, no question for safe mode. I can start the sim from now on without any issues. Weird.

Hello thanks for accepting me, my flight sim version is steam, I have a problem after updating, to v when I try to fly or do any activity when I click the fly button, it stays on the next load page forever, in the task manager it says msfs It does not respond, since the community content is empty, I even started in developer mode, I have reinstalled the msfs from 0 and the same problem continues, I do not know what else to do I am desperate now … if someone knows another possible solution I will I would appreciate it, thank you very much !!

Has there been any more development on this issue?

I have a buddy who works at Microsoft. He pulled up some internal docs surrounding troubleshooting MSFS, but nothing has worked from that angle either. I actually don’t have this specific crashing issue (I own the MS Store version), but a friend of mine does. We have tried logging into his account on my computer where it is known working, and it crashes still. So I agree that it must be something between the link of MS and Steam. With that, we have looked through his Microsoft account settings online and tried removing any data pertaining to Steam, but still no luck. And of course, a ZenDesk ticket was opened, but that got us nowhere.

Again, the issue is as stated in the title of this post; Game purchased through Steam crashes upon internet connection, and has been crashing since the release of SU5. Annoying to put it mildly, and it’s not even my game crashing!

1 Like

Additionally, for what it is worth, we ran a packet capture during the launch of the game, and outside of several TCP resets AFTER the crash, there was nothing seen. Everything looked good, including the TLS handshakes between my friends computer and MS Azure services.

Im having the same issue! Since August and ive been getting the same replies from the Helpdesk. Ucrtbase.dll package broken or something. But whenever i turn the wifi off, the game runs fine. Any development on how to fix? I know this is the same issue as this user: Crash on initial loading screen (Works Offline, but not Online)

1 Like

CTD when internet is enabled; check.
However; this is only true when I’m using my account which I purchased MSFS with.

I was given a tip that I should try to use a ‘family member account’.

I can confirm that works, even with internet enabled. But the downside is; I can’t download my purchased planes and scenery.

I am sure there is something support could do, like reset or delete corrupted files within our online profiles. If not; give us the tools to do so on our own - just like they can on XBOX!!

All this said though; I’m not sure how this would work with Steam sadly.

related to data in cloud: in case of Steam it is possible to remove/replace the cloud data relativ easy… as example see here: Steam - CTD on Startup (after splash screen) - #11 by eaglechlapf6920 . It can fix possible invalid settings, but whether this will fix login issues, I don’t kow.

Sorry for the late answer, I’ve paid full price again to play the store version in the meantime… Altough I would really rather use the steam version still. I have a few things bought on the marketplace and they don’t sync to the store version, even though it’s the same MS account linked to the sim…

I can confirm it definitely seems to be something related to the link of the accounts that has broken with SU5. It also happens after complete reformat and reinstall of Windows etc.

Steam support confirmed there is nothing they can actually do about it except clearing steam cloud cache, but that does not help unfortunately. It seems to be some bug on Asobo/MS site… I just tried reinstalling it after SU7 on a fresh system but it still happens.

As I said multiple times previously clearing the steam cloud does not help unfortunately. Steam support cannot do anything else. I am waiting for Zendesk since July 27th never got an answer other than automated FAQ answers…

Anyone came up with an answer? I have been offline for two days now. Everything was working fine before. Now the moment I connect to the internet the program crash. None of the suggestions seems to be working for me. I am on my third installation.

Hi… and welcome… there are some different answers in this topic and also in other existing topics in forum. Because you not mentioned what you already tried, we can only answer in a very generally way: the worstest case is, that your settings, stored in cloud, becomes corrupt… the easiest case is you have simple have to re-connect in xbox. But there are different cases in middle of that. Just check some topics and then mention what you already tried and so user can give you may be additional hints ( and no: dont re-install a fourth time :wink: )

Hi MichaMMA, I’ve tried just about everything mentioned in this forum and others. I can get the game started, as long as I am not connected to the internet. I am using Steam and don’t have Cloud settings turn on. Reinstalled 3 times, Reinstall windows one, page file increase, etc. It was working fine…went to bed the following day started acting up. Nothing new, no new software or upgrades.

you can may be recheck to be sure: Sign In
And/or also trying clean steam cache ( C:\Program…\Steam\userdata\xxyourusernumberxx\1250410 )

Tried this twice… even downgrade the Nvidia video drivers.

I am also having the same issue from past 3 months and yet to fix it. I tried to login with new id both in SIm and xbox app and it works with online functionality without any issues but only getting the standard edition.

I tried to switch back to original id (used to purchased the sim) when ever sim/world update releases by hoping the issue may have fixed but unfortunately it’s the same result CTD if connected to network.

if nothing of the other hints will help, its may be an issue with the cloud data which you must remove then. There are existing topics in forum how you can do that , e.g. for ms-store

1 Like

Thanks brother finally it works.

Apologies for bumping an old thread, but I thought I’d add to this as I was having a similar issue and I believe I have finally solved it.

I tried downloading the game again since I was having this issue since SU5.

I’m using the steam version but I assume this could also work for Microsoft store version as well.

I deleted all flight sim files I could find as well as the cloud save.

I logged out of the Xbox app and Microsoft store.

I went on the credential manager and removed the xbl tokens (could maybe remove all the xbl credentials, but I only removed the tokens)

Restart the PC.

Login to the Xbox app and Microsoft store again.

Download flight sim again and make sure the cloud save is disabled (might not be necessary to disable cloud save, but I can’t confirm that)

After logging into the game (if you get asked) let the game download the files again.

After the games downloaded, you will be asked to setup necessary settings and from there you should hopefully be good to go.

I’ll need to do further testing, but so far it looks to be okay for me. Hopefully these steps can help someone else in the future that might be running into the same issue.