CTD when loading the menu, cant even get to play


Hello, as the title says the game crashes while loading the main menu, so i cant even get to the menu and try different things. I have the game on steam, i have played multiple times so the game used to work, but now each time i load the game it just crashes before even getting to the menu. I will put a video of it. During the video i did not touch anything (any key or mouse) and at the end the game just crashes to desktop.
(I had to lower the video resolution due to its size, but theres nothing to see but to hear, u can hear the music stopping when it is going to crash)

I could use some suggestions, thank you.

Firstly, not quite clear from your post/video if this is actually a crash to desktop (CTD) or if the sim is locking up at the point where the video clip stops?

Gave you tried verifying the files in Steam? - not sure if this will do any good though.

  1. Removed/renamed your community folder to rule out a dodgy mod?
  2. Run the sim as admin?
  3. Closed any background tasks before running the sim?
  4. Checked if anything else has being updated on your system like a windows update that occurred between the sim working and not working?

After the last sim update I had an issue where the sim would actually CTD just as the UI started to load, in the end I completed a clean install of the sim. If you can wait it might be worth holding off until the next update due out in a few days time.

The exact same issue and exactly like in the video! The installation manager shows up, does something, black screen, then it reappears, music stops playing, app closes without any message of any kind.

I played the game last time before SU5 came out +hotfix. Now I can’t get it to work. Clearly the SU5 is the issue. I cleared my community folder.
Seriously, bugs and errors are one thing, but downloading an update and then not being able to even launch the game that worked fine before, someone should get fired for such a failure…! And no patch for over a month!

This can only happen in Microsoft software - customers are the Q&A and beta testers!

1 Like

Could be a mod issue. Move your Community folder to your desktop and try again.
If it is the case then you need to narrow it down to find the culprit. I will get it mainly with AI Aircraft Im working on or repaints. It will happen if theres a duplicate name, which could be even a folder name.
i.e. I copied my Asobo 787-10 repaints to a new Folder called 787-9 but neglected to rename the folders inside those as well as the files. It was trying to load duplicate Etihad 787-10’s and would ctd shortly after the FSUIPC load screen finished and the loading bar would continue. Would generally be around about where you are having issues in the video.
I find that using MSFS Addons Linker is great for narrowing it down without having to move anything as the mods are on a completely different drive.
Hope that helps.

Sorry for your trouble. I have 3 suggestions.

  1. Empty your community folder to ensure you don’t have a conflict.
  2. Check your hardware to make sure you’re 100% stable. Even if you were stable in the past it doesn’t mean you’re still stable. It’s best to check so at least you can eliminate that from the possible issues. My suggestion is you download OCCT. It’s free and has a number of stress tests for all your components (CPU, RAM, GPU, and total system power). Can your computer pass 15 minutes of all of those tests? The program has temperature sensors to monitor the various temperatures. I also suggest you watch your temperatures while doing the stress tests.
  3. Perform all the things listed on the official post from zendesk. Especially there’s a section about known applications you may have installed that conflict with the game.

Those are the things in your control so if that doesn’t work then most likely the problem is with MSFS 2020 and you’ll just need to wait and hope that some future update will fix things for you.

Good luck.

I had the exact same issue this morning.
I fly the sim every day, have no mods installed, play pure so to speak and I have never had the CTD on loading.
It didn’t seem to matter what I tried the sim would CTD at the exact same spot as MatiR9625.
Until…
Disable the Steam setting for the game ‘Keep Game saves in the cloud’, and rename the ‘C:\Program Files (x86)\Steam\userdata\usernumber\1250410’ folder to ‘C:\Program Files (x86)\Steam\userdata\usernumber\1250410-Old’
The sim will go through the initial setup at which point you can close it down. Take a copy of the renamed folder and put it back with the correct folder name and the sim was working again as it was the day before.

Good luck.

What needs to be pointed out is that all these users had NO problem until SU 5. Gee I wonder where the problem is?

SU5 brought big improvements in data handling but is not compatible with FAT32 or even exFAT. Check first that you are using NTFS and then check that your C&O folders are properly linked at the bottom of your UserCfg.opt file

I’m ■■■■■■■ sick and tired of the ■■■■■■■ ■■■ ■■■■■■ crashes. I can’t even ■■■■■■■ get into the game and it literally crashes after about 2 or 4 minutes after playing it. I’m going to uninstall the game title and never play again if this keeps on happening. It’s not work the $119 to buy the game.

Yet a couple of million aren’t having that problem … there’s lots of possibilties that aren’t down to the sim ranging from 3rd party mods that need updating all the way to really stupid things like fragmented HDDs and untrimmed SSDs.

I get it. Up until SU5 I had these problems. As I explained, you can only control what you can control. Check the things you can control and if that doesn’t fix it then the problem is with the game. There’s nothing more to do but report the problems and wait.

I was so frustrated until SU5. I couldn’t complete more than 10 minutes in a flight before CTD since February. Nobody believed me that the game code was an issue. Lots of people were in this situation. So believe me, I believe you. They fixed my problems which stemmed from using AMD hardware and it seems they broke lots of stuff for Intel/Nvidia users in the process. That’s my guess anyway about what’s going on.

I guess my point is don’t do as I did. Don’t waste coutnless hours trying to find some magic setting that will fix your problems. There isn’t any magic setting. I tried all of them and nothing helped. So do the 3 things I suggested and stop trying other things. It’s not worth the time and energy. The game code has issues. The problem is not with you.

I had exactly the same think happen to me yesterday Mati. I renamed the community folder and rebooted and it did the same. Today I gave it another go, I run my MSFS through steam and this time steam did some sort of update that lasted literally a second. I then ran MSFS and it loaded with no problems, I then added back the community folder, rebooted and again with no problems. For me its amazing what a difference a day makes. :thinking: