CTD with VoloCity SU7

Hey Guys,

Getting a repeatable CTD during loading screen when I try to fly the new VoloCity drone thingy …

Anyone else getting it ? SU7 otherwise appears OK I can load FBW A320nx with latest Dev version and the Heavy Mod 787 with no issues at all.

Haven’t submitted a bug report yet but will do.

I saw another post about a CTD. Does the CTD happen everywhere you start? Have you tried starting up in various places?

Same with me. As soon as I try to start a flight with the Volocity, there is a CTD during loading the scene. It starts loading, and the blue progress bar at the bottom keeps moving - until it reaches maybe 75%, then CTD.


Alsp ctd’ed trying to load into Stockholm (runway).

Anyone getting ctd with volocopter? All other planes loading ok.

Could you please give more information? How did you get a CTD? Where? Were you using third-party scenery/airports/tools when it happened?

1 Like

No third party, community folder empty. From the menu chose volocopter and an airport, departure from runway and had ctd. Any other plane and sim works

1 Like

I haven’t tried different locations but will do - however as noted by others in this thread it happens about 75% into loading screen so there must be some sort of glitch causing it on certain systems.

I hope a root cause can be found!
I just added someone else to this thread who is also experiencing CTDs, too.

1 Like

I have submitted a ticket:

Request #135459 CTD at 75% loading VoloCity Aircraft

… and mentioned that others here are having the issue as well.

1 Like

I have tried from various locations and always CTD

Also CTD tested at various locations. Community full or empty makes no difference. In developer mode change model goes up to the engine start then CTD.

I also get CTD when loading this aircraft at YYZ or other locations nearby. no issues with the other new aircraft yet.

I am also having the same CTD issue with this new aircraft.

I am NOT having any issues with this aircraft, no CTD’s . Seems to operate correctly although it is SUPER SLUGGISH !
Not sure why I do not get CTD’s but I have NO Mods, None… never added anything to my community folder.

I do not want to be rude, but I don’t see how saying “no CTDs” is helpfull. Obviously some of us are so there must be an issue.

I do not consider your comments to be rude but I was only trying to let the OP know that there are some of us that are NOT experiencing CTD’s with the VoloCity aircraft and ONE of the items that could have been a factor was complete lack of MODS.
I also let the OP know that I considered the aircraft in question to be sluggish on my system. So I was, in fact, trying to help with the only “facts” that I knew about “MY” system.

Hopefully, now you see that I was actually trying to be helpful to the OP.

Same issue, CTO on 75% loading. Tested with&without mods&plugins, in safe mode, even reinstalled whole game, updated to latest Win10 - seems like a real bug.

AMD Phenom II X4 965BE + AMD RX560 2GB


This is the generic CTD response I got from MS Support below …

I was about to ask if anyone has tried deleting the Rolling Cache but given @inosak has done a complete re-install and still has the problem sounds like it is a genuine bug.

@inosak - for the sake of completeness did your rolling cache get deleted and re-created during the re-install ?

Safe Mode doesn’t deactivate plug-ins and software additions that allow customization or add new functions to Microsoft Flight Simulator and cannot prevent hardware failure. To find out the cause of the crash, a thorough investigation is required. Please note that our team cannot provide remote assistance to perform these steps.

Before following complex troubleshooting steps, you must imperatively benchmark the sim’s performance in its vanilla state. To do so, we have prepared a handy step-by-step guide to help you restore the sim to its vanilla state: How to restore the sim to its vanilla state. We cannot assist with modded installations, so we appreciate you taking the time to restore the sim and try again.

Why should I uninstall mods?

  • Some mods may have become obsolete

  • Some mods are resource hogs

  • Some mods are not optimized

  • Some mods may contain malware or virus

Why should I uninstall freeware and payware plug-ins?

  • Some plug-ins modify config files without your knowledge/consent
  • Running freeware and payware alongside the sim consumes a lot of resources
  • Some freeware or payware content may become unstable or stop working overtime

Why should I uninstall peripherals?

  • The more peripherals are plugged into your system, the more energy they consume and require
  • Some drivers may have become obsolete or corrupted
  • Some config files may have become obsolete or corrupted

Why should I uninstall free or paid content from the marketplace?

  • Paid content might become obsolete

  • Paid content might not be optimized

Why should I delete the rolling cache?

  • Some cached data may be obsolete or conflicting with more recent data
  • Some cached data may be corrupted

I had rolling cache turned off. After fresh install it was enabled by default and also crashed.

1 Like