CTDs and Power Usage

I’ve had no problems with the sim until the recent UK update. I’ve tried flying in the US as well as the UK. I constantly get CTDs now. While flying I get an audible sound, like the sound of a record play needle dropping on an LP. I know that’s just a symptom and not the cause as it does the same whether I use my sound system or my Bluetooth headphones.

Recent lockup (screen freeze) I checked the Task manager. Although CPU and GPU figures were okay I noticed that under power usage it stated ‘Very High’. I guess that means that my PSU may not be up to it. Seems strange that all has been fine until the recent update.

Windows 10 is set to balanced performance and playing some games in 4K HDR Ultra graphic setting are not causing any problems. Any help please?

1 Like

Couple of things to consider here. Not the least of which is, although everyone always says, “nothing has changed”, when strange things start happening, it is because something has changed that you experience something different. :wink:
Each update brings with it an increased load on our systems. Having been tweaking my system to accommodate flight sims for far too many years, I learned that every update will require some adjustment to my settings if I have pushed my system out to the hairy edge between performance and quality.
We need to be prepared to manage the limited resources we have if we want to run software that is capable of consuming ALL that are available.

Second. Pushing our systems out to that hairy edge has the effect of making them work, hard. One of the components we always neglect is the PSU. All PSU’s are not created equal. Some are very stable under high load and others start to provide messy waveforms. If you consider that power is the fuel that drives the various components in the computer, fuel quality becomes a factor. If you are running a clunky old truck and just need to haul garbage at low speed then who cares what you burn. If you are trying to win a Formula 1 race in a state of the art speedster, it pays to provide the best available fuel.
Unlike a fuel tank, the PSU degrades over time under normal usage. If you are driving it to the max all the time, the degradation is accelerated. The stability of the rest of the system will suffer as the PSU becomes less stable.

The “Very High” power usage is not based on the power being provided. It is based on the power being consumed. It is a measure of the needs of the computing components. Your PSU may be just fine and without doing an analysis of the draw from each component I can not tell you if the PSU is struggling under the load.
If you post your specs on the following…

  • CPU
  • GPU
  • Memory
  • MB
  • Drives
  • PSU (age as well)

We can do a napkin evaluation to see if the PSU may be in need.

1 Like

Thanks for your comprehensive reply. I do push my PC to the max. I guess each sim upgrade can push it a bit further. Below, the information you have requested:

*CPU - Intel Core i7-7700K 4.2Ghz (OC 4.7 I’ve lowered this to 4.5)
GPU - Nvidia RTX2080Ti
Mem - 16Gb (2x8 DDR4 3200MHz Corsair Vengeance LPX))
*MOB - Asuz Strix z270g
*Drives - Samsung 500Gb 850 Evo SSD (Windows 10 boot)
ITB 970 Evo Plus NVMe M.2 (MSFS installed)
*2TB ST2000DM006-2DM164 (older SATA drive)
*PSU - Cougar GX-S 750W 80 Plus Gold

  • Items all 3.5 years old

Wanted to upgrade to 32Gb ram but discovered on MemTest86 that the other two bank were faulty. Tried both 16Gb rams there and they failed but both worked 100% in the other two banks. Will eventually replace mobo with updated but same make, hopefully not screwing W10. Unfortunately no one has them at the moment. PSUs (even good makes) are not too expensive. Might replace that first.

I notice that if I fly local area I get no CTDs. I’m practicing touch and go with the WACO YMF-5 and the new Spitfire.

It’s when I do longer journeys that I get CTDs and/or Freeze frame. I had an idea that maybe MSFS suffers with ‘memory leek’. I have made a larger Page File and on the drive where MSFS is located. Didn’t make any difference.

That’s it. Thanks again for your input

This is nothing to worry about. It just means that the software is giving your hardware a good workout. The ‘very high’ classification is mainly targeted at laptop users who worry about their battery life.

What do you have your virtual memory set to?
It is very common to have CTD when 16GB users have the upper limit set to anything less than an additional 16GB. The sim requires a min of 32GB available thru a combination of physical and memory and available paging.

Memory slots must be used in the correct configuration. You will not be able to use a1 and b1 without having dimms installed in a2 and b2 as well. Just an FYI.

Your 750 W PSU should be OK. If you choose to upgrade though a good quality 1000w is my personal minimum these days.

The memory slots are set correct in a2 and b2 and cofigured in the BIOS as duel channel. My page file is now set to 20Gb (8gb min)

If you decide you want to do the MB upgrade, I think I would buy a 4 stick mem kit first and plug all four in to see if there is an issue with your existing board before making the jump.

Another thing to check is to confirm your CPU is seated properly with no misaligned pins. It has been noted that DIMM slot misreads are often due to poorly seated CPUs. Some guys suggest backing the heatsink screws a touch. If you try that, be sure to carefully monitor the temps to make sure the heatsink is still doing it job.


as already mentioned is these the most useless column in Taskmanager :wink: … more cpu power is of course more consume of energy.

More important for your CTD might be this:

We spoke already about :

Was this settings/increasment is not helpfull ?

If so there must be another reason.
Examples: Overcloacking ( your cpu have 4.2 Base Core, not 4.5), usage of memory XMP mode, some users report issues with Blue-Tooth devices which go in sleep mode, also outdated sound-drivers, etc.

I have been getting this error message lately-

As you can see this can happen even in the flight creation menu screen, but also in the middle of a flight, or during the pre-flight hangar loading screen. I’ve experienced a crash in all scenarios where I get that pop up.

I have tried doing several things including tips in this forum but nothing is working. I recently downloaded a new driver but the first session after the restart/updated driver, I got the same crash error.

Previously I never had that issue before. Nothing’s changed on my end.