CTDs with Carenado Aircraft after World Update 2

Is this the new norm? Or is it all aircraft? Anyway, doing a redownload instead of an “Update” so that it will be done right. Just wondering what everyone else’s observances are. Thanks. :slight_smile:

No CTD here. Tried multiple aircraft and all works fine. Do you have enough memory?

Only tried the Seminole since, worked ok no ctd.

Remove mods, all of em. Try again

Mods seemed to be my woe from about a week ago… hope this helps

Yeah, I do. 32gb of Ram with 11gb RTX 2080ti card, and Ryzen 3900x 12 core processor.

Yeah, I decided to uninstall the whole sim and redownload from scratch. i find that works better sometimes.

Hm, I have a Intel processor and no problems. What about Manual Cache? Rolling Cache? Maybe you need to reset those?

If it does it with the reinstall, I’ll try that. Thanks Jeffrey

Two CTDs out of nowhere. One in the A32NX and one in the TBM. No error message, no warning. Just crash.

Here’s hoping the fresh download reinstall will work better then. Thanks for your report on it. :slight_smile: Hope its fixed for yah as well too

I’ve had some problems updating certain planes, like the Seminole, where the update downloads but fails to update, but yesterday was a new one.

I noticed I had updates for three Caranado planes. I selected all three, hit the update all button, and while finishing the first the sim crashed. I tried this a couple of times, and then gave up, and deleted all three from local disk.

Each one downloaded okay, extracted okay, tidied up after itself, and then crashed. So it took me three more crashes, then three restarts to get all three installed.

Only Caranado Marketplace planes do this.

For what it’s worth, I had the exact same experience. After each update loaded, the sim would crash. With Steam, I have to reboot in order to run the sim again, so it was install an update, sim crash, reboot, reload sim (3-4 minutes) install another update, repeat.

Confirmed its an issue with something in my Community folder. If I rename that, rename the Caranado Arrow, then launch the sim to download it via My Content, it works.

If I rename the Community folder back, and repeat, the sim crashes. Now the painful task of finding out which it may be, and hopefully not multiple mods.