Custom airport package not working

Hello,

So I’ve been following the topic about creating custom airports and I get to the point where I need to put my airport package into community folder, but when I load the sim it simply does nothing, the original airport it’s still there (I read SDK documentation about ticking all deleteAirport options and polygons about removing generated buildings). Any help is really appreciated, since I didn’t find anyone else facing this problem. Thank you.

Did you put the correct ICAO in your airport object?

Yes I did!

I have a similar-ish problem. My airport kinda shows up, but it seems like its overlayed on top of the old one, or maybe everything is doubled? I set up the polygon to get rid of default stuff, so IDK why it looks like I have two airports stacked on top of one another.

Update guys: I made it work. Apparently the sim wasn’t recognizing the name example-airport-icao-name format, so I miraculously tried airport-icao-name format. It worked. Glad to know I was doing things right and hours of work did not go to waste. Thanks guys.

Make sure to tick all checkmarks in the toDelete airport properties

Are those in the polygon properties, or somewhere else?

They are in the main Airport object properties, at the bottom.

1 Like

Oh okay, I see them now. I missed that whole section when I looked before.