DA 62 and fire

After emergency landing because of fire in both engines

1 Like

Moved to #flying:user-screenshot-gallery

Ouch… landed, well done… but maybe you kept throttle on max to go up in the mountains ? In that case, better use a few goarounds to go to a proper altitude ! When max (red) throttle is on too long… you’ll have issues with the engine.

If you dont need this kind of simmer cautions, you could go Options / Assistant and switch on Engine Stress assistant. you won’t be bothered with dangerous engine situations…

Yes I kept the throttle on max to go up. I will try next time to go to options/assistant and switch on engine strees assistant.

According to the AFM, 100% power is 5min limit. Max continuous is 95%.

You can only turn off engine stress damage. There’s no assistant associated with engine damage.

That said engine fire isn’t a result of engine stress, neither in MSFS nor IRL.
Must be something differnt in your settings.

I don´t find on general options /assistant to switch Engine Stress assistant.

Options > assistance options > failure and damage > engine stress damage

You can select engine fire only in the aircraft failures menu.

Perhaps is in this page?

No. Options > assistance (asistencia?) options. The center menu in the option menu.

Furthermore you are using the wrong flight model!!! You have to use modern! (moderno)

About 80% is plenty of power. Keeps you out of the engine damage risk zone and should be fine for most things.


According to the AFM 95% is the correct climb power and for cruise as well.

@MrTommymxr I don’t understand why the engine should overheat and catch fire since the temps are within limits even at 100% power.

No the temps are not in limits. They creep up into the yellow and red. You even get CAS warnings
And why? Well whats the point of the yellow caution area if it doesn’t mean anything?
(yes im aware the NXi doesnt show it)

Are you talking about the default DA62, the modded version or the real one?

the modded version

Ok, I was referring to the real one.


I don’t understand. That’s exactly what I wrote in my initial reply to the OP.