DA40-NGX Improvement Mod (v0.7.5.2, Mar 2 )

Hey there Tommy,

I did another flight this afternoon and this time the autopilot followed the flightplan in Nav mode without any problem. I have included two screenshots to illustrate the situation. I only have some trouble with reducing RPMs on final, when at idle the power increases, that must be some conflicting setting.

Yes I had that too - trying to descend with idle power - made the rpm go up.

1 Like

As it should be.
This is to increase prop drag

This is in the included PDF

6 Likes

The prop mod makes it much more realistic. Keep it. If someone wants it out, you have told them how! Haven’t flown the DA40 for weeks, looking forward to it.

Flying a Piper in real life I made this error, especially after coming from flying a Cessna product. Using a timer definitely helps… but in reality if you run out you start to lose power and you switch real quick LOL and that teaches you to remember.

FAQ as of 22/01/2021
How do I know if the mod is installed
As stated in the Readme, there is grey triangle filling the bottom left of the thumbnail. Here it is in red.

Throttle lever is not moving and Prop RPM stays at 2150RPM.
FADEC Code hasn’t loaded in. Check the Incompatible mod list below.

LOW VOLTS/ALTNR AMPS warning and no Engine indications.
The ModelBehaviorDefs folder isn’t being loaded in. Check the Incompatible mod/livery list below.

Propeller RPM is all over the place.
Your propeller axis is interfering with the FADEC. It can happen that the sensors are jittering. Move your assigned propeller lever or wheel to an end stop. (0% or 100%) This should fix it.

Controlling the DA40NGX seems sluggish, slow and heavy.
We all know how sensitive the planes are in this game. Check if you have sensitivity curve setup in your control settings. The DA40NGX doesn’t need a curve and it is recommended that you fly with a linear curve.

I don’t like the nose wheel steering.
The nose wheel steering can be reverted back to a castering nosewheel here

Unable to takeoff and or the plane rolls and flips uncontrollably
Only the modern flightmodel is supported. Check that you are not using the legacy flightmodel.

Incompatible mod/plugins:
Uwajimaya’s lighting mod: Its included and improved
Kinetic assist: delete simconnect.cfg in your “my documents” folder.

Compatible Career plugins: (please submit)
FSEconomy: Fully Compatible
OnAir: Probbably not due to the larger fuel tanks
AirHauler: Not tested, No complaints as of yet.
SkyPark: Not tested, No complaints as of yet.

Compatible Liveries: (please submit)
DA40 Repaints from BilingualHarp7
Aviators Club livery from Asobo
Test pilot livery from Asobo

Incompatible Liveries: (please submit)

How can I support you?
A like on the original FS Forums post and a like on Flightsim.to is all that I ask.

3 Likes

If you have anything to add, please do. These are what I came up with during lunch break.

2 Likes

FSEconomy definitely works with it. I’ve been flying all over (~60hrs) using the DA-40NGX with no issues.

1 Like

This is my favorite plane in the sim right now. Thank you for this excellent mod. The plane is awesome, has great visibility, fun to fly. The mod adds a ton of realism and functionality. And performance matches the AFM almost exactly.

I am having an issue every now and then with autopilot. I’ve seen others report the same issue with the CJ4. When ascending to a set altitude via VS or FLC mode, the AP will sometimes overshoot the altitude and just keep ascending indefinitely. I’ve found that nothing will get the AP working properly again except clicking the VNAV button a few times.

3 Likes

I will investigate.

Yes, I have this behavior with CJ4 mod but not with DA40-NGX (btw I had only 3 flights)

i just tested it, was not able to reproduce.
Were your altimeters synced?

Yes I experienced this issue when I had both the secondary altimeter and the primary altimeter synced to the same setting. It is intermittent and I can’t figure out what triggers the issue. Seems to happen maybe a third of the time or so when I engage some kind of vertical mode like VS, FLC, or pitch (yes it even happens in pitch mode). The FD in all these cases shows the correct guidance, but the AP is continues trimming the aircraft for climb.
I don’t know if it’s related, but I usually use SimConnect events to manage the AP with some external hardware. I haven’t tried a flight using only the virtual cockpit controls. I know that the SimConnect events don’t work in the CJ4 because of how the mod works, but I assume they should work in this DA40 mod.
Here’s a screenshot of a moment when I was having the issue. In this example, the AP ascended to my set altitude of 4400 feet and then continued ascending. I was trying all kinds of ways of getting it working again using VS, FLC, and pitch modes. At the moment of the screenshot, I had tried setting it to -500 fpm VS mode. Eventually clicking VNAV a few times seemed to get it to work again.

1 Like

Did you reduce the power at the point in your screen shot. I don’t see the FD on as there should be two magenta bars under the two yellow one. The AP looks correct for descent back to 4400, I see -500fpm I see VS I see the blue marker on Vertical rate gauge just below the mid point near the 00 in 6110.

Also ALTS is white meaning the next thing the AP will do is capture the ALT of 4400.

Only suggestion is to press the FD button and reduce throttle at this point.

Thanks for the suggestions. I did try reducing power and that slowed the ascent rate, but didn’t put the aircraft into a descent. I could see the AP still adjusting elevator trim pretty much constantly, maintaining the ascent. The FD was on, but it was far below the horizon and cut off (edit: out of view, I mean), I think. I tried turning FD on and off a few times. In pitch mode, I could see the FD moving up and down properly as I clicked the “Nose Up” and “Nose Down” buttons, but the AP continued its own ascent.

Very strange. Has not happened to me - AP captures ALT, but I mostly use FLC

1 Like

I talked too early… :frowning:
Same problem for me. It climbs forever

Can you explain in detail please!

You open the SimObjects folder.
Copy paste the communist manifesto while listening to 009 sound system dreamscape.
Then you put your right foot in, you take your right foot out, you put your right foot in, and you shake it all about, you do the hokey pokey

1 Like

I am very happy with the plane, there is a tendency to slowly drift to the right, but i am sure that has nothing to do with your model. It has something to do with the logitech extreme 3D that I am using. Thanks for the flight model, it’s a great improvement to the original one concerning flight dynamics. The airplanes have never been so lifelike and the DA 40 gives you the immersive quality of forgetting you are in a sim sometimes. Indeed that effect will be far greater in VR which I will try at some point.

Cheers, Marc