DA62X Improvement Mod (v0.6.2, JAN 07)

did a 1h flight. everything went perfect so far. (havent test deice stuff)

I’m seeing something similar – only able to reach about 43% power on full throttle.

@MrTommymxr By FADEC warnings, do you mean the L/R ECU A/B FAIL messages? I got those when doing the standard voter switches and ECU test checklist items on the runup. I don’t think I got them before or after that though.

I downloaded the latest, today’s version of DA62X and I cannot start the engine; it looks like there might not be enough electricity? Any idea what I did wrong, or is this a bug?

It does the same even after I restarted the “flight”. When I used ctrl + e it tries to start the left engine for some time, and after it stops turning the MFD still flashes. Also there is no problem starting the right engine.

I removed the previous version and placed the new into community, haven’t overwrote anything, will try to reinstall.

Working perfectly for me, as is the updated DA40 mod.

1 Like

Something is very strange, the latest DA40 is working fine for me, but I cannot start DA62’s left engine. Also it looks like the battery is switching on and off when the MFD is flashing, and the left Master switch is on, if I turn of left master when the MFD is off the right doesn’t start but if I flick the left master to on and switch it of when the MFD is on then the right starts.
I have the latest G1000NXI, and restarted the game, changed airports but it still does this

what the hell, some mod is interfering with this, I removed every one of them and it works OK, however I only had couple basic mods like working title g3000 and an airport.

Sorry about this false alarm, and thank you tommy for making this essential mod!

Edit: it looks like I forgot to remove Uwajima’s light mod for DA40 and DA62, and it only caused problems for the twin.

1 Like

Try it without the G1000NXI loaded up, I suspect that’s where your problem may be.

I’ve suffered so many problems in the past due to the NXI that I’ve deleted it. I use the legacy WT G1000 mod instead. It may not be so cutting edge but it is stable.

Some more testing, with results that have me scratching my head.

First of all, I did what you should always do when something isn’t right and removed everything from my community folder except the DA62X, then restarted the sim. Same behavior – only 43% power.

I still had the G1000 NXi installed at this point though, so I figured maybe that was interfering with the DA62X. So I uninstalled that from the content manager and, for good measure, restarted the sim. And, success, now I was able to get 100% power!

So to confirm that the G1000 NXi was the issue, I reinstalled it, restarted the sim, then did the test again. Confusingly, I was now still able to get 100% power.

Very strange. The only explanation I have was that maybe my G1000 NXi was originally in some corrupted state. I did note when I updated it that it only downloaded about 1 MB worth of files. The reinstall was about 4 MB. So maybe there was some file it didn’t update that should have been updated…?

I’ll now reinstall my other addons – fingers crossed that it continues to work. Certainly, I’d recommend to others who are seeing this to uninstall, then reinstall the G1000 NXi.

In a way, this was a cool experience… to do an available power check where you actually don’t get the expected power.

Update: Reinstalled all my other addons in the Community folder again, retested, and I still get 100% power. So whatever the glitch was, it seems to be fixed now…

Sooooo

This happened!

I guess this is what happens when you leave the engine power at 100% for too long… It was oddly tame in handling, I didn’t even need to floor the rudder to be in control, and I managed to go below blueline a few times, but I made the runway. Skill or luck?

Tell you one thing, though, those guys in that red firetruck are useless, didn’t even lift a finger to help!

2 Likes

The DA40 NGX and DA62X create a folder in your MSFS packages folder. I always delete the folder when installing a new version. Learned this from the Airbus H135 project, which often had problems with a newer version, if you didn’t remove the folder. First time you load the aircraft in MSFS the folder get recreated, so does no harm. On my system the folder is located in :-
C:\Users<user name>\AppData\Roaming\Microsoft Flight Simulator\Packages.

1 Like

so what ive done is fail the turbochargers when the FADEC code isnt running.

In my testing i had this problem aswell. I solved it by waiting 30 seconds… well, i thought i solved it…

1 Like

So, for those having issues with the throttles sticking at 43%, I may have quite accidentally found something to help your troubleshooting efforts, because I managed to recreate that issue in a very odd and unexpected way.

By enabling HDR, if you can believe that!

Whether or not HDR hurts/helps people with post-su5 graphical problems was being discussed in another thread, so I decided to turn it on and see what might happen. Well, my sim (or specifically this plane?) lost it’s mind. In VR, I first noticed that I could not see either my stick nor my throttles responding to inputs. It turns out they were, because if I turned my head so I couldn’t see them in my headset, manipulated either control, and then looked back, they properly reflected how they should have looked post movement.

That was odd enough, but whatever, I decided it didn’t matter if I could see them moving as long as they were working, so I continued. Pre-flight complete, taxi to the active, and hit the power for TO, and what do you know, I’m only getting 43% power from both engines.

So I shut her down, turned off HDR, and tried again. The odd “I don’t want you to see me moving” behavior from the controls continued, however, I was back to 100% power on both sides, and was able to successfully fly.

While I don’t understand why HDR settings could cause the sim (or a plane therein) to misbehave, I also cannot dismiss the apparent causal relationship between one event and the other.

If it just so happens that you’re having this odd 43% power problem, and also running HDR, I’d be curious to know if this helps…

Kev

I doubt HDR is causing it.

Dont worry, hot fix in a few min

2 Likes

Fixed the low engine power bug and you can now set the deice fluid level when the plane is on to confirm the changes. The menu is really finicky and this makes it easier

3 Likes

Hey there - cannot get AP (or FD) to work using latest hotfix. Not sure if it’s the latest NXi update that has broken it. Anyone else having the same issue?

yes it works again.
thank you *************

I’ve seen that issue, of tyres sinking into runways, a lot since SU5 came out.

turn the fuel off to stop the fire next time

1 Like

Next time?