DA62X Improvement Mod (v0.9.1.1 Oct 22, SuX)

The mod works with Beta well. All the NXi versions still have “Lean” page instead of Fuel. The dark grey triangle is in the lower left corner of the plane’s icon. Check mod directory DA62X\SimObjects\Airplanes\Asobo_DA62\TEXTURE\thumbnail.JPG - the same icon should appear in your sim.
For some reason picture upload to the forum doesn’t work for me now.

this doesn’t look right.

The wind overpowers the propwash way too much.

2 Likes

Ooh that looks fun. When is the update to give the DA62 thrust vectoring coming out?!?

2 Likes

Is this the new gust system in beta? Yes, it’s definitely not correct, I had issues with other planes too to keep them straight while rolling out. The feeling was like the rudder authority was weakened a lot, that could have been the issue too.

not really, its just he CFD

After flying the DA62X since 2021 with setting Assistance - Failure and Damage on HARD which enables Engine Stress Damage, I noticed that when I started the engines earlier this week, for the first time I heard an alarm and the PFD showed an alert for a fire in the right engine. Both engines still started, but cruise speed was about 130 knots or so instead of the 150 or so that I usually get at 70% throttle.

Thanks to a comment on the DA62X flightsim.to page, I found that damage to the right engine block was at 100 in my State.cfg file. I set these engine damage variables all to 0 in that file and now it’s like I had both engines rebuilt and the DA62X is cruising again like it was new:

DAMAGE_BLOCK:1=0
DAMAGE_BLOCK:2=0
DAMAGE_OIL:1=0
DAMAGE_OIL:2=0
DAMAGE_TURBO:1=0
DAMAGE_TURBO:2=0

I am posting this here In case others are having issues with the engines because I have not found any other way to reset engine damage.

From the Official folder the relative path to this state.CFG file on my drive is:
..\..\SimObjects\Airplanes\Asobo_DA62

What does ESP Off mean?

How do i get the message to go away?

Turn on the ESP :blush:

1 Like

How do i turn it on? lol

hi there,

thanks for your work! great mod.

I just have one issue. I don’t know if its been addressed or not.

I occasionally get the “pitot off” and “stal ht off” errors on my pfd even if I turned on the pitot. These errors normally would just be there for like 20 secs then they are gone. And after like 5 mins, they showed up again. Any tips?

In the DA62X mod, to turn ESP on, press and hold the Gear/Fire Test button for 3 seconds.

4 Likes

Hi,

Firstly, massive thanks for making DA62X - it is a huge improvement over the one that ships with the sim. I’m having a slight issue though, I’ve searched around the forums but can’t see anyone else who is having the same. Basically the aircraft has a tendency to roll to the left. I would say the rate of turn is about 10 degrees a minute. It’s certainly not a deal breaker but to fly the aircraft straight and level slight right pressure is required on the stick at all times. I’m wondering what I could do to treat the issue?

I’ve tried rudder trim and this resolves the issue mainly but then the aircraft is flying in an uncoordinated state.

Any help much appreciated. Thanks!

Are you just loading weight in the pilots seat by any chance? Try evening it out to the right seat if so

Good suggestion. But alas not. 77kg pilot balanced with 77kg pax in the right seat. Also a balanced fuel load with fuel tanks in both mains, nil in AUX. Other than de-icing fluid there is no other weight loaded.

It’s unfortunately more severe than I previously indicated too, banking in the order of 10 degrees within about as many seconds :frowning:

Roll tendency caused by propeller rotation?

This is usually an issue with joystick calibration in my experience. Sometimes people say planes roll to the left, sometimes they say planes roll to the right. it’s always the users joystick.

No, this isn’t P-factor. It’s too significant for that. Reasonable thought though.

Whilst I could see how you could conclude that, I don’t think so. I’ve tried with multiple joysticks, without a joystick at all and the issue persists. With no controller input at all I can release the aircraft from the control of the autopilot and the roll is pronounced and starts immediately - this is with no controller connected at all and no user input from the mouse or keyboard. In addition the issue doesn’t happen with other aircraft as you might expect with an input problem. Thanks for the suggestion anyway, gave me pause to check that everything was calibrated okay and that no spurious input was coming from the joystick. It really has me puzzled as no one else seems to be reporting having the issue.

All I can say is 1, I do not have this issue so logically it cannot be plane related. And 2, when the inevitable post comes along reporting a strong right roll, I will have the poster contact you directly. And it will happen.

If you do use the AP to fly straight and level, what does it look like ??
Meaning is the aircraft flying coordinated and is it wings level ??
My guess is there is a trim error somewhere. Not sure where it comes from, but it must be something on your system. Or an unwanted interaction between the 62 and your system.
I did have something similar once but it was a controller input, one I forgot I still had configured. But you said you had all controllers disconnected.