Daher TBM 930 Garmin Screen Freezes

Daher TBM 930 Garmin Screen Freezes after changing flight plan & approach sequence. I also lost all AP and Altitude settings and VS. I had to fly manually but the controls were unresponsive, even when disabling the Approach button FD & AP.

5 Likes

I reported this to ZenDesk. I power cycled the avionics and the indicators came back initially and then froze again.

Got it, thank you. By far I found the TBM to be the most responsive and accurate of the props to fly so I was surprised to find this glitch.

I agree. I love flying the TBM!

Same here. flying a 45 min hop last night, no cockpit controls no responses but the engine / props kept running. mfd a/c stayed in one spot!

Same problem here. Screen freezes and ap controls do not respond.

1 Like

same here, and a white horizontal line crossed out my PFD

Same thing happened twice yesterday. First time it was fixed when I started descent and cut throttle and activated VS mode. Second time, it seems to fixed when I reset both generators with overhead buttons. But yeah, this is something new.

Dont know if its the same bug but part of the pfd (speed/alt/baro/plane inclination) freezes during last flights. Also the gps 1st person map on the pfd remains blank (brown). It was just before the approach et everything came back to life once the atc asked for a new flight level.

could be related to mods, I got the g3000 et tbm930 by guifarias31.

Exactly the same here. White line across the PFD and ap controls not responsive. Definitely related to the update as have been flying the TBM with no issues until now.

Same here.

This isn’t only TBM problem,

I sent similar problem at first days after release, I had this problem on DA62 with NAV data (fixes) synchro problem, really now I don’t care because if I want save all my bugs and other things in my head, all will be closed already…

My autopilot freezes as soon as I activate the approach.


Display completely screwed on 350i no bank info, skewed horizon indicator and none of the AP info in green updates or changes.

Wierd it came back on its own

Can confirm. Happened after trying to load procedures in flight. Stayed frozen all the way to the ground. The above installed backup altimeter and speed indicator kept going properly. I also filed a zendesk bug report.

Same here.
See Daher TBM 930 problem with Garmin

Oh yeah – this happened to me last night on approach to London in “my” Daher. I made like what I imagine a real pilot might do and landed visually using the backup instruments. But unlike a real pilot I did a terrible job, although with no damage to the aircraft!

I also noticed that the Daher’s autopilot was completely unable to maintain altitude, bouncing up and down by over 500’ in each direction, and attempts to change altitude using VS mode were very flaky. It’s not like it worked before, although TBH last night I encountered more turbulence than I have ever seen as well.

The autopilot in the TBM930 stopped working on two flights while on approach. I tried to enter a new altitude and nothing changed in the altitude window on the PDF. everything was working fine yesterday.

Do you have trim bound to some joystick axis? I had exactly the same problem and had to remove trim binding from one of my X52 dials. Seems like the AP can’t use trim properly when it’s on axis not buttons.