DC Designs F-14 B No Model Just Cockpit

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?

This Is A Store Mod, So No

Brief description of the issue:

I love flying the F-14 but one day when I was Flying the F-14 B, the entire plane was missing but the cockpit

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Intel Core i7 2.3 GHz
RTX 3050 TI

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Please use #bugs-and-wishlist for stock sim (no Third Party Products) reports only. Moved to #community-support

Just because it is a store addon doesn’t mean a mod conflict can’t happen.
They certainly do.
Rename your community folder and start the sim.
It will make a new one and that will eliminate at least anything there as a source.
It could also be from a livery for theF14.

Most likely a conflicting 3rd party mod or livery DC Designs cannot provide customer support on these forums. Please contact via Facebook or via Discord for product support
DC Designs

Hello and thank you. I renamed my community folder and also moved it to a different location on my PC. It made all of my mods disappear. However, the F-14 a and b never was deleted from the menu. I checked windows explorer and it also never made a new folder. I also know it is not a livery issue because all of the liveries don’t work. This is also only on the F-14 B, not the F-14 A.

Thank You

Most likely there was an update (or similar) to the plane that did not complete, and hence the exterior model is missing.

My advice would be :-

(ie what i would do, and have done in the past for similar issues),

is to quit MSFS, then manually delete the plane from MSFS , and when you restart MSFS, it will either re-install, OR you will find it available to re-Install from within MSFS.

Having the mods disappear was the reason for doing so.
That proves it isn’t a mod conflict.
The F14 must have been purchased through the marketplace, which installs it to the Official-One Store folder.
To get your mods back, delete the new community and rename the other back.

Thank you all for your help. For Some reason it worked all the sudden again.

im having the same kind of issue i have the f-14 and f-15 from dc designs and i had a few mods and they worked perfectly fine but when i updated them now they are just low qauility cockpits except for the new super tomcat which functions as normal so i was wondering if you could please help with my situation