DELUX version 92 GB Taking forever

Have been eagerly waiting for this
Pre ordered Deluxe version
On my HP Pavillion i5
Taken from.11 AM to 11.27 to get through75 GB of 92 GB
Help!!

1 Like

Regardless of whether that’s 11am to 11:27am, or to 11:27pm, you’re still doing better than me. I’ve been going since 2pm yesterday my time (it’s now 9:33am 19th for me). I still got 56gb to go.

I’m 9 hours into it on very fast internet - only show 40% complete. crazy

Took around 2 hours for me.

1 Like

3 GB more for me now… 01.AM … West Africa

13 hours of 20mbps and yet to complete

… and once we finish this humongous download… what lies in store for us??

Just woke up to find that while the screen say 45GB remaining its already downloaded 59 GB and hasnt hit the end of the progress bar, though its almost there.
. Its 6.36 AM here . Been downloading since 11.00AM yesterday. :scream:

And then I get to just over 3gb remaining and it turns to ■■■■ - no online fix works. Currently reinstalling from the start. ARGH.

I started yesterday morning the download, everything worked well until 12 pm. Suddenly there was just „please wait…“ and yes, I waited. I waited for the whole night and nothing happened. I have nearly 60gib remaining and can’t download. Can any body help me please?

Sorry for some mistakes, I’m from Germany :upside_down_face:

if a speedtest shows your Internet link is OK, you can try a VPN connection and see how you go. A number of people had had success with that to work around ISP/routing issues.

This is from MSFS2020 Zendesk. The forum isn’t letting me insert links. I have copy-pasted the instructions here.

If you are experiencing slow download speed when downloading Microsoft Flight Simulator, please do the following:

  • In the Windows search bar, type Command and look for ‘ Command Prompt
  • In the menu select “ Run as administrator
  • Enter: netsh int tcp set global autotuninglevel=normal
  • Press enter
  • Reboot your computer

We also recommend doing the following:

  • Close the app and restart it rather than letting it hang. Note: the download will resume from where it left off (you will not have to download from the start again)
  • Avoid using WiFi when updating. Try using an ethernet cable instead.
  • Turn off any security software that may be interfering (UAC, Antivirus, Firewall).
  • Change the installation repository (from C: to D: for instance) or try creating a new installation folder in the drive of your choice (for instance create “MSFS” in your C: drive)

This has helped a lot people. Give it a go.

I already downloaded 40gib, can I now change the installation repository from C: to D: ?

It took me 12 hours (from 6am - 6pm yesterday) all-in to download and install my pre-ordered Premium Deluxe from Microsoft Store. It was 95GB all-told, installed to a 2TB USB drive. Luckily I had the day off work and could hover about monitoring the download. I don’t have a particularly fast BB connection - here in the UK we have fairly average BB, even on so-called ‘high-speed’ connections.

Still, the whole thing went off without a hitch. The sim fully installed, including all the Premium Deluxe content, without me ever having to interfere with the process. I was then able to set up my scenery download caches on an internal drive (250GB and 50GB respectively) - again without any hitches (albeit a bit of a wait for the caches to be formatted by the sim).

I won’t say I wasn’t worried. It’s scary getting a behemoth like this onto your system, always fearing that some unforeseen error or fault, or poor internet connection is going to mess it all up. You don’t get your hand held; you just have to pay attention, slow down and read any instructions that do appear.

All-in-all, I’d say good job. I hadn’t quite banked on needing a whole day to get it all done, but now that it is, it seems to be working fine. The game looks for updates when I fire it up. So far, so good.

1 Like

Finally Downloaded
Tried running the app
Getba small.window saying that mycomputer may not have all.specs so will run with erors
It gets to the part past the ads and the lead video , says Press Any key to start
And then reaches a screen that says 1
Graphic settings. 2. Service 3 Control.Setti gs 4 Assistance… and freezes…
Can click anything on the FS screen

Duestion
Can I now save this on an external drive and move it to another computer??