Discussion + Poll: Hotfix

Same here .Still CTD. Good thing I have school coming up. Won’t have time with this game then but hoping to enjoy it before I go off and this version has been the worse. Was quite stable for me since the launch version.

1 Like

My sim is useless as a bosom on a bull, and I’m pretty unhappy about it, but if I had your system I’d be absolutely steamed.

I hear you mate, but how come it was working with orbx stuff pre SU5 ?

CTD’s are pretty rare, it’s most likely something on your PC. Do you run any additional programs? Close them.

No matter what sim you have all updates sometimes upsets 3rd party devs, but its their responsibility to update after any update not the sim itself.

1 Like

I agree that 3rd party addins are not Asobo’s responsibility at all. I’m an X plane vet and their updates always broke 3rd party things all the time. Time will heal those.

However, the live weather, temp spikes, and atc are issues that are not fixed even though the patch said it would. We need to focus on true Asobo issues and not 3rd party things IMO.


100 % agree

1 Like

Forget not any extra performance gained from the update will put more strain on practically all your hardware and IMO it would seem that something of yours is right in the balance. I’d advise anyone who is still getting crashes to keep an eye on their temperatures etc. especially if they have any overclocks.

Apologize if I missed it here or somewhere else. All my bush trips have been reset to start even though it shows I have completed various legs and shows % complete. When I start it tries to point me back to POI 1. Thoughts?

That seems sensible advice in general, however a few remarks:

  • The ‘balanced’ is only necessary for the FBW Airbus… the DC-6 flies high on ‘high’, so do the few Asobo airplanes I tested…
  • This crashing starts immediately, when the system is still ‘cool’
  • I ran the power ultra high pre-SU5 with nothing like this
  • See others complaining about the same

So I’m not worried about the computer. My bet is on Asobo… :wink:

I’ve said my bit, obviously you know better

Actually I’ll rephrase that … when was the last time you tested your ram?

Sorry for the abruptness.

Same here. Frustration with graphics, but after hotfix, until now no CTD after around 3 hours of different flights.

1 Like

I’m on win11 too and have the last update running. Please try this way
1- Open Store
2- Go to the three dots
3- go to your library (list of your apps)
4- click on Flight Simulator (normally this will open another windows and start downloading update)
If you have no results also you can use the command wsreset
Hope this can help all people with this issue

1 Like

finnaly got time to fly a little and now we got this problem again, what a shame.

Nothing in MS Store. Already tried logoff + restart the PC + logon. Tried open XBox Store for Windows or MS Store first, tried open de sim first. The three dots don’t show option to update.
I not have a update of this sim that download and installed fine on the first try, every update is a headache.

W11 too, I just clicked on update and after a bit of dark magic it told me I needed an update … which appeared and downloaded flawlessly when I loaded the sim.

What was strange for me is that I had to search for MSFS while normally it would just be there. Navigate to your version below and try again

1 Like

Unfrotunately, with SU5 the flight controls wont work either while looking around while using the right-click mouse. The latest patch didnt fix it either.

That sounds nasty … I don’t expect it to work but personally I wouldn’t give up without first creating a new controller profile to try despite it being such a pain.

Downloaded SU5 + Hotfix. I’m not going to actively use the sim (fly) until the weather bug is fixed but the main issues I can see from just quickly opening the sim are:
World Map:

  • All airports have brown marker, no green markers to denote available approach
  • World map will not move when legend tab is open (I swear it did before)

Sim itself: (loaded in the Caravan)

  • I set the Instrument tooltips to delayed but it makes no difference, they appear instantly
  • In the G1000NXi, once you open the flight plan page on the MFD It can’t be closed (even though it says press the button to close, the button does nothing)
  • Weather option seems to have disappeared, and to my eyes NEXRAD does not function
  • Drone Speed does not change, stays at default 4% speed even when slider is moved all the way to 100%

Positives to note:

  • Performance improved: before SU5 I was getting 30-35 FPS with stutters when sitting on the ground at my local airport, now achieving 50-60FPS with minimal stuttering is still present, settings High/Ultra
  • Loading times I estimate improved by 50%
  • The G1000 NXi looks incredible, if all the functions that are listed are actually implemented it will be mind blowingly good :crossed_fingers:
  • No CTD but take this with a grain of salt… I haven’t even left the ground since SU5.

Currently working on another project right now and giving MSFS a rest for a week or two while some bugs are ironed out