Discussion + Poll: World Update VI (1.19.8.0)

Because if you’re already at monitor resolution, being able to render scale > 100 is an easy way to take sharper screenshots for instance, and you can’t set your in game resolution to anything higher than monitor resolution unless you have something like Nvidia DSR enabled.

That, and some people just like how it looks.

You have to go to the store first and update gaming services, then update MSFS. If you try to do both at once, on every update it has never worked for me. Rebooting after every step seems to make the store happier to. Remember once in the game you have not finished updating, Content Manager has new updates, and Market place is where you finally get World update 6.

“In general” doesn’t mean it’s always a problem. But the thing with overclocks and MSFS is that they work just fine… until they don’t. I used to run OCs on both my CPU and GPU, assuming they would help. I learned early on the CPU OC wasn’t helping at all, so when it started getting unstable problems, I dropped it like a hot potato. But sometime in between SU3 and SU4, I started getting random CTDs. Tried a few things, and then I remembered I still had a GPU overclock, so I turned that off, too.

Poof, CTDs gone. And I know from experience that if I turn the OC back on, it’s not a question of if I’m going to start getting them again, just when. Now, maybe SU5 or WU6 fixed that, the only way I’ll know is by testing it. But frankly, despite the fact that I’m using “only” a 10600K with a 2070 Super, I’m actually pretty happy with my performance, so perhaps I’ll try again, and perhaps I won’t.

Especially after SU5, even if I can make a framerate counter spit out a bigger number, I’m not sure my eyes will notice, and that’s the only thing that matters.

I’m off track. Point is, if you (the generic you) are having problems with MSFS, the very first thing to do is turn off the overclocks, but some are too stubborn to do so. And then they have the stones to come on here and blame Asobo.

Yeah but the scaling won’t work past your monitor’s resolution capability so scaling to a resolution higher than what your monitor can display won’t get you anything.

Why … it significantly removes the grain of the picture and the edges that are visible on large screens …

3 Likes

It still makes for a better quality image going greater than 100, even at a cost of frames. The post I linked explains the why.

1 Like

They do updates to the World Updates. For example, the Asobo chief said recently that he’s I
dissatisfied with London as it is in WU3 and plans to rework it.

2 Likes

It actually does a lot since TAA is very sloppy

Render scale 100

Render scale 200

It’s basically a brute force method to get better anti aliasing and sharper interior

5 Likes

What’s PGG? I attempted to fly from VIDP to EDDF in mod 787 and CTD twice in the same area while cruising at FL340. The event viewer says due to grammar.pgg in onestore. My community folder is full but obviously it’s arising from the onestore not community. What gives?

London is the MSFS version of The Bermuda Triangle :slight_smile:

2 Likes

I can’t tell any difference as both screenshots are the same resolution. All I’m saying is just run the game at your monitors highest resolution then use 100 render scaling. That is the best image you will get.

1 Like

I’ve followed the instructions (I only logged out of the Microsoft Store, not my Windows computer account-which is one and the same), and it still doesn’t work. No update for MSFS 2020 in the Microsoft Store. Launching MSFS tells me that I need the Microsoft Store update, etc. I’m running the latest BETA version of Windows 11. I don’t plan on uninstalling/reinstalling MSFS. This is no longer a beta or alpha product so it should behave like a mature, sophisticated app that just works for its users without a lot of convoluted hoops to jump through, IMHO. Update: Also tried with launching Xbox app 1st, as suggested by previous posts in this thread, e.g.

You have to install and launch the XBox app (assume you’re on a PC), only then will the update appear in the store…

I neglected to add that bit of information to my previous post. Doesn’t work after shutting down computer, unplugging, holding down power button to drain circuit electricity, rebooting computer, launching Xbox app, searching for update in Microsoft Store - perhaps I need to add the magical incantation of signing out of the Microsoft Store before shutting down, etc., :rofl:

Edit_Update: Signing out of Store, confirming in running Xbox app, restarting computer, launching Xbox app, signing into Store with account for MSFS, looking for update - FAIL as usual…

Spoke too soon. Two CTDs in a row after changing servers in the menu. :angry:

Is that comment necessary?

If you can’t see the difference, bless you. Don’t look for it :slight_smile:

1 Like

Hello from Madrid, in case it helps somehow I did the xbox app trick, started session on the xbox app, then logged out, then logged in again on the xbox app, update the Xbox on the store and voilá there was the fuc… update!! Good luck

1 Like

Unable to find MSFS update in Store. MSFS update points me to doing a Store update.

image

Clicking OK puts me to the Store below.

image

Store Downloads and Updated do not show any updates for MSFS.

Keyed in Search “flight” and selected MSFS Premium Deluxe which is says I own but there is no Update to select. OR begins.

image

Tried this sequence of events a number of times with reboots each time, but no luck.

Anyone with any ideas???. In addition all store updates done wsreset.exe run as admin. and Xbox App installed. Running MSFS only from a PC.

Interesting followed a post above re launching Xbox App. Played around here but no update. Then went to MSFS app back to store selected Download and Updates and an update for MSFS appeared (this time). Store update completed. Now lets see what the MSFS update does.

Here exactly the same problem.