DLSS option missing SU10 RTX 2080 TI

Yeah as others mentioned this was reported early on in SU10 beta for a lot of people.

I have see it mentioned somewhere else that some people impacted by this had done a registry edit previously to try and improve performance in the Sim. Obviously no idea if that is the case here but some state they fixed it by restoring their backed up registry. Take with pinch of salt as it worked fine for me always in the Beta but then I never did a registry hack so who knows.

OK someone I know tried it doing this. Before doing anything back up your registry I cant stress that enough. This is what they said.

I had both registry tweaks active. Reverted only the one, where you add “TRDLevel=0” in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers (Key TDRLevel deleted) and now it works.

Reboot PC after the edit

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers (Key TDRLevel deleted) and now it works.

Fixed the problem with this.

Very disappointed with both DLSS and DX12. Textures blurry as I would change them to ultra low. I did quick test on the ground:

DX11:
TAA - 56 FPS | Limited by Mainthread/GPU | GPU Load ~98%
DLSS Balanced - 60 FPS | Limited by Mainthread mostly | GPU Load ~70%

DX12:
TAA - 56 FPS | Limited by Mainthread/GPU | GPU Load ~98%
DLSS Balanced - 60 FPS | Limited by Mainthread mostly | GPU Load ~70%
DLSS Ultra performance - 60 FPS | Limited by Mainthread mostly | GPU Load: ~70%
DLSS Quality - 60 FPS | Limited by Mainthread mostly | GPU Load: ~75%

1 Like

Thank you…fixed here as well now !
Much appreciated

( TDRLevel )

Absense of this is the default and these keys must created manually.

Did I understand correct, that reverting of the manually settings for “Timeout of Driver Recovery” fixed your problem that you not get the DLSS option ?

That would be an intressting side effect of that parameter and if that was the reason, it is may be the major cause of user reports. A lot of users fiddle around this parameter.

The default of these parameter is “3” ( recovery on" ) , which should be same as “not present parameter”.

EDIT:

ah, I see now… this is also mentioned within an existing Bug and users confirm same solution ( revert user tweaks ):

( so, sounds for me not like a bug, just a user tweak with side effects )

1 Like

When users “fiddle around” with registry parameters to fix something, they unknowingly assume the responsibility of troubleshooting future problems caused by the “fiddling”. If the Registry change “fixed” their current problem, then the fix needs to be communicated to MS Windows, Asobo, NVIDIA, AMD, etc. so the fix is incorporated into future patches/updates. This then shifts the troubleshooting responsibility back to the vendor/developer.

The alternative is for users when encountering a problem is to first remove any of their “fiddling” even if it seems unrelated to the current problems.

1 Like

These TDRLevel and in special disabling the Recovery, was never a solution. I often warned the users about that ( e.g. CTD in DX11 mode without FPS Cap - #47 by MichaMMA ). The newest post within the former linked bug-topic also describe that : the user got still CTD , but not revered the TDRLevel setting.

For me intressting is the side-effect… I also had not expected that disabling the recovery have an effect on DLSS :slight_smile:

Some users see that popup about “gpu problem happend…” . May be that comes from a different “fiddeling” too :joy:

2 Likes

Strange performance there all being at 60 FPS. You didnt have vSync on did you?

Awesome glad it worked mate!

Mine is clearer in TAA. Tried all the different settings under the DLSS, none did better at the clarity of instruments, seemed to be ok, just not as crisp.

3080TI here…

I knew someone will ask. No I’m using GSYNC with 144HZ GSYNC monitor, i’m locked in RTSS on 141 FPS. I have around 80 FPS in menu.

Can you please explain how to do this workaround? I really need to get DLSS to work! Thanks

Well you only need to do this is you ever edited the registry previously so by the sounds of it you didnt if you are unsure? Or did you? Just checking that is all mate

1 Like

Yeah I didn’t change anything before, figured out it was a problem on my end, thank you!