DLSS option not showing up

Hmmm I’d say it definitely your end though.

I’m now left wondering if your new SSD needs a firmware update.

Hi everyone,

Our QA team would like to investigate this issue further. Please remember that DLSS is exclusive to Nvidia’s RTX line of graphics cards. The feature is currently not available to other lines of graphics cards.

  1. Launch MSFS

  2. Go to “General Options” > “Graphics”

  3. Search “Direct X” version > Select DirectX 12

  4. Then under Anti-Aliasing select “NVidia DLSS”

If you have Direct12 installed and activated but cannot toggle DLSS, update your NVidia Drivers. Be aware that some players only saw the option after upgrading to Windows 11.

If you are still unable to find the option, please submit a request via Zendesk with the subject “Missing DLSS option”.

  • Go to https://flightsimulator.zendesk.com/hc/en-us/requests/new

  • In the drop down-menu, select “I want to report a bug/a small glitch that DOESN’T prevent me from playing”

  • Fill out the field marked by an asterisk - it is important to provide your platform, Operating system, Operating system’s build version and MSFS build version

  • Categorize the bug as “Misc”

  • Use “Missing DLSS option” as the Subject of your bug report

  • Attach to your ticket the following documents:

     1. A Dxdiag
    
     2. A copy of your UserCFG file
    
     3. A screenshot that shows the list of .dll files inside your “Content” folder that is nested inside the game’s installation folder.
    

HOW TO FIND THE USERCFG.OPT FILE

By default, this file is available at the following locations:

Microsoft store version:

  • C:\Users\Username\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

Steam version:

  • C:\Users\Username\AppData\Roaming\Microsoft Flight Simulator

HOW TO CREATE A DXDIAG

  • In Windows, select Start and enter “dxdiag” into the search box on the taskbar. Select dxdiag from the results.

  • In the tool, click on ‘Save All Information’ and wait a few seconds

  • Save the file as a ‘Text File (*.txt)’ on your desktop

  • Attach the file to your response.

We appreciate you taking the time to provide us with this information. We will not be able to provide individual response to your ticket, but we will use each report to investigate the issue.

2 Likes

Hello, and thank you!

Request submitted, #172771, as per instructions. Note that it was instantly marked as “solved”, don’t know why…

image

you got an email which explain the states…

Otherwise see also

1 Like

Hello @anon74745450,

We know the terminology can be confusing, but a Zendesk status of “solved” doesn’t necessarily mean the issue is resolved, it just means your support ticket has been processed. This could mean that your issue has been escalated to the developers for resolution or it is a duplicate of an issue that has already been logged in our internal bug tracking tool.

Please see the FAQ here:

Can you explain the Bug Reports (Ticket) statuses to me?

Below you will find a short description of each status.

  • New: The bug report is in the queue and hasn’t been handled yet.
  • Open: You updated the bug report.
  • Awaiting your reply: Our team contacted you to request more information and is waiting for your reply.
  • Solved/Closed: The bug report has been handled and escalated to our internal bug tracker—Our QA team will then review the information and try to reproduce the issue thanks to the information you provided.

I reported bugs and you closed the ticket but the bug isn’t solved in the sim, why?

Because bugs and issues are tracked in our internal tracker, the status of your Zendesk bug report (ticket) does not necessarily reflect the status of the bug in-game. To know if a bug has been fixed, please refer to the Release notes.

Thanks,
MSFS Team

Thanks Seedy … so it’s an obvious bug, maybe we should all submit a ticket to Zendesk explaining the abuse of our language :wink: :rofl:

1 Like

Can you help a non savy computer guy. How do you rename the Tdrlevel key to Trdrlevelold key. Step by step if possible. I also do not have dlss, with a 2080 card

Thanks

@CausingSloth766

If you aren’t familiar with editing the registry, I strongly suggest you reconsider doing this. I say this for a couple of reasons. One, mistakes in the registry can be hard to fix. Worst case scenario would be that you would have to reinstall Windows. Second, I wasn’t impressed with DLSS. It made things too blurry for me. That said, others seem to be happy with the results so YMMV.

If you chose to do it, here are the steps.

  1. Right click on the Start button and select Run.
  2. In the Run box, type regedit
  3. On the left side, navigate to

HKEY_LOCAL_MACHINE
SYSTEM
CurrentControlSet
Control
GraphicsDrivers

  1. On the right side you will see a list of keys and values. If TdrLevel is listed, you can right click on it and rename it. If it doesn’t exist, you are done. In the upper left, click on File then Exit.

The TdrLevel key is not present by default. It was a hack that fixed a problem with crashes caused by GPUs not responding within the default 2 second timeout. I have no explanation as to why it being present causes the DLSS option to not be available.

1 Like

Changing TdrLevel finally fixed it for me too.

Ok, I’m going to think about it first . Thanks for the help and advice, I greatly appreciate it.

Thanks

Robert

Actually, I just went in to see if I had that TdeLevel key and it wasn’t there, so I guess that is not my issue.

Thanks again.

Robert

What happens if I don’t have the “TDRLevel=0” file???

Well… today’s update seems to have fixed whatever was causing it. Let’s hope it stays like this! Still, i’d like to thank to everyone envolved in helping

1 Like

Well, to my dismay… DLSS option is gone again! :face_with_symbols_over_mouth:

This time I didn’t touch anything, one day it was there, the next it’s not… I’m not gonna bother with it anymore

Workaround according to zendesk - update gpu driver or switch to windows 11

Finally…you recommendations lead to the fact that now i have the DLSS option…thanks !

I am on W11 and do not have the TDRLevel in registry. When I switch to DX12 I only see “AMD FSR 2” as new anti-aliasing setting. I am on 1.29.28.0 version.
Not sure what else I can try.

I’m guessing you have an AMD gpu?

No I am intell i7 with 3080ti, I am using in OXR the FSR although I read this does not matter.

Sorry I can’t help with VR, it’s voodoo tech beyond my knowledge.

1 Like