Download infinite loop

Yep, same problem. Tried every suggestion for days now and endless attempts to download the 17GB file and it just loops at the end. Extremely frustrating. I am at my wits end with this. Actually requested a refund twice now on Steam and was denied. I’m going to escalate this debacle to Fair Trading complaints here in Australia. Microsoft, this is a disgrace!

1 Like

je ni arrive tjrs pas a installer, l’installation se bloque tjrs sur fs-base-0.1.196.fspatch002

j ai trop envie de reprendre les commende mais malheureusement je ne pas

Despite the MS post (cf: “[SOLVED] Download loops”) saying this is now fixed, it isn’t - for me at least. I’ve tried all the user-posted fixes, e.g
netsh int tcp set global autotuninglevel
remove plugins
run netlimiter
etc

What can be so hard about writing a utility to download zipped remote content, validate it, then decompress and install it? How can it be acceptable not to fix a broken version of it in a commercial product for weeks on end, thereby entirely bricking users’ installs?

It amazes me that such an incredible piece of technology as MSFS is, is currently unusable for want of a working file downloader util. Please Asobo can you address this again?? Your fix doesn’t work in all circumstances.

Thanks

4 Likes

Mine got corrected with the MS server fix ( not sure what it was but the looping stopped for me) and the last patch solved my CTD issues for the most part. Like you, I tried everything posted to the community and didn’t have any luck. May be drastic, but have you entertained an uninstall and reinstall? Maybe Russian roulette but it could help…

Good luck in your endeavors!

Version 1.19.8.0 is installed but i can’t get v1.19.9.0 and the Sim doesn’t even start anymore.
After trying to start the Sim today nothing happened. So i figured, there might be an update available in the store.
This update then was stuck in loop. After trying the Xbox App, multiple restarts, logout from the Store … it said, the update was installed and the Sim is ready to go. But still nothing happens.
While trying to solve the update loop, i also changed the timezone and sync settings, i also made sure i have every windows update and i also removed the Commuity folder from the install path.

Still, no update, not even shown, neither in the Store, nor in the Xbox App and the Sim is just dead.

edit: I did also the Store repair and now also the MSFS repair in the Advanced Options (Add/Remove Apps). Still nothing.
edit 2: uninstalled Xbox App, Restart, Reinstall XBox App → next try → nothing → restart → next update try, still nothing.

Since WU6 and the bs with the Xbox App, the Updates on the Sim are a nightmare.
Absolutely annoying.

2 Likes

Same issue. Can’t play the game now because of the download loop. I hope MS comes out with a hot fix on this issue quick!!

1 Like

If everyone starts bombarding them with refund requests on Steam etc. they’ll soon acknowledge the problem. I’ll have to do it through Fair Trading complaint because the game has been installed for more than 12 months. It’s the principle though. No other game I own has this issue or complaints ignored for this long now.

after formating hard drive and fresh install of windows, 5 days of re downloading I managed to finish the instalation at last. Seems to be working… until the next update?

2 Likes

Same problem for me since the release of SU6 until today.

My update was looping on one of the fs-base-cgl patch files (0.1.74), this at 98% through the update. Pause, exit and restart resulted in the entire fs-base-cgl folder structure in the sim being deleted, requiring a new 60GB download.

I make system images of all my drives so restored the entire sim to try again multiple times, also trying most of the official and unofficial potential fixes which have been posted, none of which worked. I even tried connecting through a different ISP (tethered to my phones hotspot), no difference. The same patch file went into an endless download loop every time…

In the end I manually deleted the fs-base-cgl folder myself to let the updater download the whole thing - finally this worked as of this morning.

This is now the 2nd time this has happened to me since I first installed in June. The July update also failed with a similar issue and in the end I reinstalled the whole sim.

I think there are numerous causes of these update problems, some in the network infrastructure and some on the MS servers. The fact that the same file can fail to download repeatedly when others both large and small download fine without corruption does point to something wrong where the files are held or with some of the files themselves. I also question the update and fallback logic in the installer and the lack of any diagnostic tools to pinpoint what might actually be going wrong in detail e.g. a switchable trace log.

I am thoroughly fed up with this whole process now - I’m on a limited speed connection (20mbs) so downloading repeatedly takes a great deal of time and I have a broken product I can’t use all the while. In all the years I have used and programmed PCs and played online games and flight simulators I have never had this much trouble with updating.

3 Likes

Being absolutely annoyed and having tried everything i found (posted in my previous reply), i contacted the Support to try to get help. I told them, what i have already done (copied my posting, wasn’t willing to write that all again) and got a pretty fast reply.
Who would have guessed … it was the same steps you can already find on the internet and i did try even more then that. So very helpful advice in the first place
Just to be save, i took the time (about half an hour) to redo those steps in the exact order they provided me just to be at the same situation like before.
MSFS2020 doesn’t start, the store says 1.19.8.0 and if you try to start MSFS2020 from the stupid Xbox App it just opens the Store with the Gaming Services which are already installed.
This is a f***ing joke to me.

Thanks for contacting Microsoft Flight Simulator Support today.

First, please go through the Microsoft Flight Simulator Support Checklist below to ensure that no essential application updates are waiting to install and that the connection to Xbox services is fully restarted.

CHECKLIST
STEP 1 — INSTALL PENDING UPDATES

** Click on Start (the Windows icon in the bottom left corner of your screen)*
** Select Settings*
** Go to Update & Security*

** Stay on Windows Update*

** Click the Check for Updates button.*
** Wait until the verification is finished.*

STEP 2 — INSTALL STORE UPDATES AND SIGN OUT

** Click the Store icon pinned to your menu bar or type “Store” in the “Type here to search bar” next to the Start icon then select “Open”*
** In the top right corner of the Microsoft Store app—next to your profile icon—click on the Arrow icon or the three-dots menu.*

** In the drop-down menu, select Downloads and updates.*
** Click Get updates then Update all and wait for the updates to install.*

** Once the updates are installed, click on your profile icon in the top right corner of the screen.*
** Click on your email address.*
** Click on Sign out.*

STEP 3 — SYNCHRONIZE TIME SETTINGS

** Go back to Start, then select Settings > Time & Language.*
** Select Date & Time and toggle the “Set time automatically setting" and “Set time zone automatically” to ON.*

** Click on Synchronize your clock to synchronize your system’s clock with an Internet time server.*

** Then click Region, double-check that your country or region is correctly set up (for example if you live in Canada, make sure that the region isn’t automatically set to the USA or vice-versa)*

STEP 4 — LOG OUT OF THE XBOX APP

** To see if the Xbox app is installed on your system, type “Xbox” in the search bar.*

NOTE: If the Xbox app is not installed, skip this step.

** If the Xbox app is installed, select Xbox app then “Open” in the menu.*
** Click on the icon in the right-hand side corner of the screen.*
** In the drop-down menu, select Sign out.*

STEP 5 — LOG OUT OF THE XBOX COMPANION APP

** To see if the Xbox app is installed on your system, type “Xbox console” in the search bar.*

NOTE: If the Xbox Console Companion app is not installed, skip this step.

** If the Xbox Console Companion app is installed, click on Xbox Console Companion app then select “Open” in the menu.*

** In the left menu, click on the cog icon to open Settings.*
** Under “Account”, click on Sign out.*

STEP 6 — UNINSTALL THE XBOX APP & THE XBOX CONSOLE COMPANION APP

NOTE: If the Xbox app and the Xbox Console Companion app are not installed, go to Step 7.

** Click on the Windows icon in the bottom left corner of your screen, then select Settings.*
** Click on Apps.*

** In the “Search this list” field, type Xbox. A list of all the relevant apps will appear.*

** In the list, click on Xbox then click on Uninstall.*

** A pop-up will open. Click Uninstall again to confirm your choice.*

** Next, click on Xbox console companion then click on Uninstall.*

** Click Uninstall again to confirm your choice.*

STEP 7 — REBOOT THE COMPUTER
Do not skip this step, as it is to ensure all changes are correctly applied.

STEP 9 — SIGN IN TO THE MICROSOFT STORE APP

** Open the Microsoft Store app.*

** Click on the icon in the top right corner, then click on Sign in.*

** Sign in with the email address used to purchase Microsoft Flight Simulator*

STEP 10 — DOWNLOAD AND INSTALL THE XBOX APP FOR WINDOWS 10 PC

NOTE: You do not need to subscribe to Game Pass to use the Xbox app. DO NO skip this step.

** Go to https://www.xbox.com/en-US/apps/xbox-app-for-windows-10*

** Click on the DOWNLOAD THE APP button.*

** Follow the installation process.*

** Once the app is finished installing, launch the Xbox App.*

** Click on the icon in the top right corner of the screen, and click on Sign in.*

** Sign in with the email address used to purchase Microsoft Flight Simulator.*

STEP 11 — LAUNCH MICROSOFT FLIGHT SIMULATOR FROM THE XBOX APP

** Click on the Microsoft Flight Simulator icon in the left menu.*

** Click on Play.*

** Sign in to Microsoft Flight Simulator with the email address used to purchase Microsoft Flight Simulator.*

TROUBLESHOOTING
1. Make sure that Xbox Live services are up and running on your Windows 10 device.

** Click on the Windows icon in the bottom left corner of your screen.*

** Click on Settings.*
** Go to Gaming.*
** Go to Xbox Networking.*
** Wait for the diagnostic to finish running.*
** Click on Fix it to force refresh the connection.*

2. Re-install the Gaming Services app via PowerShell:

1. Close Microsoft Flight Simulator
2. In the Windows search bar, type Windows PowerShell
3. In the menu, select “Run as administrator”
4. In the Administrator: Windows PowerShell screen, type the following command and press Enter:

get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers

5. In the same window, type the following command and press Enter:

start ms-windows-store://pdp/?productid=9MWPM2CQNLHN

6. Click Get to install Gaming Services (select Yes if you receive the User Account Control (UAC) prompt)
7. Restart your device and try again.

Same problem here. Download start looping at some point and game stays unplayable until the download system is fixed.

same problem here also.

Im dealing with this issue as well… so yesterday i completely uninstalled the game and attempted to do a fresh install. The same issue is occuring with the new install.

The Installation Manager shows that a package is downloading, but no progress is actually made

image

and the .part file is showing 0 bytes.

I get to 46.7 gigs then crash to desktop, then it crashes when trying to resume.

Same issue. Game is broken. What a joke. Getting a refund

Bonjour a tous , j’ai également eu le même problème depuis la mise a jour world update 6 et quand j’essaye d’installer FS2020 je reste dans une boucle infini
exemple : au début du téléchargement sa décompresse “fs-base-0.1.165.fspatch” et lorsque je suis au dernier fichier “fs-base-0.1.198.fspatch” sa me remet sur le tout premier . Donc je suis plongé dans une boucle INFINIE . Après avoir chercher des information et des vidéos YTB sur se problème j’ai enfin réussi a passer cette étape de boucle infini et mon téléchargement a repris normalement .
Voici les étapes:

1.installer : NetLimiter 4 et regardé cette vidéo : [CORRECTIF FACILE] Microsoft Flight Simulator | Dépannage d’installation

  1. si malgré les valeurs qu’il a mis sa refait le même problème mettez : 300 KB/s
    perso pour moi sa ne fonctionnait pas avec 427.25 KB/s donc j’ai mis 300.
    ( le téléchargement sera plus long mais au moins sa téléchargera votre jeu.)

  2. essayé de désactiver les anti-virus comme : Avast
    (personnellement Avast bloquait les téléchargements et les décompression de certains fichier )

Personnellement toute ces astuce m’ont aidé a télécharger FS2020 donc essayé les.
et n’oubliez pas de réactiver les anti-virus et remettre votre bande passante en illimité lorsque FS2020 sera téléchargé.
Bonne journée et j’espère fort que vous aller réussir a téléchargé FS2020.

2 Likes

Thanks for sharing this or should I say Merci Beaucoup :smiley:

moi ton conseil na pas marcher pour moi mais merci quand même

Thanks so much for this post.

I had tried everything else - but disabling my (AVG) antivirus finally fixed the problem.

I didn’t have to throttle my connection with Netlimiter or anything else once I’d done this - it just all worked.

seems to have several people citing this as having fixed their issues too.

Make sure to disable any antivirus software during the update.

For me I had this issue since Avast was silently blocking msfs access to one of the “LOADING” folders inside the steam lib.

1 Like