Download speeds/server capacity is an absolute joke

…just another thread complaining. They are jesting, right? 1MB/s…


In deed it is a joke, but not a funny one……at least not for the customers……


The speed here has varied from 16 down to 0.02MB/s. Six hours in and at 43%. I am not amused.


I’m averaging about 12 -18 Mbits. Not bad for having DSL speed.

Its an absolute joke, tried to update last night took 6 hours but everyone must be trying to do it so expect the servers to be slow…
I’ve had to reinstall it from scratch as the update decided to crash a number of times. I started the install at 9am and its only on 56%. I’ve even had to use a vpn to get it moving from 1mbs. I’m on a gig connection :roll_eyes: No idea what they have done but before this a complete install was just over half an hour for me.

1 Like

At Max I got ~1.2 MB/s and lowest is 80 KB/s (are you joking??)
Seems MS underestimates the interest in its own product OR doesnt want to pay for better servers. This will take 12 hours+ for ONE update. Sigh.
And @MrPeaUK yeah, the ingame market place updates I too cannot do without VPN, it just keeps resetting the download over and over again. Why it would work with VPN… I have NO idea. Maybe they don’t like my location.


New to MSFS and started download this morning at 10.00am…still at only 25%!!! after reading about all the CTDs with this new update I feel I have wasted £110 this morning. Luckily have still got X-plane 11

1 Like

I’m close to being done, only a few GB’s left for the Marketplace updates. According the date stamps on the folders its been running for about 6.5 hours. It would have been far worse without a VPN connection.

I have to say that in a little over 40 years of gaming, on a number of platforms, it is the worst designed, and performing updater I’ve experienced so far.

Even the worst MMO launch I’ve experienced hasn’t held a candle to this. The GPU issue has a workaround of sorts, but there is very little we can do about slow downloads. MS are the ones to rectify that, and commissioning more hardware, virtual or otherwise, is all they can do. What they have in place simply cannot handle the amount of users attempting to access the data at the same time.

It is now 7 pm, been downloading since 10 am and still at only 39%!!! What a joke you would have thought MS would be the one company to have servers to provide a decent download speed


Really frustrated about the forced update downloads. They call it mandatory update and I have been waiting for two days to complete the 30 GB download with less than 1Mbits/s. My steam shows 167 hours playtime, half of which is the annoying download times. I paid to play and not wait around for forced updates. Really really worst gaming update experience ever. :frowning:


No but this is an absolute joke!!! I am in fiber, I downloaded on DCS WORLD the update of 50 giga in 14 minutes while on your game I am at 4.30 mb / s, I tried last night, in 1 hour I took 2%, and today it’s the same joke, ■■■■ game, you have abused! I want to delete your game forever


Me too paid £110 this morning!!! Never had this problem with X-Plane 11…Doesn’t bode well truly poor service


43G took me 11.5 hrs to download, crawling along at less than .5 mbps for hours, and that’s on a 70mbps line.

I upgraded my internet to fibre and get 360Mb/s but here I am struggling to get 20…what a crock of s**t. Can I get a refund and go back to good old reliable X-Plane 11?

Absolute joke and no sign of it changing. I dread these updates now 8hrs in and only at 69%

1 Like

Wow so quick

1 Like

Same issue here. Support is just replying back with standard answers where no help is available.
I will echo other people here saying this is the worst download manager I have ever seen in a game/simulator. I wonder how this software ever got approved by the test managers.

I will give up trying to download for now, and come back sometime next week to check if there are any improvements.

1 Like

I had fast downloads up until SU3, 200-300MBps on my 300Mbps connection.
Since then I have put up with downloads appearing to be capped to about 30Mbps.
Lastnight I started the SU5,and sure enough I got about 15-30Mbps.
Realising it was going to take ages I had time to think what might have changed since SU3, why was it so much slower etc…
Googling around I spotted the netsh command prompt command which I’m sure I’d tried before with no effect but thought I’d give it a go again just in case, this time however it worked, after a few minutes my download speed picked up to over 200Mbps.

That was at about 7pm UK time so probably right in the peak downloads period.

After that I downloaded all the extras in the content manager and marketplace and was getting close on my 300Mbps.

Somewhere along the line I must have messed up a setting or some other piece of software had messed them up for me.

Open your windows CMD as Administrator

​2- Enter this command and press enter:

netsh int tcp set global autotuninglevel=normal

​3- It will display an “Ok.” when everything is done.

speed picked up after a few minutes of me doing that

and almost every aspect of this game is streamed…

The bing maps data
The photogrammetry
Azure voices
Etc etc

Basically everything.

So that server load issue is a permanent part of the experience.

I am in the middle of downloading the first install, can I still use this fix?