Download stops at 59.97GB remaining, won't download more

I have tried uninstalling and reinstalling the game several times. I start the game and it wants to download the 91GB of content. It always starts fine but then when I get to the point where there is 59.97GB remaining, it stops. I’ll restart the game and then it just says “please wait…” when I try to start downloading again but it never starts downloading again. Help!

1 Like

I got this one. Did you try to free some more disk space on your HDD (FREE DISK SPACE: 150 GB)? I did and after uninstall ad re install it worked. Not sure this was the problem because I did it in the afternoon and I had the problem in the morning. Maybe their servers were just overwhelmed…

In any case, if installation stops do not loose your time by repeating the full install immediatelly like I did …, my internet access is a 1Gbs and when install works it just download and uncompress continuously…

Yes, more disk space. That 150GB is pretty accurate requirement (if not more). It needs room to download, decompress and install. And in the future, this will grow with additional add-ons and objects by MSFS and 3-rd parties. Plus, it needs that room too for downloading scenery on the fly as you fly.

Same problem over here, just at 67,92GB… so frustrating

Thank you. I have 850GB available so that is not a problem :wink:

I went into Apps and Features to see if the program was registered there. It was, I pressed the repair app and then reset app button, and it finished the download.

I was wondering if that would work without wiping out what it has downloaded.

Good to know!

I was going to try wiping out what had already downloaded but can’t find any files. The path that shows in the content manager doesn’t exist from what I can see

I noticed that my disk is running at 100% when it’s decompressing fs-base files. My disk has plenty of space so it shouldn’t be an issue

Same issue

same issue. Tried reinstalling but doesn’t work.

I have the same issue. Gigabit internet, it still isn’t downloading. It’s just stuck on “please wait…” Pretty infuriating, even after uninstalling it and starting the process again. Also, I noticed I can’t even pause the updating, it’s like the button is broken. Weird.

edit; uninstalled everything on the disk and restarted the download, seems to be moving along now.

■■■■■ ■■■■■■! No one has found a solution to this yet…I can`t believe it. Never had problems while downloading games before.

If all the FAQ suggestions about installation problems and what is found on this forum doesn’t work, Aboso is issuing an update for installation problems - we hope!