Downloading updates - many strange indications!

I have to d/l Update 6 and many other free updates I found with Content Manager. I had assumed all would be installed automatically.
I have selected all (some 24GB) and they start to download but then the d/l amount jumps back and keep recycling. Eventually I get a Package Failed!
Even the Update 6, which ran thru’ to nearly complete, is now showing Download Available again.
Is the system broken?

Quit the sim. Remove everything from your Community folder, or just rename that folder something like COMMUNITY.old. Reload the sim. Update everything in your Content Manager. Quit the sim. Copy everything out of your COMMUNITY.old folder back into the new COMMUNITY folder created by the sim. Reload the sim as normal.

Thanks this is about MSFS in XBox.
I don’t think I have the access to delete files from a folder.


1 Like

I find that I don’t even have the Deluxe Upgrade installed!
But when I try to d/l just that, it appears to keep restarting the d/l and later increasing the d/l amount, but jumping back to a reduced amount!
Occasionally it jumps by some 200mb.
After waiting nearly 15mins for 1.25GB to download it reverts to showing the upgrade is not installed!
Please help me.

Have you tried quitting the sim and rebooting the Xbox? Whenever I want to download an update or new content I need to go through this process, if I try to start a download coming from “Quick Resume” I get the same problem as you.

If anyone is having issues with downloading Deluxe and/or Premium Deluxe, please use this topic:

Thanks all. I got into Chat with a MSFS advisor and they solved it for me.
Likely as you suggested, I reset the Xbox and then the downloads all worked.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.