Drone Camera too fast, very unpleasant in VR and other platforms

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

I use the drone camera a lot to “walk around” while in VR. In the new beta the speed of the camera has been doubled, as stated in the release notes. This is very unpleasant in VR, not to mention that at that speed you can’t control the camera precisely enough to walk around in the cabin of an airliner.
I couldn’t find a setting to revert the speed back to what it was before.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Load game, use drone camera => it’s too fast.

PC specs and/or peripheral set up if relevant:

Are you using DX12?


Are you using DLSS?


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I fail to see why they thought 200 was a good default speed, 100 would be better but yeah I agree it’s not great in VR for those quick looks around the plane and stuff.

Since it’s called the “default” value, do you have an idea if or how the value can be changed?

Is it the DEFAULT speed that has changed, or the MAX speed that has been increased , resulting is , say a 50% setting being twice as fast. ?

One can always change the Drone speed … and it saves and remembers it … Its up to you what speed you want, depending on how you use the drone …

The change, has just allowed you to go twice as fast as before – IF you now want to ?


Asobo have coded the new default so no, they need to adjust it I think

How? Where? I couldn’t find it.

1 Like

F1 to make it slower, F2 to make it faster.

Thanks, I guess I’ll have to map F1 and F2 to my joystick then…

1 Like

50% faster is not twice as fast, that would be 100% faster so lets hope they have not made 50% double the normal speed.

Since I often alter my Drone speed. it really does not matter if it’s 50%, 25% or 100% – I just set the Drone Speed to what I want, when I want. – so now I have no idea what the “default” was, or do I really care.

What I see is that I “CAN” now set it much higher, if I wish, than I could before – which is OK with me …

Really low was default, way down near the bottom end of the scale. I tend to crank it up to look around local airports so I can understand why they have raised the default speed.

Topic moved into Beta Miscellaneous as this effects all platforms.

What should be done is the default setting around 100%. It should also save last used setting.


can agree with this. im on flatpanel right now but default speed at 200 is just waaaay too fast. i can just reduce it to my liking but everytime i press reset drone cam view (Numpad5), its just snap back to 200 speed again.

if only there is a way to atleast “save” last drone camera speed would be nicer :grinning:


Is there a way to set our own default that’s retained across flights?

I find that the new default is way too fast for positioning the camera anywhere near the aircraft, and it seems awkward to have to dial it down on every flight just to recover previous functionality.

Not saying you’re wrong, but I do think that this issue is far more significant for VR users than for pancake users. Pancake users are likely to embrace this change as it saves them time, while VR users are likely to get sick and complain.

1 Like

The topic has already been logged for all platforms. :wink:


It’s not only annoying for VR users, mate. It’s extremely annoying when you press the reset position button and the camera goes full mach 5. No idea why Asobo thought it was a good idea but you know, classic…

Absolutely does not save me any time on a flat 2d monitor; makes it very difficult to place the camera instead.

Maybe I’m weird in that I’m using drone camera to position the camera precisely to look at my plane at cool angles for screenshots, not zipping around the scenery randomly?

How do bugs like these randomly show up??? Is there any fix for this? How can we reduce the speed? The drone movement, up/down, right/left is so fast right now, we can’t even do a walk around.

It’s not a bug, it’s in the patch notes for the latest beta patch as default being changed to 200, this was done deliberately.