DV20 Center of Gravity CG abnormal (nose down)

The DV20 is unflyable after the latest patch ( The Center of Gravity is out of the normal range (nose down) and cannot be centered by fuel or payload.
Has anybody used the DV20 with and same issues?


Same here. Just opened flight simulator after patch and have the following:

Yes, same here. Too bad, because I liked using that aircraft the most for my VFR flying. Guess I’ll switch to the DA40 for the time being.

Yes, the DV20 is also my favourite airplane for local VFR flights. But it seems to be not the most popular one, if I look at the number of votes.
Please don’t forget to create a Zendesk ticket.

Since the yelling majority seems to be the “i want big fat airliners to fly straight around the globe…!!!” faction…no suprise…quite sad, though.

Just did my standard test flight with the DV20 (my favorite aircraft in the sim for VFR practice flights) and noticed the abnormal nose-up trim required during the pattern. Now I know the reason at least…

I really wonder how the devs can miss a bug like that… Seems like nobody even did a pattern in the DV20 before release…

1 Like

Edit: fix name problem

I found a workaround:

  • Save your dv20 folder in Official/Onestore
  • Use the previous version tool of windows on Cfg.fsarchive (Right click → Properties → Previous version)
  • Restore the 31/10 version of the file
  • Go to the root folder of the DV20 (asobo-aircraft-dv20)

Then if you want to keep the name DV20 in the sim :

  • Open your layout.json → go to the line of the Cfg.fsarchive replace size value by 40226 and the date by 132486257101899054 Then open the manifest.json and replace the total package size by " 00000000000405242958" . (Edit : Corrected Total Package size for UK update, thanks @CagyAntelope273 and @Szepy2235 )

Alternatively (you’ll get a weird name in the sim menu) :

  • copy/past the content from here

  • Execute the .py file

  • Done !

Relaunch the sim and you’re good!


Would be nice if I would not have reinstalled the DV20. :frowning:
But thanks for your idea!

How can we get this to be fixed in the next update?

Do developers read the forums or should we send an e-mail or a report to developers or support for them to fix it in the next update(s)?

Report on Zendesk and vote to this topic.

All, who has opened a Zendesk ticket please check it. Mine was put in “solved” however the issue still persists.
I’ve reopened the ticket and added the screenshot.

As far as I know, “solved” on a Zendisk ticket just means, it’s in the backlog of the dev team and not that the issue itself is solved.
Nevertheless this should have been fixed by now…

1 Like

Thanks for the heads-up, I was not aware of this. For me Solved means Solved, not “Put in the backlog”. Not in any language. :slight_smile:
I’ve also got some experience around dev topics, never used it as such.
And there was a small update that could have easily hold the earlier version and with that - lo and behold - they could have reverted it back to a working version with around 5 min work.

1 Like

Well if you want the previous version of the file I can help you with that…

That would help me a lot. :slight_smile:

Update : to keep the original name in the sim menu

And yes, every aspect works as you’ve described. Thanks! :slight_smile:

what if there are no previous versions. the filestructure is a little different with Steam-Downloads.

The folder structure is similar, so it’s the file you’ve mentioned. I’ve also done it with Steam installment.
I can send you the working cfg file as Spitap did to me, just PM me if you need it. I suggest to the the first process (manually modifying the files) and keeping the original name of the plane not to cause any issues with addons, etc.