DVD verification


Hope this is the correct forum for my problem (if not please move to correct one):
I switched to WIN 11 several weeks ago. Because of this I had to re-install MSFS.
After a complete download (>80 GB, annoying cost me hours) via xbox store and finish of re-install everything worked fine over a month now. But since yesterday (06/27/2022) the annoying “please insert MSFS Game disc” reappeared. As I have not longer an internal DVD drive, I always have to connect an external drive, take my original game disc and have to do the verification. Under Win10 this process could be bypassed by using a Virtual Drive with a copy of disc1. But this trick no longer works for me under Win11.
It is very annoying to connect external DD every time for startup MSFS. No other application requires this.
Question: Why does it work without disc verification in the past month??
I contacted support, but received only an automatic response that they can not deal with startup problems. For me it seems that people from Xbox Store, Microsoft Store and Asobo do not work well together.
If anybody else had “insert disc” problem and solved it, it would be great to give me a hint.

Maybe one of these DVD using search

or here in support faq

Had it too this afternoon. Went to MS Store, selected ‘update all’ and the Game Pass (or something) required an update.

It hanged on the final bit of the installation, but restarting the store at that point cleared/finished the installment and was okay again to start MSFS normally. Hope it works for you too.

Thanks for your support guys. I saved the requested DVD as ISO file on my SSD. Now I have to click on the ISO before starting MSFS. That solved it for me.
But it is strange that MSFS started for about 4 weeks without any disc verification.