EGKK scenery, randomly drop down to 1 FPS


I currently have the EGGK Ultra custom scenery installed and I noticed that anytime when I’m near it or on the ground, there is a chance that my FPS falls down from 20-30 to 1-2 FPS. From there it stays like that until I close down the sim. Even if I return to the main menu it still stays stuck on 1 FPS.

When I run the devtools peformance counter, it shows that the game is GPU bottlenecked with it taking 350+ ms to render a frame. During this situation, the GPU is locked at 100% while the CPU is having low utilisation.

Sometimes, using the dev tools to teleport myself to another airport would fix the issue. And there are moments where tabbing out and then back in fixes it as well, but that is rare.

Screenshot of devtools:
3c0c0ca8d94a919d4004c6512b3c9582.jpg (

This only happens when flying into Gatwick (EGKK). Nowhere else does this issue happen. It seems to be completely random as well. Sometimes I have no issue and sometimes it happens.

EGKK Ultra freeware scenery
Fenix A320 (Happend in the FBW A320 once as well)
Toolbar pushback

What gets me is that the issue persists even when I back out to the main menu. You’d think that if it was caused by any of the addons, the issue would go away in the main menu. One weird thing is that even though the GPU is locked at 100%, the power draw is lower then what it would normally draw when everything is running fine.

PC Specs:
AMD 5600X
RTX 3080
24GB RAM (Happend with 16GB as well)

Ok, that’s a strange one. I wonder if setting pre-cache to low would also fix some things for me. But it definitely shouldn’t work like this. Pre-cache on the highest level is meant to fix the stuttering. And its the Ultra freeware Gatwick scenery you’re using from I tried that one some time ago and decided it’s really stuttery and it’s performance is awful. And I’ve seen a lot of comments on where others had bad performance too. Something I don’t experience with other 3rd party payware airports. Usually I just use the Origami EGKK scenery. The performance isn’t the best too, but it’s far better than the freeware one in my experience.

Unfortutely removing that addon has not solved it. However I may have discovered a possible fix.

Today I flew into Gatwick again and upon arriving at my stand, the dreaded 1 FPS began again right after I set my parking breaks. I decided to test around again and found out that setting the terrain pre-caching from ultra to low (medium didn’t work) fixed the issue!

I’m not sure how terrain pre caching works exactly but maybe it caused the VRAM to be too high as that is usually almost maxed out whenever I’m around Gatwick (tho its usually always on the high side regardless where I am).

Yeah it looks like you were totally out of VRAM and tapping into system memory. I believe the precaching system is flawed ever since Xbox optimizations were made, and I don’t think DX12 improves it, but I haven’t done much experimenting.

Its not a VRAM issue
Memory Leak Gatwick EGKK , with or without 3d Party scenery - Bug Reports / Install, Performance & Graphics - Microsoft Flight Simulator Forums
I am not even near the limit on VRAM on my machine , the issue just happens after a few minutes , go and look at the screen shots …

Look at the VRAM usage in his photo and think again.

Dear all, i had exactly the same problems that my performance went bad after a specific time or what others were mentioned after long haul flights. I tried nearly everything, but right now its not occurring anymore.


  • Tried the NDU fix, did not work, but its still active

Right now:

  • Turned off the page file in windows
  • Switched off Photogrammetry
  • Switched off Rolling Cache in the Sim (Before switching off deleted it)
  • I have the google maps replacement addon with high LOD enabled and the Cache in the Mod set to 100 GB
  • Traffic in the SIM switched off due to just flying on vatsim

It seems one or more of those mentioned points solved it but not sure why or which one of these. i can maybe try to find out which one.

System is Ryzen 9 5900 x 64 GB Ram and 3090 graphics card.

Graphics settings just set to ultra with vsync on to 60 fps. Resolution is 3800 x 1600 and i have 60 fps with the pmdg 737 when flying and around 40 when at bigger airports with a lot of vatsim traffic, but its running smooth and no degradation.

Some people already mentioned also it can have something to do with the connection to Microsoft / Bing as some people also wrote about the dev on dev off solution.

When flying to or from Gatwick in Vatsim even with standing there a lot of time, no drops.

Using the Origami (paid) version of EGKK; on landing at Gatwick, I get around 28fps but on taking off from the same airport, my frame rate drops to 7fps and stays there, even after take-off. I have a 3080ti graphics card, 10700k processor and 32GB of RAM.

I do not have the same problem taking off from London Heathrow.

I am using the Fenix A320.

This seems like a really weird problem to me!