EGLF CTD When Loading

I have been unable to load EGLF. It constantly crashes the sim whether it is set as departure or arrival. The flight tries to load but fails midway with a CTD. Tried with multiple aircrafts but to no avail. This is the only airport that does this. I tried reinstalling but that did not help. I tried with default Navdata and with Navigraph, same result. The only I did not try is to empty my community folder and only leave EGLF in there. Will try…

Update: After removing everything from Community folder except EGLF it now loads…Time to start the painstaking effort of finding the offending module…Binary search anyone…

Update 2: Traced it down to the Enhanced Airport Graphics Mod. I was running an older version. It is nigh impossible to keep up with updates to so many mods unless you are using apps like Orbxcentral or Contrail…Buying mods without package version management is really asking for trouble.

Same here. Can not load EGLF even not the default airport.
When the screen is loading i get CTD with no warnings.
Could it be something with the UK update??
Please advise

See update 2 on my post. I traced it down to an add on that was out of date. Updating it resolved the issue.