Engine won't run on P-51's with fuselage tank

P-51s that have the bug at the moment:

F-51D Wee Willy II
P-51D Bunny
P-51D Mustang
P-51D Spam Can / Dolly
P-51D ManO’War

All the other ones work fine.

3 Likes

How , where, ask it? I’ve tried to find a path to some customers service, but there isn’t any option for “dlc refund”… Through steam, pc platform, you can ask a refund only for the entire game.

Steam won’t do it without Microsoft ok’ing it as all you buy from Steam are tokens and then they’re used up. You’ll need to contact MSFS support which can authorize a return to Steam.

Do we know any Devs on here? Ping one of them, then they’ll have to see it.

It’s literally robbery. They’re stealing from us! They’ve sold us a faulty product. I know that sounds ridiculous and a bit silly, but in a nutshell that’s the truth of the matter.

2 Likes

The mods immediately come in saying not to ping if you try that.

Then the mods can see it and then can ping a dev! It’s not like the topic is hidden away, or it’s a small bug from another dev…

It’s literally a plane breaking bug for an item we paid for, that they’ve given us.

Please address it or acknowledge it for Pete’s sake…

4 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Are you using DX11 or DX12?

DX12

Are you using DLSS?

Yes

If relevant, provide additional screenshots/video:

What i want is a refund! Looks like this package doesn`t work anytime in the past

1 Like

The mustang you get with the Reno package is also broken now. Completely unflyable.

There is supposed to be a fix live in the latest beta patch! Woooo!

It works now!! I think this bug is finally resolved!

5 Likes

The issue seems to be fixed in the su15 beta, but the Mustang is completely unflyable. It goes all over the place and it has the craziest roll rate I’ve ever seen. On the ground it’s also ■■■■. The tailwheel stays unlocked so taxiing is basically impossible.

I don’t have a problem with controlling it and haven’t noticed anything out of the ordinary with the roll rate. It performs much like it does in any of the other sims that have it. For taxiing keep the stick back to keep the tail wheel on the ground (this is also supposed to lock it) and use small power adjustments.

I know exactly how to handle this plane. Are you on pc or Xbox?

I’m on PC and there’s no issue there. Maybe check if you have downloaded the most recent version of the P-51s on the content manager?

I have the most recent version of the aircraft. I also tried reinstalling the game and the p51. It might be an Xbox problem only.

It’s not. Some of them work some don’t. I’m on PC and there are a couple that are definitely broken. It’s an acknowledged issue.

I’m on PC with the default Mustang and Man o’ war working fine. I’ll run through the rest of them and see if I can reproduce any obvious problems with the others.

Maybe they pushed out an update and I didn’t notice then. They’re working on Man o’ war according to the beta note/forum

This is only working on SU15 beta btw

I just tested all of them, they all takeoff and fly just fine.