Escape characters on taxiwaysigns (i,d,u,m)

Hi there,

I have the following problem that would be really nice if this could be resolved:

When creating a taxiwaysign, I need to have the character “m” on a sign. Example: The TORA sign that says “3045m” in plain black on yellow.

When typing the m, the editor glitches and adds unlimited “mandatory” sections to the sign itself. It gets in a loop and is stuck.

In general, a logic to escape characters would be nice. Otherwise we are not able to use the characters “i”, “d”, “u” and “m” in any taxiwaysigns. Or am I just missing how the escaping is done?

Thank you!

So it seems, nobody knows and/or Asobo is not communicating at all.

Maybe, if you open up a forum for SDK discussion, you should at least have a small team of people available to check over the forum posts once in a while.

A plain “Yes, we are aware of that and will add that some time soon” or “You can escape characters with some character” would help me much more than just letting this sit here unanswered.

Please Asobo, and also Microsoft, learn how to manage a community if you want to develop a game with a community. The SDK Documentation is a complete joke, looking at all the TODOs that are written in there.

Also, there is no communication when and what new features to the SDK will be added. Features and updates just appear out of nothing and one is not able to prepare for newer features at all.

Sorry for this rant, but still hoping to get some reply here.

SDK changes are recorded in the SDK documentation on page 1 when you load the SDK.

Have you tried using a capital M? No idea if that will work, in fact, it probably won’t, but just a thought. The full taxiway definition is in the P3D SDK, although some is not implemented (I just submitted a bug on it today, these three characters x Do not enter, # ILS boundary, = Runway boundary don’t work)

Do you have a spec where the unit character is required? For the US, no unit character is required, distance in 1000 foot increments is assumed.

Just worked on this a few hours ago. Yes, a capital “M” works - it’s simply impossible to escape a character. Since we are trying to be as realistic as possible, we really want to have the correct signage.

I cannot cite a regulation, but in Europe (or at least in Germany) the TORA sign has the unit explicitly stated. This makes sense since this in in meters, while many other data is measured in ft.

Thanks for your answer and also your bug report. But the deeper I get into that topic, the less hopeful I am that this functionality will be added. The taxiway sign logic has been integrated since at least FSX and I guess they plainly took it from there and kept it.

1 Like

They’ve fixed most of the bugs I’ve submitted. Not right away, but usually within 2 releases. I’d totally ask for what you want. They do want this to work.

I’m glad “M” worked :slight_smile:

Edit: And, yep, there it is, when I searched for TORA distance, it came up under the ICAO standards. I’m sure they’ll add that eventually if you ask for it.